[Bug] Upload Failed Unable to Validate

Editor Discussion
I can figure out what has happened but every time i try and upload my map i fails.
Unable to Validate Default Attributes
This all started occurring when i attempted to add additional Game Variants
To in game what variant was picked i created a custom Game Attribute.
After setting this all up my map would no longer publish.
So i removed all the attributes and tried again still same error
Next i removed all the Game Variants but 1 still same error
Then i removed the last Game Variant and still the same answer
Is there any way to get a better description of the error?
So after going to an older version of my map and redoing all the things i had done before.
I was able to upload it successfully
Now for whatever reason i am getting this same error again however i have not changed the Game Variants I'm unable to locate exactly what can not be validated this is such a pain.

We Need Better ERROR MESSAGES its nearly impossible to locate what might be causing this the game plays fine i just cant upload it now.

My theory now is that it has to do with copying XML data, or something in the Data Editor is causing this or its something in the Trigger Editor
So Still getting this issue hoped that perhaps the new patch would have fixed it but here is the thing i want to know what is happening but i cant find the Dump File it says
Upload error then gives me this path:

D:\Documents and Settings\All Users\Application Data\Blizzard Entertainment\Battle.net\Cache\TMP\DCEB084DBF6A9603F27139610F9C643C5591F652353D0B741C2FA0F4321C8687F34B1CbA0B639FF

But when i go to find it TMP is Empty any help?
After Further Testing i have now removed all Data Edits by Converting to a SC2Component list and removing all the Data Related XML files.

After Removing the Data Edits the Size of my File Increased to 24.5 from 24.2

Then i Removed all Battle net info and my File Size Increased Again to 25.6 from 24.5

Then i tried making player 13 Neutral and Player 14 Hostile but still same error Hope we can get this solved
I do also get 2 weird Message when i Select the Game Variant Option from the Map Dropdown Menu
"Unknown attribute id '2000' has been removed from game variant 'Other - Custom'."
"Unknown attribute id '2018' has been removed from game variant 'Other - Custom'."
I have a similar Problem it Uploads 81-83% of the map then the File transfers makes a hazard sound and says failed under download status?
Same issue here. I can't even publish unless i have 2 computer players in the player properties tab.

Join the Conversation

Return to Forum