Achievements and Portraits not loading

Technical Support
1 2 3 12 Next
I cannot get my achievements and portraits to load. I've tried synching my time, double checked that all the proper ports are open, deleted my cache folder in ProgramData and have had no luck.

Please help me Blizzard.
Could you try issuing this command from a 'cmd' window:

telnet 1119

and see if you get an established connection (the screen will probably just clear), or if it hangs indefinitely?

EDIT: In case people are jumping to this thread, please see this sticky for consolidated info:

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\USER>telnet 1119
'telnet' is not recognized as an internal or external command,
operable program or batch file.

Win 7 x64
'telnet' is not recognized as an internal or external command,
operable program or batch file.
Bleh, silly Win7 ;-)

Open your control panel, and click on "Programs and Features".

Then, click on "Turn Windows features on or off" on the left-hand column.

Then, select the checkbox next to "Telnet Client".

Then, try the command again :)
Ah yeah, I forgot it's not on by default in Win7. :)

I get an established connection. Command Prompt clears and sits there.

Thanks for the quick responses by the way!
Hmm, are you having any other issues w/ content loading - or just achievements and portraits?

Can you give it a quick try again - exiting completely and re-running the StarCraft 2 client? try right-clicking your portrait (or, where it "should" be) and select "Change Portrait" -- do any of them load at all?
Content loads fine for me except for achievements and portraits. The only other potentially weird issue I notice is that sometimes it takes an longer time than normal for SC2 to close when I exit it, more than 10 seconds (not sure exactly how long and it probably takes a lot longer than 10 seconds). It will sort of hang at the normal exiting picture.

I have included screen shots of the issues that I'm having:
Hmm, what happens if you launch StarCraft 2 "As Administrator"? I'm wondering if your client might not be able to write to its local cache.
Right clicked the shortcut, Open As Administrator. No change.

I feel a little bad for not mentioning this earlier, but when I load a game with others in it, their portraits don't show either. Campaign progress shows on the main profile screen shows the correct information.
Im having the same exact problem. The thing is that just before the last patch eveything was working fine, achievements and all...

Just tried the "run as admin" thing, and nothing changes. Hopefully you guys can sort this out

Thx for your time
I have the same problem since the new patch too.
However, I'm running XP, so I hope this helps debug the issue a bit.
I tried telneting, but I am not getting a response.
Have you had any further ideas on this Segfalt?
Just a quick note to let you all know we're actively looking into possible reasons for this (obviously, it's not affecting very many people, so that makes it harder to troubleshoot).

So: no real update, yet - but we may have something for you guys to try/test, later.
Thanks Segfalt. Glad to know that Blizzard is actively looking into this. If there is anything I can do to help, just let me know!
Ok, for those that are having achievement/portrait loading issues, we've set up some test files we'd like you to try loading in your web browser.

Please try to load each of these in your browser - if they work, you'll get "Test successful"

Let us know, thanks!
Test successful.
Test successful.
80 Test successful.
c0 Test successful.
Ok, well, that's really odd.

Can you double/triple/quadruple check that you didn't somehow accidentally block your StarCraft 2 application in your firewall software?

The fact that you can load things in a browser, but the client has issues, is confusing.

I'll try to dig up some URLs of actual data (not test data) that the client tries to load, in case it's something specific.
I just turned off Windows Firewall and disabled all shields in Avast (free version). Opened SC2 and the problem persists. I double checked my exceptions for ports 1119-1120 UDP and TCP, 3724 TCP and 6881-6999 TCP in both Windows Firewall and Router are active.

It's a little strange that this started when 1.1.2 was released.
Ok, let's try something.

Can you download these 3 files, from these links:

Once downloaded (assuming you can download them), verify that they are all 831872 bytes in size:

10/28/2010 11:27 AM 831,872 6c8a0a83aed63386d675214c444af1be2e10afe7eae825add344e9c0bc99acba.wafl

If you don't mind finding a sha256sum program for windows, run it against each, and the sha256 should match the filename, e.g.:

E:\Utils>sha256sum.exe *.wafl
6c8a0a83aed63386d675214c444af1be2e10afe7eae825add344e9c0bc99acba *6c8a0a83aed63386d675214c444af1be2e10afe7eae825add344e9c0bc99acba.wafl

(I tested using this one, if you want: or

Please report back your findings: if you can/can't download, and if the size and sha256sums are proper or not.

I'm at work right now and won't be back home for about 5 hours. I'll do these steps once I'm home and let you know how it turns out.

Thank you.

Join the Conversation

Return to Forum