Achievements and Portraits not loading

Technical Support
Prev 1 10 11 12
I started having this problem yesterday as well.
Same issue???
Got the same issue since yesterday. I was playing a Heart of The Swarm campaign mission, and after the mission all my Achievement and Portrait icons have dissapear...

Very annoying.
Same issue, started last night
Exp data unavailable
No achievements...
Same here. Portrait is blank, rewards and achievements aren't viewable, 'Experience Data Unavailable", and no levels.
Gameplay seems unaffected. I can still que up games and ladder, but just these little 'extra' features aren't available.
Fix this please.
Same issues sadly. Started yesterday afternoon.
Same issue, tried to run some of the fixes you posted links for but Im using a Mac OS and the links for downloading are only for Windows. Any links for Mac you guys can post to try and fix the issue?

-Also just noticed that when I go to my profile on the blizz website all my Stats and levels/portraits have been saved on this website post the achievement malfunction. Can this problem be some sort of data relay trouble? Because Blizz seems to be saving data for games played post this problem however I can not access it when in game.
Same issue here.
As per other directions/instructions/suggestions, I had my ISP open up port 1119 UDP and TCP with no change to the problem.
Tried loading with Hotspot, no help for me. Perhaps I missed a step in this fix as it seems to have worked for others. Loaded the free version of hotspot, turned off Avast, loaded SC2, same problem.
I am also unable to access achievements, rewards, my portrait and level.
just noticed this today.
It is a known issue and they are working on it. Here is the thread to follow:
I'm experiencing this issue as well.

Yesterday I could see my portraits and achievements but was unable to change anything regarding either of these (couldn’t change portrait or decal). My primary issue was the “Experience Data Unavailable / Achievements”.

Today my portrait is now blank, the achievements screen never loads, and neither do any of the rewards screens for portraits and decals. I still see the “Experience Data Unavailable / Achievements” but, at least as of last night, I know experience was still working by looking at my bnet profile after a game.

ISP = Comcast
Location = Houston, TX

Any suggestions or just wait it out?
The Achievements and portraits are loading for me in European servers, but not in US ones, it seemed to start randomly. Could it have to do with some new software on the servers?
Update: The XP and achievment systems appear to be back, but portraits and rewards are still not viewable.

Join the Conversation

Return to Forum