Achievements and Portraits not loading

Technical Support
Prev 1 2 3 12 Next
I'm at work right now

Oh... were your other tests, earlier, from work, too? The ones where I asked you download the test files?

If so, please try those again from home. It's crucial to test from the same machine having the issues playing StarCraft 2, and when on the same network :)
Pinky: Hmm, are you using the enUS client? If not, which one are you using? (I pose this same question to everyone/anyone having this issue, too, btw)

One other file to check:

http://us.depot.battle.net:1119/f568e9df747f32dbccc52a8ee4f4950a03d754042b60cf86021c6873adba2b18.ldpt

Your browser will probably render this as text, so just save it to a file.

It should be 535 bytes, and the sha256 should obviously match the filename.

I'm going to check into a few more things and will likely follow up again later, with some more info.

For those having this problem, please specify if you have more than one StarCraft 2 client installed (as Pinky has), and any other "special" specifics (again, like how Pinky stated he's playing from the SEA region on the US servers).

Thanks, guys...
<<I was at home when I ran the download test.>>

I was able to download the files. I checked their size and they are all three 812 KB (831,872 bytes). The ldpt was 535 bytes (535 bytes).

I downloaded the checksum program, opened cmd, navigated to the folder and ran the checks. The results were

C:\Users\USER\Desktop\SC Troubleshoot>sha256sum.exe *.wafl
de0bf409d37c19101fd57a33457301ba2dd7c755f199111ab9a84eaa433cfeb5 *324b75a80c4a6f
04a93b16ab9a54dcfe504c943902fe9dad16705c6a15eae911.wafl
593097dcec7c4a1eaebd2c89e9f0f74f206db6c722296fb836b48978f0b73be0 *593097dcec7c4a
1eaebd2c89e9f0f74f206db6c722296fb836b48978f0b73be0.wafl
6c8a0a83aed63386d675214c444af1be2e10afe7eae825add344e9c0bc99acba *6c8a0a83aed633
86d675214c444af1be2e10afe7eae825add344e9c0bc99acba.wafl

C:\Users\USER\Desktop\SC Troubleshoot>sha256sum.exe *.ldpt
f568e9df747f32dbccc52a8ee4f4950a03d754042b60cf86021c6873adba2b18 *f568e9df747f32
dbccc52a8ee4f4950a03d754042b60cf86021c6873adba2b18.ldpt
de0bf409d37c19101fd57a33457301ba2dd7c755f199111ab9a84eaa433cfeb5 *324b75a80c4a6f
04a93b16ab9a54dcfe504c943902fe9dad16705c6a15eae911.wafl
This is broken. Those hashes should match.

Something is altering the data as you download it.

Who is your ISP? Do you use a proxy? Do you know if your ISP does invasive transparent (intercepting) proxy-ing?
Test Text Files:
http://us.depot.battle.net:1119/000000test.txt
Test successful.

http://us.depot.battle.net:1119/400000test.txt
Test successful.

http://us.depot.battle.net:1119/800000test.txt
80 Test successful.

http://us.depot.battle.net:1119/c00000test.txt
c0 Test successful.

File Size Verification:
831,872 324b75a80c4a6f04a93b16ab9a54dcfe504c943902fe9dad16705c6a15eae911.wafl
831,872 593097dcec7c4a1eaebd2c89e9f0f74f206db6c722296fb836b48978f0b73be0.wafl
831,872 6c8a0a83aed63386d675214c444af1be2e10afe7eae825add344e9c0bc99acba.wafl

Checksum:
324b75a80c4a6f04a93b16ab9a54dcfe504c943902fe9dad16705c6a15eae911 *324b75a80c4a6f04a93b16ab9a54dcfe504c943902fe9dad16705c6a15eae911.wafl
593097dcec7c4a1eaebd2c89e9f0f74f206db6c722296fb836b48978f0b73be0 *593097dcec7c4a1eaebd2c89e9f0f74f206db6c722296fb836b48978f0b73be0.wafl
6c8a0a83aed63386d675214c444af1be2e10afe7eae825add344e9c0bc99acba *6c8a0a83aed63386d675214c444af1be2e10afe7eae825add344e9c0bc99acba.wafl
1. Iowa Telecom (2 Mbps DSL)
2. No.
3. Unknown.
Daskar, could you try downloading this one, again:

http://us.depot.battle.net:1119/324b75a80c4a6f04a93b16ab9a54dcfe504c943902fe9dad16705c6a15eae911.wafl

and run the sha256sum on it?

If the hash does not match the name again, please download this URL, instead:

http://us.depot.battle.net:1119/324b75a80c4a6f04a93b16ab9a54dcfe504c943902fe9dad16705c6a15eae911.zip

unzip the file, and then run a sha256sum on it.

Thanks.
Actually this problem is affecting a LOT more people than you know.
Actually this problem is affecting a LOT more people than you know.

Well, then, I'd like to know :)

For those it's affecting, please perform the tests I listed - mostly on the first page.

Thanks!
Check from the first link:

C:\Users\USER\Desktop\SC Troubleshoot>sha256sum.exe *.wafl
de0bf409d37c19101fd57a33457301ba2dd7c755f199111ab9a84eaa433cfeb5 *324b75a80c4a6f
04a93b16ab9a54dcfe504c943902fe9dad16705c6a15eae911.wafl
593097dcec7c4a1eaebd2c89e9f0f74f206db6c722296fb836b48978f0b73be0 *593097dcec7c4a
1eaebd2c89e9f0f74f206db6c722296fb836b48978f0b73be0.wafl
6c8a0a83aed63386d675214c444af1be2e10afe7eae825add344e9c0bc99acba *6c8a0a83aed633
86d675214c444af1be2e10afe7eae825add344e9c0bc99acba.wafl

Check from the 2nd link (zip file):

C:\Users\USER\Desktop\SC Troubleshoot>sha256sum.exe *.wafl
324b75a80c4a6f04a93b16ab9a54dcfe504c943902fe9dad16705c6a15eae911 *324b75a80c4a6f
04a93b16ab9a54dcfe504c943902fe9dad16705c6a15eae911.wafl
593097dcec7c4a1eaebd2c89e9f0f74f206db6c722296fb836b48978f0b73be0 *593097dcec7c4a
1eaebd2c89e9f0f74f206db6c722296fb836b48978f0b73be0.wafl
6c8a0a83aed63386d675214c444af1be2e10afe7eae825add344e9c0bc99acba *6c8a0a83aed633
86d675214c444af1be2e10afe7eae825add344e9c0bc99acba.wafl
Daskar, your ISP (or something on your network) is mangling the data that is being sent to you. This is evidenced by the fact that the raw file is mangled, yet the zipfile is clean.

It could be your ISP, or possibly some anti-virus software you are running, that is falsely thinking there is a trojan (or virus/etc) in that particular StarCraft 2 data file.

I'm not sure what to suggest you do, short of contacting your ISP and asking if the do any sort of intrusive proxy-ing of web traffic.

You could also try briefly shutting off your anti-virus software, and running StarCraft 2.

Lastly, you can try copying that file (the one out of the zipfile) to

C:\ProgramData\Blizzard Entertainment\Battle.net\Cache\32\4b\

(assuming you're on Win7/Vista), and seeing if SC2 will run.
I don't have a 4b folder in the Cache\32\ folder.
I don't have a 4b folder in the Cache\32\ folder.
Go ahead and create one, and place the file in there :)
K, just wanted to be sure you were aware before any modifications. :)

So after creating the folder and placing the file in there, I can see my Roach portrait, but I cannot navigate the rewards or achievements sections.
I'm following along. I didn't have the 4b folder either, so I created it and placed the unzipped hash in it. I got back my portrait, but none of the other portraits are available nor are the achievements.
Interesting... well, since these files are somewhat related, it's possible the client decided to not copy any of them, if one of them fails.

So, try placing the other two files in their respective C:\ProgramData\Blizzard Entertainment\Battle.net\Cache sub-folders, as well:

593097dcec7c4a1eaebd2c89e9f0f74f206db6c722296fb836b48978f0b73be0.wafl
goes in: Cache\59\30\

6c8a0a83aed63386d675214c444af1be2e10afe7eae825add344e9c0bc99acba.wafl
goes in: Cache\6c\8a\

Create any of the sub directories you need, if they are missing.

Join the Conversation

Return to Forum