100% cpu use after logging in to browse maps

Editor Discussion
I didn't find an equivalent forum on the eu site, so I'm posting it here. Also, I searched for a solution and didn't find any threads with replies pertaining to this particular problem so I'm making this one in the faith that it is an unanswered/undiscovered issue.

[the problem]
When I log in through the Open dialog to browse the battle.net map repositories, the cpu usage of the editor jumps to 100% on all cores and stays there indefinitely until I force end the process (I have tried waiting for over 10 minutes on one instance). I found that this happens even if I am already logged in (by using the options or other parts of the editor that require it) and regardless of whether I have a map open or what region is selected.

Specifically, the list populates itself up to a point (not sure if it reaches completion) and then the cpu usage problem occurs.

[temporary solution]
It can be avoided if the process is placed on a cpu affinity of one core. I have a dual core processor, so I'm assuming that reducing affinity so that at least 1 core is left free prevents locking up. I tried lowering the priority of the process but it has no effect. For those looking for a solution, you can change the affinity of the process through the windows task manager by right-clicking on the process name and selecting "Set Affinity...". Do this after starting the editor and before attempting to log in/browse maps.

After running it at single-core affinity, maps can be selected and downloaded normally, albeit slowly (while the interface is usable, it still feels sluggish).

I am running win-xp sp2 with a core2duo at 3ghz and 2gb of ram. The rest of my specs are adequate to run sc2 at about medium quality settings without lag (I usually run it windowed at low and get a steady 60 fps). I am running 2.0.9 patched yesterday and didn't use the editor prior to that (for a long time at least). As this seems to be a cpu/code issue, I won't include more information unless asked.

Thanks and please look into this as it might make the editor impossible to use for those who can't troubleshoot it on their own.

Edit: threads apparently pointing to the same issue:

Edit: added clarifications for those looking for a solution
I'm also getting this on a Core 2 Duo, I'm on Win 7 with 4GB of RAM though.
Same issue here on Win7 Ultimate x64, with an i5-2500@3.3 GHz and 8GB of RAM.
Setting affinity to fewer cores helps a little bit, but after a couple more seconds of the list loading, the program freezes, and I cannot even view the list of maps. The program always ends up freezing and not responding when loading the map list, no matter how I set the affinity.
I've just tried using the editor for the first time today, and am having this exact problem.

As soon as I login and try to load the list of any "battle.net" maps through the editor interface the program becomes not responding, and chews up my CPU.

Setting the affinity doesn't appear to help for me.
If I set it to two cores (down from 4), it'll just sit using 50% CPU, but still remains completely unresponsive.

I am running a Intel Core i5-2500 CPU (3.30ghz)
Win7 64bit
NVidia GeForce GTX 460. (Driver Version: 337.88)

I've also tried a "Scan & Repair" of StarCraft 2. This has not helped.

Any assistance would be greatly appreciated.
I am having this problem as well; my computer is totally new, I don't think it's a spec issue, but here they are:

Win7 home 64 bit
NVIDIA GeForce GTX 760
intel i7-4770K.

As soon as I log in, populates some of the list, the window and stuff is movable but everything inside the program is impossible to use/nonresponsive. As above, help would be appreciated.
thanks for sharing this subject. I had to update because of my previous computer HP.

I now have an HP Envy h8-1400z Desktop with 2x, 3x and even 4x what is recommended let alone required to run this game. I had problems from day one with this computer and still have "Performance Alert's" popping up left and right saying, "100% of at least one CPU" overload.

Operating system - Windows 8 (64)
Processor - AMD FX-8120 eight-core processor [3.1GHz, 8MB] (started with 6 core. factory upgrade)
Memory - 6GB DDR3-1600MHz
Hard drive - 1TB 7200rpm
Graphics card - 1GB AMD Radeon HD 7450

Even with better hardware than recommended my CPU still has performance alerts and hesitations or stutters while using the editor or even on line playing. I think my problem is that all 6 or now 8-cores don't share the load equally. I need a "professional Tune Up"
06/21/2013 01:41 PMPosted by MechaLynx
After running it at single-core affinity, maps can be selected and downloaded normally, albeit slowly (while the interface is usable, it still feels sluggish).

I tried using just one core for the editor using a special tool that lets you assign a specific number of cores to any application you run (THG Task Assignment Manager).
But it had no effect: The editor still crashed. The Manager works, Windows Task Manager showed me that only one core is used (but at 100%), while the other 3 where @ 1 - 6% (which is normal for browsing and stuff).
I'm having the same issue! I login to the editor to load up the Blizzard maps and it freezes/crashes as soon as I click on one. I tried the affinity solution as well and nothing has improved or changed.
same problem, is anyone looking into this at blizzard? just curious because i think it renders the software useless if you cant publish or alter published maps through this problem. i've tried altering the core usages and still am unable to get past this.

i'm just looking for a response of any kind as to weather this is being looked into here, i get that its not always easy to fix bugs and time consuming but is it atleast inline to be worked on or something. i'll check back often looking for this fix.
Same problem here. Anyone from blizzard want to reply?
So I have been waiting about 6 months for AN ACTUAL SOLUTION from Blizzard...?

Can we please have some acknowledgment here.

The "temporary solutions" that I have searched all over the web for have been pretty much useless and have accomplished nothing for me. The one core affinity fix got the maps to load up on the list but click on one to select it for view or loading into the editor just causes the program to stop responding - back to square one.

So... this temporary solution that has not even come from blizzard, posted in 2013.. TWO THOUSAND THIRTEEN.. doesn't even work for all of us.

Can we please just get some sh*t done for us... I bought the Collector's for both WoL & HotS... but the editor is what I really wanted and it has been 2 years and no properly working solution. Thanks.

EDIT: I am sorry if I was a bit frustrated when I posted this but the truth is I AM STILL FRUSTRATED.
I want to use the software I spent extra on because I love this game and wanted the extras!
I'm having this problem as well, it makes it impossible for me to edit virtually any pre-existing map.
Saddly, after two years. This is still a problem. A very annoying problem. How could this not be fixed yet? Is no one looking beyond it?
This problem has resurfaced and hit hard. I cannot access ANYTHING on Battle.net right now, with 8GBs of RAM and a Duo Core @ 3.15 Ghrz per Core, 100% CPU usage should not be happening.
Getting the same problem, I notice 100% cpu and can't download because after logging in editor freezes. It was fine 2 months back (by fine I mean worked but slow/sluggish) don't know why this is happening.
Bump. - I would really like to make a map but unable to for same reason!
...I may have found a solution? go to File ==> Document Dependencies ==> Add Others ==> Battle.net ==> login and search for whatever (and download I guess I don't remember but for sure the search works at this point), then go back to File ==> open ==>battle.net and then it works? can someone confirm this works?
Exact same problem

Has blizzard done anything at all i want to do the sweet user maps on other regions to Americas, because everyoen is quitting no fresh games to play.


Windows 7 - 64-bit

3.3 ghz 6-core
8gb ram
AMD radeon HD 6670
same issue, bump
I have had this issue since I upgraded to windows 10.

CPU Usage spikes to 100% in the menus and crashes my computer.

Join the Conversation

Return to Forum