Error 2231

Technical Support
As the title says, the game refuses to launch. I click Play, it loads, it gets to the title screen, freezes for a second, closes, and the launcher just pops right back up. I've tried running as an administrator, playing around with my firewall settings, and changing to windowed mode (it's works for other things for me).

When I run the repair tool I get:

An unknown error (2231) has occurred when attempting to download data.

I have yet to try reinstalling, as it takes hours to download, but if there's no other easier suggestions, I may just have to try.

I'm running the Vanilla game on a standard edition account. I can post system specs if needed, but it was running just fine last week.

EDIT: The launcher will no longer get past the Initializing stage.

EDIT 2: I tried launching via SC2Switcher.exe and had the same thing happen, but this time when it quit to the launcher, it went past Initializing and started updating. I guess if this happens to you, try that.

EDIT 3: May have been my firewall changing my settings. I feel slightly like a bit of a moron now.


This is the same error facing me. I tried everything from the blizzard support https://us.battle.net/support/en/article/streaming-errors
When I try to launch from this "SC2Switcher.exe" it says it exist.

And I have no idea how to change my firewall settings. Nortan controls mine and my windows firewall is Offline.
06/26/2013 07:31 PMPosted by Charles
I have no idea how to change my firewall settings. Nortan controls mine

What I would, just as a test, is uninstall Norton with their removal tool. Then try out StarCraft II, and reinstall Norton afterwards.

Join the Conversation

Return to Forum