StarCraft II Patch 2.0.10 - A Slight Delay UPDATED

General Discussion
I am very mad. I went to play sea last night got the patch now i cant go back to na or eu or kr
Widow Mines no longer convert excess shield damage to hull damage against shielded targets affected by Corruption.


Sometimes I wonder how these types of bugs are even discovered..

Siege Tanks on Creep and in Siege Mode that are Abducted to a lower cliff level that is covered with Creep no longer become completely covered by Creep textures.


does anyone have a screenshot of this?? I MUST SEE.
07/30/2013 09:30 AMPosted by Spyrian
That link doesn't take me to any Patch Notes. Neither does clicking on the front page. I can't find any Patch notes for 2.0.10 anywhere, as a matter of fact.


As it turns out, there were so many patch notes in the 2.0.10 blog that their combined weight caused it to fall off the page. We've added steel support beams to the blog list, so those pesky patch notes should be [url="http://us.battle.net/sc2/en/blog/10530389/starcraft-ii-2010-patch-notes-7-29-2013#best"]back for good[/url].

Thanks for letting us know!


Awesome! Glad to see Neosteel Frame finally being a viable choice for professionals. ;)
Hi, I tried SE-Asia today, and now cannot play on NA. Is there a way to rollback the patch from 2.0.10 back to NA version 2.0.9? Thanks for any help or advice on this.
windows system restore or Apple time machine backup, whichever one applies
Blast and damnation. A lot of bugs even now... Protoss icons, fonts, score screens... Damn.
I logged on SEA and now I can't get back on NA :S
Just a quick update here -

We have resolved issues with the 2.0.10 patch delivery and have been able to maintain the 24 hour delay for all regions except North America. The deployment for NA will happen tomorrow morning (Thursday, 8/01/2013) at 3:00 AM.

Thanks for your patience on all of this everyone. We hope you enjoy the patch!

07/31/2013 05:16 AMPosted by ZoDiaK
I logged on SEA and now I can't get back on NA :S


If during a patch update week you update your client via another region prior to that patch being deployed in the one you normally play in, you will not be able to return to play on your normal region until it also updates to the current version. This is one of the side effects of global play and something to keep in mind for the future.
07/31/2013 08:21 AMPosted by Cloaken
If during a patch update week you update your client via another region prior to that patch being deployed in the one you normally play in, you will not be able to return to play on your normal region until it also updates to the current version. This is one of the side effects of global play and something to keep in mind for the future.


Is there a way for us to know if your home region hasn't yet updated? I just logged in and patched without knowing what region I was on or that mine hadn't updated yet.
Just a quick update here -

We have resolved issues with the 2.0.10 patch delivery and have been able to maintain the 24 hour delay for all regions except North America. The deployment for NA will happen tomorrow morning (Thursday, 8/01/2013) at 3:00 AM.

Thanks for your patience on all of this everyone. We hope you enjoy the patch!

I logged on SEA and now I can't get back on NA :S


If during a patch update week you update your client via another region prior to that patch being deployed in the one you normally play in, you will not be able to return to play on your normal region until it also updates to the current version. This is one of the side effects of global play and something to keep in mind for the future.


i had that now my sc2 broke im trying to reinstail the game so i hope it will work
it just will not open it juststops me and says would you loike to reopen eror
If you went to play on the Korean server and can no longer play on NA or EU all you need to do is close out the game, start the launcher and run the repair starcraft 2 option it should let you play on the NA and EU regions again after that. This solved the issue for me.
07/31/2013 02:31 PMPosted by Octopus
If you went to play on the Korean server and can no longer play on NA or EU all you need to do is close out the game, start the launcher and run the repair starcraft 2 option it should let you play on the NA and EU regions again after that. This solved the issue for me.


I already try this and still i cant play on SEA server. It keeps telling me to restart client when i try to logon on SEA. Can anyone help please?
Still unable to get back to my regular servers. I have repaired from the launcher and that did not fix the problem, I have seen other people back online NA from streams so I am unsure why i cannot get back now.

Edit: Oops didn't see the date of NA's patch, for anyone else with the same problem it will be fixed by thursday.
Yeah didn't work for me either
I cannot even download this Patch. Whats going on I can't play at all! its been at 0.0% for the past 30 min! They need to make sure these damn Patches work BEFORE they decide to release them.
Hello, I'm also having diffuclty downloading this patch. I'm using the Battle.net desktop client, and it doesn't seem to realize that there is actually a patch available to download. Is there a way to manually initiate it?
after i downloaded patch whenever i send client into fullscreen mode it distorts aspect ratio and crops out a bunch of the UI... anyone else experiencing this?

Join the Conversation

Return to Forum