Blue Screen Memory Dump

Technical Support
I've played the game since release and this problem happened just yesterday:

I had played about 4 matchups and then, during gameplay, my computer locks up and all I see is the frozen game on my screen.
I restart.
I open the game back and my computer locks up during the menu screen. This time it goes to the blue screen and does the memory dump thing which results in my computer auto-restarting. I believe the computer is only doing this while in SC2 but who knows if it will happen in other applications too.

Possibly relevant: My computer had a similar problem a while back. I resolved it by removing 1 of the 4 memory sticks (stick or slot was bad, don't know). Well for whatever reason I tried to install this 1 stick yesterday (hoping it wasn't going to fail) but it crashed. (Note it crashed in Windows which CLEARLY indicates that something is unstable about that stick/slot). So I removed it and all was good for a while. I played several matchups in starcraft after this. But then hours later I get this memory dump thing happening as mentioned in paragraph 1. I understand that this bad memory stick (or slot?) should have nothing to do with the problem but it seems rather coinicidental...

My computer is an Alienware Quadcore 2.4GHZ with 8800GT, 3 GB RAM.

Thank you for all your help!
finally,

Do you recall the error message that the Blue Screen gives you during these crashes? That may help us narrow down the issue.

If not, it may be due to memory like before. Let's do a scan of your physical memory.

http://memtest.org/#downiso

You can use the bootable thumb drive option or download the .ISO and burn a bootable CD. Make sure you let the extended test run and loop; it can take many, many hours, but is one of the most thorough scans out there.
Thank you. When I get home from work I'll see what the error message is and get back to you about it.

In the meantime, I will perform the memtest with the 3 RAM sticks installed. Should I conduct this test first with all 4 sticks or is that a bad idea? Thanks!
finally,

Based on your description of the issue, I'd agree that the fourth stick or slot is probably bad. Since we are assuming that already, I'd recommend running the test on the remaining three.

You can go back and run the test on the other stick if you would like further confirmation regarding it though.
I tried to reproduce the blue screen by loading starcraft 2 but I didn't get an error. With luck this is a good thing...

The dump file contains the following,

NOTE ***() indicates where I typed the commands:

***(!analyze -V)

ADDITIONAL_DEBUG_TEXT:
Use '!findthebuild' command to search for the target build information.
If the build information is available, run '!findthebuild -s ; .reload' to set symbol path and load symbols.

FAULTING_MODULE: fffff80002c57000 nt

DEBUG_FLR_IMAGE_TIMESTAMP: 4b07613e

FAULTING_IP:
nvlddmkm+10d230
fffff880`0fff8230 803d39d3b60000 cmp byte ptr [nvlddmkm+0xc7a570 (fffff880`10b65570)],0

DEFAULT_BUCKET_ID: GRAPHICS_DRIVER_TDR_FAULT

CUSTOMER_CRASH_COUNT: 1

BUGCHECK_STR: 0x116

CURRENT_IRQL: 0

STACK_TEXT:
fffff880`0292b9c8 fffff880`04498ef8 : 00000000`00000116 fffffa80`03ca44e0 fffff880`0fff8230 00000000`00000000 : nt+0x70740
fffff880`0292b9d0 00000000`00000116 : fffffa80`03ca44e0 fffff880`0fff8230 00000000`00000000 00000000`00000002 : dxgkrnl+0x5cef8
fffff880`0292b9d8 fffffa80`03ca44e0 : fffff880`0fff8230 00000000`00000000 00000000`00000002 00000000`00000000 : 0x116
fffff880`0292b9e0 fffff880`0fff8230 : 00000000`00000000 00000000`00000002 00000000`00000000 00000000`00000000 : 0xfffffa80`03ca44e0
fffff880`0292b9e8 00000000`00000000 : 00000000`00000002 00000000`00000000 00000000`00000000 fffff880`04498c02 : nvlddmkm+0x10d230


STACK_COMMAND: kb

FOLLOWUP_IP:
nvlddmkm+10d230
fffff880`0fff8230 803d39d3b60000 cmp byte ptr [nvlddmkm+0xc7a570 (fffff880`10b65570)],0

SYMBOL_STACK_INDEX: 4

SYMBOL_NAME: nvlddmkm+10d230

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: nvlddmkm

IMAGE_NAME: nvlddmkm.sys

BUCKET_ID: WRONG_SYMBOLS

Followup: MachineOwner

***(!analyze -show)

2: kd> !analyze -show
Unknown bugcheck code (0)
Unknown bugcheck description
Arguments:
Arg1: 0000000000000000
Arg2: 0000000000000000
Arg3: 0000000000000000
Arg4: 0000000000000000
finally,

The error log tells us that nvlddmkm is faulting. That part of your Nvidia video drivers. Lets uninstall the current driver and then get the latest driver from Nvidia.

Uninstalling the driver can be done from the control panel under your add & remove program options. This will make sure any corruption in the old driver is removed before we install the new one.

You can find the latest Nvidia drivers on their site.
http://www.nvidia.com/page/drivers.html
I did as you suggested:
1. Uninstall Driver for Video Card
2. Install Latest Video Card Driver

Now when I click to load a level in the SC2 Single Player Campaign it freezes.
There is NO blue screen error this time, just a lockup.
When I restarted and went to the settings within SC2 it was freezing for a while but I could give it time and CTRL-ALT-DEL or ALT-TAB out of it.

I ALT-TAB'ed out of the game and noticed that Windows message said my video driver [kernel something] stopped responding.

Does this mean that the driver is being incompatable? I did select the correct driver as I have the 8800 GT card. What else can I try?
finally,

The video card is still having issues working with the driver if you are getting 'stopped responding' messages. We can try installing the previous driver for the video card and test with that.

Have you tried running any other graphically intensive programs?
I did a system restore but now I have a problem with the latest patch.
I had to resore my system to Saturday last week but now the patch fails to work. By the way what do I do now once I have the previous drivers installed? Please also address the error that Blizzard Updater is giving me below. THANKS!

The patch "pc-battlenet-hdfiles\Support\Battle.net.dll" could not be applied. (MD5 mismatch: expected 0x33313AC8B77B8F4D2ED890C0C800D133, actual 0x2F17E77E5D022AE25446C07E698B4377.)(PTCApply_BSDiff failed.) If this problem persists, you may be able to solve it by uninstalling and then reinstalling the game. If you are unable to correct this problem, please contact Blizzard Technical Support. (BNUpdate::PTCApply)
Update:

1. I used the "Starcraft II Repair" utility and that resolved the patch update error.

2. Now when I am running the game I get the same error message that "driver has stopped responding" and the game freezes. I am able to open a campaign mission and even start to play with no apparent graphical problems but suddenly the game will lock up. I think I can play for about 30 seconds so. I have applied a System Restore to get back to my previous video card drivers. My driver is 195.62 and the current latest driver is 260.99 for my NVIDIA GeForce 8800 GT. The same error is happening in Starcraft 2 for both drivers. Thanks for your continued support!
finally,

Have you tried any other graphically intense programs? It's starting to sound like the card may be going out.
Yes I have tried to play Left 4 Dead 2 and the same thing happens. I can navigate the menu but once the game begins I get a freeze.

I am going to order the GTX 260 which I hope will resolve it.

Thank you for your help, i'll re-post here later fyi if it works out.
finally,

Thanks for the update. Let me know how it turns out.
I had the same problem and it ended up being my video card
SpidZ you could really help me make that call, could you please get back to me?

I have done a GPU test and my graphics card did not overheat. It was at like 71 C temperature. But I got the "video driver has stopped responding" during this GPU test! It's always the video driver has stopped responding thing. I can play starcraft 2 for like 30 seconds or so but then I get that message. I'm considering just getting the new graphics (GTX 460) but I'd hate to throw money away with it possibly being a different problem.

Even without overheating does this problem indicate a bad GPU?

Thanks so much!
JonD:

I have the GTX 460 installed now and it seems to have fixed the problem. Thanks again!

That's some good news. Thanks for letting me know how it turned out.


________________________________________________
Technical Support
Mon-Fri 6:45-3:45pm PST

How's my driving? http://www.surveymk.com/s/R5D3LCF
i resently got battle.net up and started again and a friend bought me the new heart of swarm starcrt 2. as it was downloading wings of liberty and heart of swam it gets to a cirtain point of dounload and dose a blue screen and memory dumps but if i play the game before the download finishes it works fine so if you have any solutions i would be most greatful
Locwiz, can you create a new thread, and post your msinfo file there? Thanks!

I'm going to lock this thread because it was created in 2010.
________________________________________________

Rate me! https://www.surveymonkey.com/s/Velnrak

"True self is without form."

Join the Conversation

Return to Forum