Network Error: End of File?

Bug Report
I was playing Crash RPG with another player and partway through the game, I got a popup that froze the game saying something along the lines of "Network Error Occurred: Reached end of file". Clicking "OK" booted me back to the main menu.
Example of the error: https://a.pomf.cat/ggqqeo.png
I've seen the same error but for single player original campaign mission :( no idea why it happens
I just had this happen in a Marine D game, unsure what it means... did it go away for you guys?
Same error today in a ladder game :( ... One on One mode, on andromeda.. was a really exciting 5 v 5 base PvT :o
Just happened to me very early on the map "Impossible Campaign"
This just happened to me at the end of mission 9 in the Brood War zerg campaign. When I reloaded and completed the mission again, it was fine, but yeah.
This has happened to me on several occasions, and it has made it impossible for me to play on any maps that require a considerable amount of time to play. It almost always happens if the game I am playing is a long one.
https://1drv.ms/i/s!AgE9w2HpqZMZgZJwdlXA8SlkoCDJgA

same to me
Had it twice on random single player campaign missions. I noticed that after the error I am unable to login to play online until I restart the program. Seems like something is crashing in the network stack. Not sure why that's happening during single player games though.

client version 1.18.3.1490 on Windows 10 x64
Same for me, game vs. 5 bots.
http://imgur.com/a/Gjrmw
And here an example from SSL: https://youtu.be/oadDW1_0WWM?t=8m55s
Same for me....Local IP game, 1v5 cpu. About 20 minutes in.
again today...1v4, about 45 mins in. Lovely.
Hasn't happened to me for a while... hopefully it was fixed with 1.18.4 / 5 ?
Just happened to me today during the singleplayer campaign.

Reached the end of the file? I didn't know I was streaming this from Bangladesh
I realize they released a patch earlier to help address this issue, but I have recently had it twice while playing KotK RPG. It would be really nice if someone from Blizzard could address what the 'Network Error: End of File' actually means, since I can't seem to find any information on what it actually is.

I'd like to be able to avoid it if possible, does anyone know?

EDIT:
64bit Windows 10
Intel i5-6600K
NVIDIA 1060
16GB of RAM
Administrator Mode on all .exe's relating to Starcraft

FPS Cap turned OFF
Bi-linear Filtering ON
Vertical Sync OFF
Windowed Fullscreen
Enabled Color Cycling ON
Animating Unit Portraits ON

-----

Additionally I should note, I have had it happen twice, but seen it happen to others often.
Both times for me, it happened fairly early on, one was about 10 minutes into the game, during a very large wave (CCMU), the other was not during a particularly intensive moment, no CCMU, not even a rush of enemies. I also use two monitors, but both time I wasn't alt tabbed or using the second monitor.

Join the Conversation

Return to Forum