"game is running"

Technical Support
startup says "game is running" but i can't find it anywhere?
its just stuck there
Same. Help!!!
I have the same issue - clicking "Play" gives a message of "game is running" for around 3 seconds, then just goes back to showing the "Play" button again. Have tried uninstalling/reinstalling the game with no effect. Campaign Editor works just fine, but the game will not load. Would appreciate advice from Blizz on this.
Same Problem.
When I launch Starcraft directly, it opens up battle.net which says game is running.

It wont let me launch the game. When I run the top command in terminal, I see battle.net stuff but nothing that says starcraft.

If I reboot the computer, launch battle.net first, then I can sometimes start from battle.net.

being online or offline doesn't seem to matter. I am typically not connected to the internet when i try to start starcraft.
Having the same problem. I have a Mac - can't find Starcraft actually running on the computer but it keeps saying "Game is running".

Restarting the computer helped to reset whatever is going on but I don't want to have to do that every time.

Blizz help??
Seems there's a process left over on the Mac that causes this:

/Users/.../Games/StarCraft/StarCraft.app/Contents/Frameworks/ClampCursor.framework/Helpers/ClampCursorProcess

You have to kill this process for it to recognize the game is no longer running.
08/18/2017 11:11 PMPosted by thenashman
I have the same issue - clicking "Play" gives a message of "game is running" for around 3 seconds, then just goes back to showing the "Play" button again. Have tried uninstalling/reinstalling the game with no effect. Campaign Editor works just fine, but the game will not load. Would appreciate advice from Blizz on this.


Posted by Smaxx
Okay. Since there's now an incentive to get into the game again, I did some more testing and found a pretty simple solution to get the game running again! :)

Have fun playing StarCraft Remastered and don't forget to report whether it worked for you for added visibility. I'd also appreciate a like, if it indeed helped you. :)

Source of the Problem
Windows 10 Fall Creator's Update introduces a few new security features. Without going into too much detail, they're basically meant to make it significantly harder for attackers to exploit bugs in browsers, games, and other programs to gain elevated rights and do something nasty (like downloading malware).

While this is great, especially if it comes with next to no performance impact, some older games such as StarCraft (Remastered) might not work with this, since they (for whatever reason; maybe optimization) rely on some classic behavior that's no longer working due to these changes.

Fortunately Microsoft provided all the necessary tools to fix those problems for older programs. You just have to actually know about them.

Does this Endanger the Security of my System?
No, not really. We're not turning off this feature for all your programs (which some other sites might make you do in similar situations). We're only adding a single exception. While in theory this weakens the protection against exploits in StarCraft itself, the impact is basically neglectable.

Can I Undo the Change?
Yes. Just follow the steps below to get to the list under Program settings, find the entry for StarCraft, click on it and then pick Remove.

How to Fix StarCraft Remastered
Obligatory Disclaimer: I take no responsibly if you somehow screw up your system trying to follow these steps. If you're unsure, ask someone who knows more about computers than you. If you follow these steps, there won't be any issues. Trust in yourself! To apply the changes you'll need administrator access to your PC.

Open the Start Menu and type Windows Defender Security Center. Wait for the search result and open the app.
In the left menu list, pick App & browser control, which is the 5th icon.
Scroll all the way down until you find the clickable link Exploit protection settings
Click the Program settings tab on the top.
Click on Add program to customize.
Click on Choose exact file path.
Find your installed StarCraft.exe (make sure not to pick the launcher or editor) and click on Open.
In the new window look for the section Control flow guard (CFG), which should be the sixth entry.
Tick Override system settings in this section and make sure the switch right below is set to Off.
Click on Apply and confirm the UAC prompt.
Close the Security Center.
You're done! Have fun!
Going to lock this since the original thread is from 2017

Join the Conversation

Return to Forum