press PLAY button and nothing happen

Technical Support
Just purchase SC remastered, after install and press PLAY button and nothing happen. please help
If you haven't tried this, I remember a fix from the older StarCraft games where you need to set it in compatibility mode for Windows 95. Navigate to your StarCraft game (most likely in C Drive), right click the StarCraft(dot)exe, click on properties, open the Compatibility tab, check the box that enables you to run the compatibility, and select Windows 95. Good luck.
Starcraft needs to be run as administrator, are you playing on an office computer?
HI! I have the same problem. I selected windows 95 but nothing. please help me. Yesterday I was updated and it's gone
Same problem with me after update to version 1.21.2.3514 in OS Window 10, Window reporting StarCraft.exe fail to run. ever run "scan and repair" or "compatibility" still not working.
Everything was fine for me until yesterday. Now, I press play and it says "Launching....." then "Playing Now" for a second then nothing. Just goes right back to tab. Tried "scan & repair" and it says nothing found. Using Windows 10.
Same problem. Press Play and it says Launching then Game is running, then goes back to Play. I wish these 'patches' were fully vetted. I even tried re-installing the game, nothing.
i have the same problem, i tried to uninstall/reinstall but don't work i press play it says "game is running" for 5 seconds then come back to "play"
i tried to disable antivirus - same problem
i tried to launch as administrator - same problem
i tried deleting %appdata% battle.net - same problem
the game won't launch in anyway
I'm having the same exact problem...
same exact problem
Same problem as well...
Same problem. Happend after last update!
Same problem here after last update!
same problem here. It won't launch.
same problems here . please repair it quickly.
Same issue for me...can't get it to launch
Same issue here. :( :( :(

Could launch yesterday just fine.
I get this error message when trying to launch StarCraft: Remastered

Can anyone help me with this:

Problem signature:
Problem Event Name: APPCRASH
Application Name: StarCraft.exe
Application Version: 1.21.3.3601
Application Timestamp: 5a7b3c33
Fault Module Name: ntdll.dll
Fault Module Version: 6.1.7601.24000
Fault Module Timestamp: 5a499696
Exception Code: c0000005
Exception Offset: 00031d26
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 2057
Additional Information 1: de1e
Additional Information 2: de1e929f7034337636a5807b4c8bfb36
Additional Information 3: 5888
Additional Information 4: 5888ffe47d3c63798ee8c03dfde9c9cb

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

Join the Conversation

Return to Forum