inconsistent behavior for Mac option

Bug Report
This is Mac-specific, obviously. I posted this before, but apparently the forum ate it.

I'm very glad the "Use Command instead of Control for hotkeys" option, as well as "Disable OS Keyboard Shortcuts" and "Use standard function keys," was added, but it behaves inconsistently with its implementation in Starcraft II. In SC2, selecting this option does the following things:

  • Cmd+clicking units in the game view (i.e., the actual units) will select all units of that type.
  • Cmd+clicking units in the selection group (i.e., the wireframes) will select all units of that type.
  • Cmd+# will set a control group for that number.
  • Use of the Ctrl key for the aforementioned behaviors is disabled.


In SCR, we have the following behavior when this option is enabled:

  • Cmd+clicking units in the game view (i.e., the actual units) will not select all units of that type. Only Ctrl+click works for this.
  • Cmd+clicking units in the selection group (i.e., the wireframes) will not select all units of that type. Only Ctrl+click works for this.
  • Cmd+# will set a control group for that number, as expected. Ctrl+# will also continue to do this, unlike SC2.
  • Use of the Ctrl key for the aforementioned behaviors is still enabled and, indeed, is still often the only way to do it.


So, provided the goal is to replicate the behavior of the SC2 option (which would be an ideal goal), we're 1 for 4, which isn't great. It's quite confusing for Mac players who use this option and play both SCR and SC2. Please close this gap and faithfully duplicate the behavior of SC2.

Join the Conversation

Return to Forum