Patch 1.21.3

General Discussion
02/24/2018 03:27 AMPosted by JumpyLion
Blizzard, I am a player from Australia playing at Korean server. My computer and internet connections aren't behind the latest but it seems I appear as bad 'ping' so I am getting banned as soon as I join the game. It got worse since the latest patch so, I am guessing that could be the reason.

If you do not fix it, you will lose all players like me joining in Korean server from Non-korea nations..

Please fix.


+1.

I am from North America, playing at Korean server. Nine out of ten times, I get booted/banned because my ping appears as red/yellow. The one time I get to play, there is usually no lag, even at a turn rate of 16, especially when we turn on the e-latency setting.

The red/yellow ping status is misleading. Please fix this.
Updated the global matchmaking algorithm to heavily favor more latency performant matchups. Join the conversation here: https://us.battle.net/forums/en/starcraft/topic/20761596714

This part is a complete disaster. I'm sorry. There are so many foreigners who cant get games above 2000+ It takes 300sec- 1 HR EVEN
02/24/2018 05:10 AMPosted by HappyFeet
02/24/2018 03:27 AMPosted by JumpyLion
Blizzard, I am a player from Australia playing at Korean server. My computer and internet connections aren't behind the latest but it seems I appear as bad 'ping' so I am getting banned as soon as I join the game. It got worse since the latest patch so, I am guessing that could be the reason.

If you do not fix it, you will lose all players like me joining in Korean server from Non-korea nations..

Please fix.


+1.

I am from North America, playing at Korean server. Nine out of ten times, I get booted/banned because my ping appears as red/yellow. The one time I get to play, there is usually no lag, even at a turn rate of 16, especially when we turn on the e-latency setting.

The red/yellow ping status is misleading. Please fix this.


Yep, I am also an Australian who plays Korea server sometimes. Since the patch I get banned within seconds of joining.
02/08/2018 11:21 AMPosted by Matt Sherman
Doubled the CCMU bullet limits to 400.


It needs to be like, 1000.
Dear Blizz Team! Can u explain me plz, where is my 2000 legacy games stats? I didnt play 2 months. Today i run SC and i am 90-70 /stats when i had ~1400-600. I was keeping my account since 2008 and now in 2018 u just removed my stats. WTF?

Poezja[T4] @ europe

April 2017, just after 1.18 release.
https://imgur.com/697hw5c

After that i played like 200-300 games. Plz investigate what happend.
03/03/2018 01:40 PMPosted by poegim
Dear Blizz Team! Can u explain me plz, where is my 2000 legacy games stats? I didnt play 2 months. Today i run SC and i am 90-70 /stats when i had ~1400-600. I was keeping my account since 2008 and now in 2018 u just removed my stats. WTF?

Poezja[T4] @ europe

April 2017, just after 1.18 release.
https://imgur.com/697hw5c

After that i played like 200-300 games. Plz investigate what happend.


Should probably open some sort of ticket for that? I doubt it will be resolved in forums. Also, has the devs abandoned the game? I liked the last few patches except the part where there seems to be more connection issues than ever? People dropping like flies.
its time for the 2v2 ladder that a ton of people are waiting for its long over due im sure you'll get more data from the 2v2 please/thank you - i think giving us the 2v2 ladder will be a great/ the best thing for the SC20 anniversary present
03/07/2018 10:53 AMPosted by Connor5620
its time for the 2v2 ladder that a ton of people are waiting for its long over due im sure you'll get more data from the 2v2 please/thank you - i think giving us the 2v2 ladder will be a great/ the best thing for the SC20 anniversary present


Blizzard should fix 1v1 first before they implement 2v2
02/10/2018 06:14 AMPosted by TimeLord04
2-10-2018
Both my Battle.net App and SC:R required Updates, yesterday. After patching, when Launching SC:R, getting into the Main Menu, a game dialog box pops up stating "Download Failed" and ONLY has an "OK" button... I exited and relaunched 3 times, and this "Download Failed" pops up each time. [EDIT:] (Playing on MAC OS.)

[/quote]

Same Problem here, starting SC: R and getting the "Download failed" error right away in the main menu.

This problem only exists on my Macbook Pro 13˝ Early 2015 running OS X 10.11.6.
On my desktop mac and on my Windows 10 machine everything works fine.

I hope this gets fixed, or at least there will be a way to fix it by user interaction.

Cheers
Yiria

Join the Conversation

Return to Forum