Customize Resolution

General Discussion
Hey,

so for 15 years I've been playing bw on a 15 inch laptop monitor. Always found the size near optimal. Recently received a 27 inch Desktop Monitor. Now I'd like to not use the full 27 inch to display bw. What I'd like would be something like a 15 inch "window" in the center of my screen. I know that windowed mode exists, but the monitor is wqhd and the window really small. Also, I really don't like the "folder-bar" on top of the window. I'd like to have it all black around. In an ideal world I'd like to play on fullscreen and achieve the black bars on top and on the side through the use of (a) adjusting overall resolution, (b) running bw in a specified resolution. Is there any way for that?
Oh yeah and for SCII I have found the following answer, does something similar exist for bw remastered?

Hey Ryan,

You can actually set the resolution manually in the Variables.txt file found in your Documents\Starcraft II\ folder. The variables for Fullscreen and Windowed modes are as follows:

Fullscreen
width=
height=

Windowed
windowwidth=
windowheight=

To change display mode manually:
displaymode=
0 - Windowed
1 - Windowed (Fullscreen)
2 - Fullscreen

The taskbar should not be covering the game in Windowed (Fullscreen) so it sounds like there's an issue there. Try restarting the PC and checking again.

In regards to the mouse leaving the game screen, you can set Confine Mouse Cursor in the Options under Mouse and Keyboard.
no1?
I'll continue my monologue!
This is something I found in another post on this forum:
SC didnt work in true Fullscreen mode, turns out, game chooses 1920x1200 which was highest resolution listed in nvidia control panel, strange cuz my monitor is only 1920x1080 (1200 = input not supported message).

I was playing with custom resolutions (basically it seems to work like DSR) so i suddenly noticed it worked with that.

So, in order to be able to launch fullscreen at native 1920x1080 i had to manually remove higher resolution like 1920x1200 from display EDID (using Custom Resolution Utility), and also remove all custom resolutions from nvidia panel that were higher than 1920x1080.

seems it runs just a little bit better in true fullscreen mode, than windowed fullscreen..


This basically would give me the result I want: True Fullscreen without being forced to play on WQHD/27 inches. What I do not like is the path how this result got achieved. Is there really nothing like the variables.txt for SCR??
I don't know of any way to achieve what you want off the top of my head. SCR runs in the native monitor resolution. So I think the 2 obvious options are either run it in windowed mode (which I know you said you were opposed to), or play with your monitor resolution in the hope that it might approximate what you want a little better.
Unfortunate, but looking at the minimap is overrated anyways! I'll go for the 27"
Thank you very much for your response!
You can get this to work if you set your scaling options (I do that in the NVIDIA control panel, can probably do it elsewhere too) to not scale, and then change the resolution of your monitor in your windows settings to the one you want. You have to play in either windowed or windowed fullscreen though, regular fullscreen will still take the entire screen, no matter what the settings are.
In your graphics card settings (NVIDIA, ATI or Intel HD Graphics) there's an option called Scaling or something like that. It's where you can select to maintain aspect ration, use monitor (display) scaling and customize it. Set option to Center image, then change your monitor resolution from there and run SC:R in fullscreen mode. The downside is that it will also change your desktop resolution (not only in the game).
11/28/2018 01:09 AMPosted by BRuǂQuaD
SC:R in fullscreen mode

This didn't work when I tried just to confirm, before I posted my response. Had to do windowed fullscreen, otherwise the game jsut ignored it and used the entire screen anyway, even though I had the ignore game settings thing checked.
11/28/2018 02:11 AMPosted by Araneae
This didn't work when I tried


Yes, in the past I was experimenting with a 640x480 resolution on my 1920x1080 monitor. Idea was to avoid compression for streaming as much as possible. In windowed fullscreen it worked. In normal fullscreen it went to 1920x1080.

Its a bit unfortunate as my feeling is that only fullscreen truely provides a flawless experience. At the same time, in the blizzcon game of rain vs mind? there was a small fpview of rain and he plays in the smallest window humanity has ever seen..

If it truely annoys me, and I heard that Win10 adds all sorts of weird V-Sync on windowed games, I'll start play around with this custom resolution utility.
11/28/2018 05:28 AMPosted by molotow
At the same time, in the blizzcon game of rain vs mind? there was a small fpview of rain and he plays in the smallest window humanity has ever seen..

Rain played in normal windowed mode and 4:3 if I remember it right.
Yes, I also intent to play in 4:3 classic graphics. Was just saying it as a counterargument to my feeling that non-fullscreen doesn't feel right.

Join the Conversation

Return to Forum