Mac Technical Support

Aug 29 Cmd-Tab STILL Broken (full screen)! While I know of the work around, muscle memory still has me trying and failing on the above. Blizz seemed to break it with 725 and to date looks like it is still broken. Dare I hope that it is fixed in 7.3?Brightbrown1 Aug 29
Aug 29 Window mode completely broken So Mac OS... I can't play this game anymore. This is really frustrating. I've been running WOW on 5k mac without any problems. When I try to do Window mode (full screen), it doesn't detect 5K, I'm stuck in "Custom" which looks like 1920X1080. It looks so bad.. In Full Screen mode, i can load 5K resolution but my fps drops down to 20. Usually it was 90-100 on a same setting. Also like all the other people already said, mouse pointer gets really small and it's barely moving. I'm running on latest mac os update. I hope this issue gets resolved very soon.Adél1 Aug 29
Aug 29 Resolution / Render Scale & Pixely Names Is there any way to lower the screen resolution or reduce the render scale without making names (that appear over characters) completely unreadable at any significant distance? (This was happening before 7.3, and is unrelated to the new reports that are coming in today about render scale not working right in windowed modes)Teneraya0 Aug 29
Aug 29 Fullscreen vs. Windowed (Fullscreen) When using windowed (fullscreen) text is very fuzzy. If I go into fullscreen mode, text issue is resolved. Would rather play in windowed (fullscreen) as it allows for easy changing of applications on the Mac.Emooly1 Aug 29
Aug 29 Mouse Cursor Size with 7.1 on 4k Display Just updated to 7.1 (game servers aren't back up yet) and noticed that in the login screen the mouse cursor size is now half the size it should be when viewed on a 4k monitor. macOS 10.12 (Sierra) Mac Pro (Late 2013) 3.5 GHz 6-Core Intel Xeon E5 AMD FirePro D700 DELL UP2414Q DisplayOrr21 Aug 29
Aug 29 Wifi is great, latency is AWFUL Hey guys! I've been using my work laptop for WoW ever since I started again (last week) and latency has been horrendous. My Wifi is 100 Up and 130 Down and works with Netflix and other streaming services, but I'm getting 2000-3000ms latency in both home and world. Any ideas on the causes/solutions?Arkhammer4 Aug 29
Aug 29 Metal 2? Hey, will we be seeing blizzard taking advantage of the new Metal 2 API?Furyville5 Aug 29
Aug 29 WOW51900322 & WOW51900323 So I have been experiencing this strange issue over the last 2 weeks (roughly). I am posting the issue that I was having, as well as the resolution, in order to hopefully spare someone some grief. Partly because it was very frustrating and partly because Blizzard lent little to no help on the matter. I'm not here to bash Blizzard, but the support channel definitely didn't help my confidence. Hopefully this helps someone. TL;DR - Uninstall World of Warcraft from the Battle.net app, uninstall the Battle.net app, redownload the Battle.net app and install. Reinstall WoW. So nearly 2 weeks ago, I went to log in to main toon, who was in Warspear. The load screen would pop up and load to approximately 55%-60% before it would get hung up. The game practically froze. The music was stuttering on repeat. Then it would resume and get to maybe 80%-85% and do the same thing ago, although for a shorter period of time. Finally, it would complete the load, but return me to the log in screen posting one of the two following errors: ... ... I logged in from a different machine/network (also a Mac) and returned to my garrison. I thought that, perhaps something jacked up on the Warspear load. When I returned to my primary machine, it would load fully and show me my garrison (IT'S FIXED!), but then after about 30 seconds (almost exactly) it would disconnect me and return me to the title screen. From here I took to the forums and found nothing. From there I opened a ticket with Blizzard. I tried all of their responses multiple times to no avail. I did some troubleshooting of my own and discovered that, as long as a character was not in their Garrison, I was able to connect and stay connected. So I played those characters while I continued to try Blizzard's troubleshooting. Finally, after losing all hope and confidence in Blizzard, I decided to completely uninstall all things Blizzard from my machine. I removed World of Warcraft from the Battle.net application (click options, Uninstall). I did this with Diablo 3, Starcraft 2, Heroes of the Storm and Hearthstone. Finally, I removed the Battle.net application. I made sure there were no more folders in the Applications folder related to Blizzard. Then I emptied my trash can. Then I proceeded to download a new installer for the Battle.net app (http://us.battle.net/en/app/). I proceeded with reinstalling World of Warcraft. I will add that I waited until the game was completely finished downloading and patching. I did not play the game after it reached the playable or optimal areas. I waited until it was finished. From there, I immediately tried to log in to a character that was in his/her garrison. IT WAS FIXED! After that, I am no longer experiencing the issue. I do hope this helps someone. Best of luck to you! Kind RegardsLokien37 Aug 29
Aug 27 Razer Naga mouse numkeys not working properly I cannot use my razer naga numeric mouse keys for abilities. I start to type a message and the keys would type the character for which they are mapped to, however, when i use the num keys for abilities, nothing happens. I am running the latest OSX version and I have made sure my driver from Razer is up to date. Any suggestions?Bralley22 Aug 27
Aug 26 mac air 128G So just to let you know, I use a mac air 128 G memory and I am able to instal and play - wow + all expansions - diablo 3 + all expansions - star craft 2 + all expansions I still have about 20 G memory left.Sathyr2 Aug 26
Aug 26 Macbook Pro Shuts Down Playing Randomly WoW For the last 2 weeks I have been have trouble with my mid 2014 Macbook Pro randomly shutting down after a few minutes of playing WoW. I have 16GB of RAM, am running the most recent version of Sierra and WoW and the Blizzard ap. I have tried playing with only WoW running. And i brought my computer into a genius bar for diagnostics. They found nothing wrong. Following their advice, I reinstalled the Blizzard Ap and WoW. With my area's crapping internet (I hate you so much, Centurylink) this took the better part of two days. It might be overheating, despite that I have installed Fan Control and have been running the fans on full. I ordered a cooling pad, which will arrive tomorrow. I have also had a few of these random shutdowns while running other less demanding programs, but they hapening with the greatest frequency while running WoW. If the problem continues with the heating pad, I'm taking my computer in for Apple to examine its guts. And if that doesn't yield a solution, they'll have to wipe my computer and reinstall everything. On the off chance that this is a problem in the WoW program and not my computer, I'm asking if any similar issues have been discovered and how to fix this.Bliith4 Aug 26
Aug 25 W Key Issues :( So I was in a raid earlier. Tomb of Sargeras. When I got stuck running forward. Usually when that happens I can press QWE and regain control. That didn't work this time and I had to hold S to keep myself from running forward. Raid ends and I am back in Stormwind near the target dummies and realize that I can't move forward at all now and my W key is no longer responding. I've restarted and also shut down and restarted. Still not working. Might WoW have caused this issue somehow or is my W key just broken? Has anyone else experienced this issue before? Any help would be greatly appreciated because if it's something I can fix, I'd love to do that before taking it in to the Apple Store. ThnaksRhothren4 Aug 25
Aug 25 Error #108 (0x8510006c) GF's not too tech savy but she's having an issue suddenly come up with battle.net where it gives this issue when ever she goes to launch the game. On top of that BLZBNTAGT00000840 error is happening too, she's running a repair now and it's about a 3rd of the way down the bar. I'm the more techy one out of the two of us hence why im posting about it.Hsianji0 Aug 25
Aug 21 New macr, game recommended graphic settings Just bought a new macbook air the cheapest one and the game has me at a recommended setting of 2 / 10. its the i5 proc / integrated 6000 / 128 mb / 8 gb 1600mhz / 1.8 turbo boost to 2.9 mhzSathyr4 Aug 21
Aug 20 Unable to use shift + mouse buttons Hi folks, I have an issue where previously things like holding shift + left clicking on a corpse would auto-loot. Or, shift + left clicking on mail items would loot the mail. I thought maybe this was a looting problem only, so I just turned on auto-loot (which of course doesn't solve the mail problem). But then I found other shift+click modifiers don't work either. I'm unable to socket any gear (shift + right click), or view my artifact details (shift + right click). I tried deleting my Cache, WTF, and Interface folders, but the problem persists. This seemed to start happening after updating to macOS Sierra or after the last patch Tuesday. Both happened around the same time so it is difficult to say which may have caused the issue.Fatherdub25 Aug 20
Aug 16 Blizzard app wont connect Blizzard App won't connect, i have tried the suggestion of turning off proxies to no avail. Any other suggestions?Mäteba1 Aug 16
Aug 16 Connecting my new MacBook Pro to a monitor hello guys. I have a quick question if I may. I have the new macbbok pro with toucher running 4GB video card and 16GB ram. I was thinking to buy an external monitor. I researched it quite a bit, and found that for my price point the Dell U2718Q would be a good match. I was just curious though on a few things: 1) Will wow even play at such a high resolution? 2) Can I use the connectors in the back of the monitor (usb, audio out, HDMI, ethernet etc...) for my MacBook? 3) if the monitor has a display port will it be plug and play? Thanks for any help/advise Cheers, Vader--))Vade1 Aug 16
Aug 16 7 fps?? OK, whatever update that took place just lowered my frame rate to 7 fps, any idea on what's going on? Mac obviously, worked great yesterday until today; specs below: Mac Pro (Early 2008) Processor 2 x 3 GHz Quad-Core Intel Xeon Memory 32 GB 800 MHz DDR2 FB-DIMM Graphics NVIDIA GeForce GTZ 760 4096 MB Any help appreciated, thanks in advance..Valgorys1 Aug 16
Aug 16 Keep getting DC in random BG... macbook pro. i have no lag issue or any framerate issue, but i keep getting dc when i am doing alot of damage, even in 1v1 as demon hunter, so when i log back in and i m dead. So yea, its annoying AF, anyone have this issue? Been happening in 7.2.5, and i disabled all 3rd party addon, any clue?Yukariki0 Aug 16
Aug 14 No World Of Warcraft Folder or Launcher? I'm trying to add addons but I can't because there's no WOW launcher or folder. All there is, is the battle net launcher.Slitherr3 Aug 14
Aug 13 Mac F Keys-Set normal-not working in WOW I play WOW Mac but I have had a frustrating issue with the F keys . All posts I can find on the subject are laptop users who fail to set the F keys to normal function. I can find nothing on my specific issue. As implied above, I am fully away of needing to set the F Keys to normal function in the OS system settings. In WOW the F keys do bind but do NOT work in the game. It is very odd that the F keys do work in other games. This has plagued me since I began playing WOW and kills my PVP ability. No matter which version, reinstall, a fresh login profile within Mac - nothing works. I even did a clean OS install before restoring my Time Machine backup just to see if some kernel extension was causing an issue. No joy. Is this a know issue on Mac perhaps? I simply want the second row of combat functions bound to the F keys... I also noticed that WOW would not use any functions bound to my middle mouse button. Again, the function I wanted binds in the WOW settings and detects the key/button but WOW will not preform the action in game. Any suggestions would be greatly appriciated.Nethuns1 Aug 13
Aug 13 MacBookPro Retina If your a Retina user, you are completely forgotten by blizzard developpers : Bad graphics performences high heat on your processor long time loading screens well, let's see , there are many other games ...Boomchack3 Aug 13
Aug 12 Insane Lag at Emerald Dream I've been having extreme lag at emerald dream since the weekly reset. - Is this latency happening only during the usual "raid hours"? (Between 20:00 and 0:00 CEST) Ever since the last reset (august 8th) I’ve been having insane lag, it is random (can happen with anything and at anytime) - If not, at what times does it happen? Anytime - Can you provide us a list of addons that you're using during the issue? ElvUI, DBM, angry assignments, RClootCouncil but I have tried to play without addons - Are you especifically in raid when this is happening or doing other things? Doing anything - City/country Cali, Colombia - Internet provider Movistar - Connection type (Fiber, ADSL...) ADSL - Time and date when the issue started August 8th - Short description of the issue and symptoms Insane lag, up to 3400ms usually around 1400ms - Pathping created during the issue. Guide: battle.net/support/article/7871 Pinging 24.105.62.129 with 64 bytes of data: Reply from 24.105.62.129: bytes=64 time=131 TTL=243 seq=1 Reply from 24.105.62.129: bytes=64 time=131 TTL=243 seq=2 Reply from 24.105.62.129: bytes=64 time=131 TTL=243 seq=3 Reply from 24.105.62.129: bytes=64 time=131 TTL=243 seq=4 Ping statistics for 24.105.62.129 Packets: Sent = 4, Received = 4, Lost = 0 (0% loss) Approximate round trip times in milliseconds: Minimum = 131, Maximum = 131, Average = 131 - (Very important) Traceroute created during the issue. Guide: battle.net/support/article/7870 Tracing route to 24.105.62.129 over a maximum of 20 hops 1 3ms 1ms 1ms 192.168.1.1 2 24ms 21ms 21ms 10.7.96.142 3 310ms 18ms 18ms 10.7.96.141 4 * * * Request timed out. 5 44ms 43ms 46ms 176.52.253.234 6 95ms 96ms 95ms 94.142.117.11 7 * * * Request timed out. 8 * * * Request timed out. 9 98ms 97ms 97ms 4.16.176.198 10 * 172ms 172ms 37.244.8.33 11 * * * Request timed out. 12 * * * Request timed out. 13 175ms 172ms 173ms 37.244.1.103 14 130ms 130ms 130ms 24.105.62.129 Trace complete. - (Very important) MTR test from Looking Glass. Please only check the MTR test, we don't need the traceroute and ping from Looking Glass. Guide: battle.net/support/article/34785 MTR: Start: Fri Aug 11 21:17:15 2017 HOST: Blizzard Loss% Snt Last Avg Best Wrst StDev 1.|-- 24.105.30.3 0.0% 10 0.5 0.6 0.5 0.9 0.0 2.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 3.|-- 37.244.0.102 0.0% 10 1.2 1.3 1.2 1.3 0.0 4.|-- 37.244.0.34 0.0% 10 1.2 1.2 1.1 1.3 0.0 5.|-- xe-9-3-0.edge2.LosAngeles9.Level3.net 0.0% 10 0.9 0.9 0.8 1.9 0.0 6.|-- ae-1-3.edge1.SanJose2.Level3.net 0.0% 10 11.4 11.5 11.4 12.4 0.0 7.|-- 4.59.0.226 0.0% 10 11.4 11.4 11.4 11.7 0.0 8.|-- 213.140.43.59 0.0% 10 119.4 118.9 115.5 122.1 2.0 9.|-- 5.53.3.190 0.0% 10 115.4 115.4 115.4 115.7 0.0 10.|-- 84.16.11.235 90.0% 10 9521. 9521. 9521. 9521. 0.0 11.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 12.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 13.|-- 186.117.189.240 0.0% 10 157.8 157.9 157.6 158.2 0.0 11/08/2017 21:17:15 UTC -------------------- MTR: Start: Fri Aug 11 21:17:15 2017 HOST: Blizzard Loss% Snt Last Avg Best Wrst StDev 1.|-- 24.105.30.3 0.0% 10 0.4 0.5 0.4 0.8 0.0 2.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 3.|-- 37.244.0.102 0.0% 10 1.0 1.0 0.9 1.2 0.0 4.|-- 37.244.0.34 0.0% 10 1.1 1.1 1.0 1.2 0.0 5.|-- xe-9-3-0.edge2.LosAngeles9.Level3.net 0.0% 10 0.9 0.9 0.8 1.6 0.0 6.|-- ae-1-3.edge1.SanJose2.Level3.net 0.0% 10 11.3 11.4 11.3 11.8 0.0 7.|-- 4.59.0.226 0.0% 10 11.4 11.5 11.4 12.1 0.0 8.|-- 213.140.43.59 0.0% 10 118.8 118.9 115.3 122.7 2.2 9.|-- 5.53.3.190 0.0% 10 115.3 115.5 115.2 117.0 0.5 10.|-- 84.16.11.235 90.0% 10 9520. 9520. 9520. 9520. 0.0 11.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 12.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 13.|-- 186.117.189.240 0.0% 10 157.5 157.7 157.4 158.0 0.0 11/08/2017 21:17:15 UTC -------------------- MTR: Start: Fri Aug 11 21:17:15 2017 HOST: Blizzard Loss% Snt Last Avg Best Wrst StDev 1.|-- Blizzard 0.0% 10 0.4 0.4 0.4 0.5 0.0 2.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 3.|-- 37.244.1.102 0.0% 10 3.0 2.9 2.7 3.0 0.0 4.|-- 37.244.1.34 0.0% 10 5.1 3.6 2.7 8.9 2.0 5.|-- xe-11-3-0.edge4.Chicago3.Level3.net 0.0% 10 2.1 2.1 2.0 2.3 0.0 6.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 7.|-- 213.140.53.132 0.0% 10 22.0 22.0 22.0 22.4 0.0 8.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 9.|-- 213.140.36.155 30.0% 10 95.9 92.8 89.5 95.9 2.1 10.|-- 5.53.3.190 20.0% 10 135.9 135.9 135.8 136.1 0.0 11.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 12.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 13.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 14.|-- 186.117.189.240 0.0% 10 178.4 178.5 178.0 179.0 0.0 11/08/2017 21:17:15 UTC -------------------- MTR: Start: Fri Aug 11 21:17:15 2017 HOST: Blizzard Loss% Snt Last Avg Best Wrst StDev 1.|-- Blizzard 0.0% 10 0.4 0.4 0.4 0.5 0.0 2.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 3.|-- 37.244.1.102 0.0% 10 2.8 2.8 2.7 2.9 0.0 4.|-- 37.244.1.34 0.0% 10 2.7 2.8 2.7 3.0 0.0 5.|-- xe-11-3-0.edge4.Chicago3.Level3.net 0.0% 10 2.0 2.0 2.0 2.1 0.0 6.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 7.|-- 213.140.53.132 0.0% 10 22.0 22.1 21.9 23.6 0.3 8.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 9.|-- 213.140.36.155 20.0% 10 95.5 94.5 90.2 96.9 2.4 10.|-- 5.53.3.190 0.0% 10 136.0 135.9 135.8 136.2 0.0 11.|-- 84.16.11.235 90.0% 10 9382. 9382. 9382. 9382. 0.0 12.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 13.|-- ??? 100.0 10 0.0 0.0 0.0 0.0 0.0 14.|-- 186.117.189.240 20.0% 10 178.6 178.9 178.3 179.6 0.0 11/08/2017 21:17:15 UTC --------------------Flyingicarus0 Aug 12
Aug 12 Graphic Settings for Legion Coming from Mac Pro 5,1, GTX 980, 10.11.5... Obviously, using Metal. Everything is maxxed EXCEPT I turn AA off (tried it, too blurry for my taste) and I set Shadows to Good. Have not run this extensively, patch tomorrow so gotta log some serious hours to see if my spec is viable (on first blush, down close to ~20k dps)... far as I know, Shadows & AA are the 2 biggest drags on fps. Not sure about the Texture filtering (maxxed @ 16x...). VERY limited time seems to be showing me my Garrison fps is running 10 to sometimes 20 fps more than 6.x live.Brightbrown4 Aug 12
Aug 12 Can't Find .MPQ Files on Mac Hello, I need help finding all of my .MPQ files. I am confused since all of the videos i have watched went like this; Applications/Wow/Data/Cache. However, after i click Data, there is no Cache folder. So then i searched the .MPQ tag for the WoW folder but no .MPQ files came up. Did Blizzard undergo a change, getting rid of .MPQ files? or am i doing something wrong or don't have something downloaded? I've also searched for alternatives for .MPQ files that may have switched but i couldn't find any threads. Please help me out and tell me what i'm doing wrong. It's hard enough playing on a mac. Any help or insight would be greatly appreciated. ThanksSwish3 Aug 12
Aug 11 Long load screens I need help with my long load screens, I've changed the critical load thing to 0, as was suggested somewhere else, I've changed a few other things, no addons... These load screens are ridiculous! I can't load into an arena until after it's already begun and my team will ultimately lose because I can't catch up. I've been kicked out of dungeons for not loading in fast enough, it's getting ridiculous. Any help is much appreciated.Sapid0 Aug 11
Aug 11 Huge GUI I came online and my entire GUI (action bars, mini-map, quest log, chat) were huge. Everything is pixelated in-game too, but not the GUI. The GUI was just huge. I've already tried everything I could in the settings. Nothing changes how the graphics look...like, at all. Are there any other people experiencing this? Please help!Adaah3 Aug 11
Aug 10 Metal option missing Hi. I switched from Metal to Open GL a while ago. Had been having load screen problems. Wanted to try switching back, but there's no Metal option anymore. Any idea where it went? I'm still running OS 10.11.6, GTX970. I think it should be there.Syrelliia5 Aug 10
Aug 10 Keyboard Stops Working In The Middle Of Raids I have a Steelseries Apex 350 gaming keyboard. It was plugged in to a USB hub with 3 inputs, which was plugged into my mac via a USB 2.0 to USB-C dongle. The other 2 USB ports on the hub were filled with my Steelseries Rival 500 mouse and Steelseries Siberia 800 headset. My keyboard would stop working frequently, when this happened, my mouse would stop working, and also the trackpad on my macbook would become unresponsive. I since moved my keyboard to another USB-C port on my macbook via a USB 2.0 to USB-C dongle. The keyboard still stops working randomly usually in a progression boss fight, which my guild leader loves. When this happens, the keyboard is still being illuminated, so the power isn't cutting off. Also, I can switch the keyboard to another USB-C port on my computer and it somewhat starts working again, EXCEPT for the extra macro buttons that are the core reason for having an Apex 350. AFTER my keyboard becomes unresponsive, and I move it, World of Warcraft freezes my computer when I 'Exit Game' or Alt+Tab out of the client. I then must hold down the power button on my Mac and force shut down it. This is very frustrating please help. Model Name: MacBook Pro Model Identifier: MacBookPro13,3 Processor Name: Intel Core i7 Processor Speed: 2.9 GHz Number of Processors: 1 Total Number of Cores: 4 L2 Cache (per Core): 256 KB L3 Cache: 8 MB Memory: 16 GB Boot ROM Version: MBP133.0226.B08 SMC Version (system): 2.38f6 Hardware UUID: DA920704-D077-5DA6-8B05-50534048C226 System Version: macOS 10.12.2 (16C67) Kernel Version: Darwin 16.3.0 Boot Volume: Macintosh HD Boot Mode: Normal Secure Virtual Memory: Enabled System Integrity Protection: Enabled Time since boot: 12:38 Intel HD Graphics 530: Chipset Model: Intel HD Graphics 530 Type: GPU Bus: Built-In VRAM (Dynamic, Max): 1536 MB Vendor: Intel (0x8086) Device ID: 0x191b Revision ID: 0x0006 Automatic Graphics Switching: Supported gMux Version: 4.0.29 [3.2.8] Metal: Supported Displays: Color LCD: Display Type: Retina LCD Resolution: 2880 x 1800 Retina Retina: Yes Pixel Depth: 32-Bit Color (ARGB8888) Main Display: Yes Mirror: Off Online: Yes Automatically Adjust Brightness: Yes Built-In: Yes Radeon Pro 460: Chipset Model: AMD Radeon Pro 460 Type: GPU Bus: PCIe PCIe Lane Width: x8 VRAM (Total): 4096 MB Vendor: ATI (0x1002) Device ID: 0x67ef Revision ID: 0x00c0 ROM Revision: 113-C980AF-908 Automatic Graphics Switching: Supported gMux Version: 4.0.29 [3.2.8] EFI Driver Version: 01.00.908 Metal: SupportedSkurjic1 Aug 10
Aug 10 MacBook Pro 15-inch 2017 Hey all, Last week I got: MacBook Pro (15-inch, 2017) Processor: 3.1 GHz Intel Core i7 2TB SSD Radeon Pro 560 with 4GB of GDDR5 memory Touch Bar Just wanted to let those of you who are thinking about buying one of these that it plays WoW on very high setting like an absolute dream!! Ive played over the years on a variety of Mac laptops and Desktops and this thing beats them all to date hands down! My performance has been EXCELLENT! Even in areas I have to lower settings a bit on my maxed out late 27" 2015 iMac (AMD Radeon R9 M395X with 4GB) its handling without a single stutter. (and WoW is IMO very good on that machine). Im playing with settings at: Windowed (Fullscreen), vsync: enabled, Texture Resolution: High, Texture Filtering: 16x, Projected Textures: Enabled, All Environment settings at 10, Shadow Quality: high, Liquid Detail: high, sunshafts: disabled, Particle Density: Good, SSAO: disabled, Depth Effects: Disabled, Lighting Quality: High, Outline Mode: disabled. Am I getting 10000 fps? No, very generally speaking I see fps in the 40s to 60 (Have it capped at 60) range yet regardless of "the numbers" its constantly smooth every where including in 20+ members raids. I replaced a maxed out late 2013 15" MBP with the NVIDIA GeForce GT 750M with 2GB video ram which ran WoW even at low settings like trash. This thing blows it away hands down. (Personally, I blame NVIDIA but thats another post). If you are looking for a Mac laptop that can finally play WoW with high settings and the game looking simply amazing this is the one finally. The touch bar is also pretty cool and I find myself using it more and more often. The keyboard feel on it IMO is very nice though might take some users a bit to get used to. I have no issue with it at all tho Ive always used an external keyboard and mouse with my laptops traditionally just because preferences. (Which I might also add the new "magic" keyboard is extremely nice). In all honesty my settings above are how Im running the game and its a dream. I highly recommend. I even find the game performance on the Mac side a small bit better than I am running on the same laptop under Windows 10 using bootcamp. (thats a first!) Big /salute to Blizzard and Apple on this one. (would love to see more touch bar support for WoW tho! and battle.net facebook streaming integration) ;) /just my 2 copper! :) (ps - as always, get yourself smc fan control and run those fans! Tho quite honestly I can report without it I dont see the temps hitting any higher than previous MacBook Pros Ive played on its always good to keep it cool while playing! The fans are actually quite quiet on this thing at maxed speeds unlike my previous MBP!)Bermy4 Aug 10
Aug 10 OSX Mavericks and Razer Naga Issue I've upgraded to Mavericks and now it seems that Shift, CTRL, and CMD will not work in combination with the number buttons on the mouse, though they seem to work fine on the keyboard. Is this an issue with the Razer drivers or my WoW client?Vinum51 Aug 10
Aug 9 G502 gaming mouse Logitech g502 I just purchased my first gaming mouse for my Mac air. I am trying to figure out how to get the buttons to work. Ex- I set up walk foward and backward on the two side buttons and it did not work. Can anyone guide me to the proper place to configure this. Thank you so much.Bellalilac0 Aug 9
Aug 9 Mac help needed Just spent all day restoring my friends mac with a clean OSX install and reinstalled WoW and he's got literally 4 minute load screens every time he zones. It's a late 2013 Mac desktop with the same specs (+ a better video card) than my 2013 mac laptop which doesn't have the issue. I figured maybe he's not tech savvy and had butchered some settings, got an infection, etc, but a clean install of the OS, battle.net client, and WoW (without any addons) didn't solve the issue. Need advice on what to try next! Thanks in advance.Lawlidari7 Aug 9
Aug 9 Character gets stuck spinning Hello, Starting after patch 6.1, I have noticed an issue where my character will be stuck in a constant spin loop after pressing one of the turn direction keys. I have turn left/right bound to A/left arrow and D/right arrow respectively. I have noticed this issue occurring after pressing either the letter keys or the arrow keys on my keyboard. I don't know if this is related to 6.1, but I did not experience this issue before Tuesday. Mac OS X 10.10.2 I also use the Logitech G600 MMO mouse and have the Logitech Gaming Software installed. I'm not sure if this could be causing any issues but I used it for a couple months prior and never had any issues. But I noticed that this happens when using the keyboard to turn (which is the iMac Bluetooth keyboard that came with the computer). I'm not sure what I've done to stop my character from spinning, it happened last night in my raid and I just started randomly pressing/clicking buttons to make it go away. This morning it happened in my garrison after pressing the right arrow key on my keyboard.Cade8 Aug 9
Aug 8 Frequently disconnecting Every since yesterday for some reason I'm having a lot of problems with disconnecting. Never had a problem before with this but it kind of came out of no where and now i get booted every 5-10 minutes of being in game. Any suggestions/solutions for this?? Thank you.Alastõr0 Aug 8
Aug 8 Playing in bootcamp? Like most of you, the update to metal improved performance drastically, until 7.2.5 when the game became extremely clunky. I have updated nVidia and OS as they come available and reset my PRAM regularly. I am, of course, open to any other suggestions for performance improvement. With that said, has anyone tried running WoW in bootcamp with the same add-on setup as your macOS install? I feel like this would be a good test to determine if the issues are macOS related or hardware related.. I'm just curious, I might set this up today and test it out..Coberne2 Aug 8
Aug 7 /reload ui is anyone else having problems with the command /reload ui. where some or all your spells icon disappear? Astis25 Aug 7
Aug 7 Razer Nostromo I recently bought a new iMac and since it is running OS 10.7 Lion my old n52te is now incompatible. I can't imagine playing without my gamepad at this point so I was thinking of purchasing the replacement Razer Nostromo. However, the current Razer driver (from Sept 2011) officially supports 10.5 and 10.6. However, Razer states that the driver is fully functional with 10.7 but may have a few glitches... ... Can anyone confirm that the Nostromo and current drivers function with OS 10.7 Lion before I go fork out the cash for a replacement device?Vadya16 Aug 7
Aug 6 iMac and WoW issues Okay, so I've purchased a new iMac (Retina 5k, 27 inch, 3.2 GHz intel core i5, 8GB RAM) Now let me preface this by saying that I've had problems with this computer since a few days after I bought it. I took it back to the Apple retailer (not the official Apple Store but an authorised Apple dealer), they performed diagnostics on it and insisted that everything was working "fine" and as intended. I've been having a number of issues with it but the ones that have also affected my game play are the display issues, like glitches, screen artefacts, blocks of unloaded graphics (like actual squares in-game that don't display game graphics but are black or transparent glitchy squares / blocks). There are also frequent disconnects as well as flickering of the question marks or exclamation marks above an NPC's head. Sometimes they don't show at all. Is this normal or a software / hardware issue? Apple retailer insists this Mac is "fine" and that "nothing is wrong with it". And yet I'm still I'm still having all these issues. I'm not necessarily expecting a response or resolution to these issues. Rather, I'm just giving you guys a heads up so you can work with the Apple / Mac department and be aware of these issues. Thank you for your time.Feenimartini8 Aug 6
Aug 6 crashing on launcher and login Launcher won't update and game auto disconnects when I try to log I just purchased this Mac book pro late 2013 i7 running Sierra I fully erased the whole Mac and did a fresh install on the os. When I tried to install the game through the client I get a few different errors and also when I try to log in it just auto disconnect me. BLZBNTAGT00000BB8 is the error I get when I try to update also the update is stuck at about 50%. Im a pc guy this is my first Mac so I'm lost and would appreciate any help you guys could give me thanks in advance.Bobbysmurda1 Aug 6
Aug 5 2017 27" 5k iMac Performance Hey everyone, So I am going to purchase the newly updated 2017 27" 5k iMac with the 4.2 Ghz i7 7770k CPU, 64GB RAM ( OWC not Apple since it's cheaper), AMD Radeon Pro 580 8GB VRAM GPU, and 1 TB SSD. Do you think I should be able to run WoW at the Retina 5k resolution on max settings and get a decent playing experience? I understand it's a scaled 5k not a true 5k resolution because that would be insane but do you guys think this config will be powerful enough? Also any other iMac players in here enjoy playing wow on their retina iMac? What current settings are you running? I'm coming from a 2013 Retina MacBook Pro with GeForce GT 650m.Rush26 Aug 5
Aug 3 In game shop errors Macbook mid 2010 OS Sierra 10.12.3 The problem: I cannot purchase anything from the in game shop. Mostly just trying to purchase a token. I can however, purchase from the online website just fine. Obviously, you can't purchase tokens online though. What I have tried to fix the issue: Disabled addons. Renamed folders to interface.old, cache.old, etc... Disabled anti virus program. Later, deleting the anti virus program completely. Made sure firewall allowed battle.net and wow through. Later, disabled firewall completely. Made sure credit card info was up to date. (It was.) Deleted credit card info, reapplied the info. Changed payment over to another card. Changed payment to paypal. Changed payment to battle.net balance. Updated OS. Scan and Repair WoW files. Uninstalled/Reinstalled Battle.net app and WoW. Reset Router. Checked forums for other potential solutions. None of the above has worked. Most of these troubleshooting ideas came from GM's I've talked to via tickets. Wanting to see what else can be done. I was able to purchase tokens before Legion with the same credit card and computer set up I have now. Thanks.Moonsugar2 Aug 3
Aug 3 Mac State of the Art Hi! Been a long time since I played WoW on my Mac (multiple years) and with my 2017 MBP, and an eGPU in the future, I am checking it out. It's not very smooth, unfortunately. On 10.12.6, I can't get WoW to match my screen resolution. All I get are lower FPS. I am using Metal, but all I get is just slower and slower peformance, no extra actual resolution. Command-tabbing works, but is very slow compared to Windows. It seems to be changing the display resolution. I have tried leaving the mac in 1680x1050 and the game in 1650x1050. Why don't these resolutions match? I have tried lowering my screen to 1440x900 but that doesn't seem to affect wow. I have tried various defaults settings in the forums, but nothing seems to help. The performance on this laptop is not as good as the 860m in my 2.5 year old PC Alienware laptop. Apple frustrates me so. Is this really the Mac State of the Art? Am I foolish to think an eGPU is going to make this a viable platform?Whelma2 Aug 3
Aug 3 Tries do DL update and keeps crashing. Every few mins my wow client keeps crashing and the game does a split second update and just lags out the client. Any help?Jaxthrax0 Aug 3
Aug 2 Correct settings for 2017 27in retina imac? Started up warcraft and just about threw up. my brand new imac with more memory than my lil 21.5 inch was making the game look like 1997. low rez and blocky. Now I realize this is due to the migration and the settings being for the old computer. but as Im trying to figure out what the heck to set things at for the new computer...ugh. when I select "recommended" it makes the game windowed and tiny and sets it to the lowest setting possible. THIS IS A HIGH END computer compared to my old 21.5 so it should be showing me BETTER graphics not worse. I figure the problem is on my end. My computer is scaled up one setting because I have a hard time reading tiny text. Ive now got the game set full screen at 5120x2880 and moved the details up to "2". Things look better, however, Im thinking with this baby I should be able to push the graphics up for greater detail. The refresh rate is at 60, however is also greyed out. which means it might not be 60 frame rate and no way the game will let me change it. not sure I should touch that even if I could. Any tips for getting the best out of the game with my snappy new imac would be appreciated. details on my imac imac: Retina 5K, 27-inch, 2017 processor: 3.8 GHz Intel Core i5 memory: 16 GB 2400 MHz DDR4 graphics: Radeon Pro 580 8192 MBVéla4 Aug 2
Aug 2 wow51900323 error on load wow51900323 error on load, I can't switch servers. This started when I switched servers from area52 to stormrage and now I can't login to the game. As soon as I see the retrieving servers the games exits to the login screen.Screwdy1 Aug 2
Aug 2 MAC INGAME STORE PROB SOLUTION I could buy NOTHING via ingame store. Others in my household could. I decided this must be an Apple problem. I searched. Found this page on their official community site. I followed the steps. AND IT WORKED!!! Blizzard customer support has been trying to help me patiently for quite a while. THIS IS THE ANSWER for people running Sierra or newer OS on MAC: https://support.apple.com/en-us/HT203538Tynaqua0 Aug 2
Aug 2 Latest Patch ate my frame-rate Went from 50-60 fps on a iMac Retina 4k 21.5 Late 2015 3.3 Ghz Intel Core i7 with the crappy intel Iris Pro Graphics 6200 1536 MB to 20 -25 fps with the last patch. 20 to 25 F. P. friction' S. Everything was set at "3" the suggested Wow graphics setting. WTF Bliz? <edit: forgot to put what fps fell to.>Chagas2 Aug 2
Aug 2 Wow crashes on load OSX 10.11.6 machine is a Mac Pro (early 2008), with a GTX 680. 28GB of RAM and around 500 GB of drive space free. When I launch WoW, the only console log message is this: Aug 2 11:12:39 Durandal kernel[0]: World of Warcraf[651] triggered unnest of range 0x7fff8b400000->0x7fff8b600000 of DYLD shared region in VM map 0xe5afc52fe99290b7. While not abnormal for debuggers, this increases system memory footprint until the target exits. followed by: Aug 2 11:12:42 Durandal WindowServer[217]: Untrusted client (pid=651) attempted to set debug options. The game just vanishes from the dock, no error dialog. This is launching from the battle.net application. Launching from the game directory gives the same behavior. I have zapped NVRAM and disabled the nvidia web driver, same result. I haven't played in a few months and just re-upped my subscription, so no clue when this may have started. No files are in the /World of Warcraft/Errors/ directory.Rheus1 Aug 2
Aug 1 5K iMac overheating on macOS 10.12.6 Ever since I installed Sierra 10.12.6 my 5K iMac (late 2014) is gong to sleep at times while running World of Warcraft. Even with SMCfancontrol on, which used to cool the system off enough to run the game. What did Apple do to macOS Sierra 10.12.6 that is causing this overheating? The game ran fine before I updated.Forumtard1 Aug 1