Imp bugged. Unable to get Imp to attack

Bug Report
Last night on Ravenholdt I was doing some random BGs. In between the BGs I was killing random mobs just for fun and random loot drops. I noticed that between me casting immolate and conflag usually I see my imp cast something. I always have him on defensive during these forays into killing randoms.

But, my Imp didn't cast anything. So, I decided to give him a chance to be aggressive and go after things himself, then I would help him kill. He didn't agro on anything no matter how close I got to the mobs.

I tried pushing Pet Attack and the Imp just stayed still. He bobbed up and down like normal, but no casting no damage done, nothing. I thought maybe I should bring a different demon out and then go back to the Imp, again he did nothing.

Since I am destro as my main spec I don't like to run around without my Imp around to give me extra crit chances. But, he wasn't working for me, so I used my doggy.

After about an hour of the doggy, which I found new respect for, I switched back to the imp yet he was still bugged.

I logged out of wow and logged back in, still bugged.

I exited game and logged back in, still bugged.

No matter what I did, my Imp wouldn't attack.

I hope this bug doesn't stay around for awhile, but for the meantime, I am enjoying playing my character differently.
Is your imp phased out, and if so, have you tried deactivating his phase out ability and seeing if that has any effect? I know usually he will just enable / disable it himself, but it's possible the bug is isolated to his Phase Shift ability.

Also check to make sure that Firebolt is set to auto-cast (this can be toggled by right-clicking the spell on your pet bar). If it's not, telling it to attack will cause it to idle since there's nothing else it can do but cast Firebolt.

Join the Conversation

Return to Forum