Patch 4.0.3 Blizzard Downloader issues

Mac Technical Support
Alright, so on this Blizzard Downloader, it stops at 22.7MB / 23.0MB.. It has been stuck here for about 45min.. Idk what I need to do, but any assistance would be greatly appreciated. Thanks.
You and me both, 22.7 98% and it has not completed now in 7 hours...
Man it sucks.. I've looked all over for help and can't find anything. Wish i could get some help with this. :(
How can I fix my permissions on the entire WoW folder?
Most installation problems can be resolved with some basic system maintenance.

First, make sure you have a Shared folder in Macintosh HD/Users/. If you don't, you'll need to create one:

- Navigate to Macintosh HD/Users/.
- Click File -> New Folder.
- Call the new folder Shared.
- Once it's created, highlight the folder and press Command (Apple) + I (as in Igloo).
- At the bottom of the info window, find "Ownership & Permissions" or "Sharing & Permissions."
- Click the padlock and enter your Admin password.
- Make sure that "Everybody" has Read/Write permissions.
- Click the cog (burst/flower) and choose "Apply to Enclosed Items."

Please use the steps below to repair file permission settings on the hard drive.

1. Navigate to /Applications/Utilities/ and open Disk Utility
2. Select the hard drive the game is installed on
3. Select the First Aid option
4. Click on the Repair Disk Permissions button

Repair Directory Procedure:

1. Shut down the computer.
2. Power up holding Cmd (Apple) +s until you get a black screen with white type
3. At the cursor please type the following: /sbin/fsck -f -y and press return
*NOTE - Please be aware that some of the procedures will look like they are frozen, but are actually taking a long time i.e. checking hierarchy
4. If anything had to be repaired, repeat step 3. Do this until it says "The Volume appears to be OK."
5. Once things are repaired type exit and press return
6. Computer will boot into Mac OS

You can also try creating a new admin account:
1. Go to Apple menu => System Preferences => Accounts.
2. Create a new Admin account. You will need to authorize by clicking the padlock and entering your admin password.
3. Log into that account.
4. Use that account to install the the Applications folder.

I would also recommend running the Apple Hardware Test. You will need to have the original disc your computer was shipped with mounted in the drive. Hold down the "D" key while rebooting to get into the Apple Hardware Test from the choices.

I'd recommend an extended test of all hardware, looping if that's possible. That will let us know for sure if there are any hardware problems. If it reports any hardware issues, you'll want to contact a local Apple Service Provider to address those.
ok, so none of that stuff seemed to work, still stuck at 98% for a day now...never had any issue like this with previous patches, should i try reinstalling wow, or something?
Did that, didn't work. So I'm just going to smile and nod and say it was fun while it lasted. Good luck to the rest of you mac users and those of you overseas. I hope someone posts a mirror for you guys to get an actual update for the game. Take care!!
Same, did all of those things, no luck. This is really aggravating since this is still broken for 2 DAYS.
Hi all,

We are trying to track this issue as it seems to be affecting both Mac and PC. If you are having this issue, please send us your system profiler so we can research this issue.

1. Click the Apple in the upper left hand corner and choose "About this Mac."
2. Click the "More Info" button.
3. When the System Profiler is finished gathering its data, click "File" then "Save As..."
4. Add your name to the filename, and save it to your desktop for easy location.
5. Email as an attachment to macsupport@blizzard.com

________________________________________________
Account and Technical Services|| Mac Tech Support Tue-Sat 9am - 5pm CST
Can't find a resolution on the forums, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
Do you love Boomkins? Sure we all do!
Wait I mean, take a moment rate how I am doing: <a href="http://www.surveymk.com/s/RF8K3KG" target="_new">http://www.surveymk.com/s/RF8K3KG</a>

Join the Conversation

Return to Forum