Push to talk Ventrilo

Mac Technical Support
I know this is a common problem, but when I Maximize WoW and press my push-to-talk button through Ventrilo, it does not capture my voice. Obviously when I click my ventrilo tab open, the Push-To-Talk DOES capture my voice

I know what you are all about to ask me: "Did you Enable Access for Assistive Devices"?

Yes I did and this does not seem to work.

I just got this MacBook Pro recently and am new to Mac computer devices

Any help would be great! =) (Sorry if my language is poor, I'm half-asleep! D:)
What key are you using? It may be one that WoW captures... FWIW, I use the option key which seems to work fine with the game full screen. As it's a modifier key and not a keystroke to WoW, it works. BTW, works in Vent OR Mumble.
Make sure that you do have Assistive Devices enabled, and after you do that you may need to quit and relaunch Ventrillo.

Also if you just upgraded to OS X Mavericks (10.9) it reset the Assistive Devices option and moved it. It now falls under System Preferences/Security&Privacy/Privacy/Accessibility - Make sure that you have checked Vent as being allowed.
I am having the same problem. I have added the accessibility and it still does not work. I have uninstalled Ventrilo and reinstalled it. I have tried over a dozen different push to talk buttons and cannot get it to work. It only works in ventrilo>setup>test screen now. Any ideas would be welcomed. Ventrilo does not offer a solution yet.
same issue i have my talk button set to my mouse it works on the key binds however not my mouse bind
Do you have Mac OS 10.9 Maverick?
I had this working fine until I updated to 10.9 Maverick.

Now it's back to the original not-working state and there is no such check box as "enable access for assistive devices" anymore.

I flipped through the various accessibility settings and I don't see anything obvious that would be the same.

Any ideas?
For OS X 10.9 Mavericks:

System Preferences > Security & Privacy > Privacy tab

Click on Accessibility on the left, and you should see Ventrilo on the right. Make sure that is checked.

Make sure you quit and relaunch Ventrilo after that, and it should work normally again.
Hoarfroste is correct.

If after that and it still doesn't work, click on configure and run your audio wizard again. That worked for me.
Where is that configure button and audio wizard option? I enabled the accessibility for vent per the instructions for Maverick, but my PTT still doesn't work.

Thanks for the help.
Hey, I had the same problem and did everything posted here and in other threads, finally the thing that worked for me was changing the key bind, no sure if it was the solution all along or it took the combination of several things such as this post suggest, but thought I would mention it, so maybe it would work for someone else.
When I use PTT on Ventrilo, I use my Control Key. Works fine for me.
I am having the same problem but instead when I go into the privacy settings and so on, vent doesn't even show up in my list of options to give it access to. Any ideas?
Same exact issue. Vent used to work, then stopped one day for no apparent reason. I have tried all of the above suggestions:

1) Set the accessibility
2) Change the binding
3) Reinstall
4) Reboot all of these

Still no luck. The test works and I hear the click acknowledgement, but when I exit setup, from the vent panel, there is not response from Vent when the 'command' key is hit for PTT. I do not see anywhere that Audio setup can be done again ... is this from Vent or some other space?
Thanks for the answers to this! I upgraded to Mavericks and started having problems. I didn't realize the settings had been moved.
So, I was going through the same issue for a couple of weeks, without an end in sight. I did everything imaginable to get this to work. I JUST figured it out, and now I feel kinda dumb.

On your vent, at the bottom when you're in the room (not in setup) make sure "Mute Microphone/Binds" is not checked. I hadn't realized this was there..

Hope this helps everyone who has tried everything else.

Join the Conversation

Return to Forum