Ventrilo push to talk not functioning in 10.9

Mac Technical Support
To be more accurate, it only works when vent is at the forefront. When I switch to my WoW window (or any other application for that matter) my PTT button no longer works, though I can still hear the others in vent. Made for a frustrating night in raiding? This issue only started to occur after I installed OXS 10.9. Anyone else having this problem?
+1
I had the same problem, so here is the solution to fix it:
Step 1: Open System Preferences
Step 2: Open Security & Privacy
Step 3: Click Accessibilty (you should see Ventrilo listed to the right)
Step 4: Click -"Click the lock to make changes"
Step 5: Enter password
Step 6: Put a check in the box next to Ventrilo
Step 7: Restart your iMac
Step 8: Start Ventrilo
Step 9: Start WOW
Step 10: Give it a try
I hope this helps you, it worked for me
Thank you for your help, yes it worked. I am requesting a sticky because I assume many raiders use vent and this solution will be helpful to them also.
First of all, Shock, don't post in 3 separate threads with the same question. Second, this isn't sticky worthy. The vast majority of Mac users already know how to add Vent to assistive devices. It changed slightly in Mavericks, but it wasn't hard to figure out.
I would only add that if the application isn't already showing up in the "Allow the apps to control your computer" pane, you can manually drag it from a finder window onto that pane. Such is the case with Mumble.
I googled "mavericks mumble" and found Donsy's thread at :

http://us.battle.net/wow/en/forum/topic/10357205703

Shouldn't be too hard to find.

If you want you can add it to the existing Mavericks sticky.
So I just upgraded yesterday and tried to fix my vent using this, thanks for it btw. But it is still not working. Any other ideas? or anyone else it still not working for?
There are two different issues. Some say you also have to disable power nap, or mumble/vent only work if the app is in front. This is done by choosing "get Info" in finder on each app and checking option to prevent power nap.
First of all, Shock, don't post in 3 separate threads with the same question. Second, this isn't sticky worthy. The vast majority of Mac users already know how to add Vent to assistive devices. It changed slightly in Mavericks, but it wasn't hard to figure out.


Well, the vast majority of Mac users know how to follow the instructions given in vent that no longer work in 10.9, and I ended up looking in the completely wrong area, so this might be sticky worthy. I mean, I'm glad you're super smart, but I had to find this through Google.
Thanks Omegal, I tried that, still doesn't work.
So I have done everything I could find, nothing would work...then I just changed my key bind to something else, in this case I used the command key...worked like a champ, so if you have tried everything, maybe just change key bind?
Worked like a charm. I too had to find this through Google.

Thanks for making my raid night a little better.
I'm having the same problem
same problem. thank you, google, because even though i've been using macs since the original macintosh, this was really puzzling me. hopefully disabling the power nap thing works, because my accessibility settings were already right. if not, i'll try trying a new keybind.
Changing key bindings worked for me.
Another easy option is to use any modifier key (Control, Option or Command) as your Push-To-Talk key. This should work without modifying anything in System Preferences. Additionally, if following the instructions posted earlier in this thread, you should only have to restart Ventrilo and not the entire operating system.
The main issue i found when trying this was the fact that my key binding for PTT was already bound to another thing in WOW.

If you can find a key that is not bound to something in wow and set that to your PTT you should not have any issue
Downloaded latest Vent release, running current Yosemite (OS X 10.10.5), have checked "Allow Vent" in privacy prefs. Still cannot use PTT, although I can hear others though headset (Kingston HyperX Cloud). Have tried all the troubleshooting steps listed for Macs in the Vent forum. Can't even hear myself in Vent's Setup Test.

Any ideas or more thorough instructions on how to have a fully functional Vent would be most welcomed and appreciated.

Thanks!
Downloaded latest Vent release, running current Yosemite (OS X 10.10.5), have checked "Allow Vent" in privacy prefs. Still cannot use PTT, although I can hear others (on a Vent test server) though headset (Kingston HyperX Cloud). Have tried all the troubleshooting steps listed for Macs in the Vent forum. Can't even hear myself in Vent's Setup Test.

Any ideas or more thorough instructions on how to have a fully functional Vent would be most welcomed and appreciated.

Thanks!

Join the Conversation

Return to Forum