Cant use the launcher

Technical Support
start the launcher and it gets to downloading the installer to install the patch, but only goes up about a half of a inch then just randomly closes out.

I have tried multiple ways to fix this. I also have NO WAY to get into my router so I can use the new 'streaming launcher' sense its like a bit torrunt, I am not allowed to download like that.

I am yet wondering if there is another way around this issue so I can play, I don't enjoy giving my money to a company that can't allow a MIRROR download, so I can play.
I seem to be having the same problem I play from Ubuntu on Linux...

I ran it again and again and this time it seems to be working, try running it again if you have this problem.
I ran it over and over again. probably around 10 or 15 times. Still no luck for me.
ive been having issues with launcher.exe as well; i find it sometimes runs better from terminal; so try running the command from there.
wine "/home/username/.wine/drive_c/Program Files/World of Warcraft/Launcher.exe"

Join the Conversation

Return to Forum