Cannot enter Redridge Mountains

Technical Support
Everytime I try to enter the Redridge Mountains,I get disconnected. Wehter flying,mounted or walking. Has anyone else had a similar problem entering an area???
We're seeing some reports where people in this region can try lowering their video settings to get around the disconnect but haven't been able to pinpoint what's happening there yet. Have you tried running the game launcher to see if it has to download more data?

Account and Technical Services
Can't find a resolution on the forums? Contact a support representative directly:

Great minds discuss ideas; Average minds discuss events; Small minds discuss people.
EDIT: Whoops...I forgot I logged out at Elwynn.
Is this what also affected those of us who started getting disconnects on 11/23/10 when we were first disconnected in midflight to redrige mountain?
I had this exact same issue, being disconnected when approaching Redridge.
Seems to be some problem with the area graphics. (the game is fully downloaded here)

One workaround that worked for me is setting the view distance to "low".
I'm Having a similar problem in Barrens, a huge part of northern barrens just isn't there, what should I do? the launcher does not download any data, it says that I can play normally, well, when i get close to the missing area WoW freezes and also my computer, i have to restart it manually because WoW don't crash at all.
i have the same problem i have 2 characters in red ridge and i cant access either of them, but i can play all my others characters fine
I believe people were posting me about this in other threads and I thought they meant aim to veiw low while I was flying the gryphon...I told them that I couldn't reconnect to do that. Now I believe you and those folks are talking about a setting I can access. Is this right? If so, where and how do I change the veiw difference to low. TY, Frewofstew
i'am getting disconnected as well, but now i can't log in to my 43 human worrior, he is i the redridge mountains as well, tried the launcher as well but that didn't work.
It worked I got my 53 Paladin back from the ride to Redridge Mountains! I went to log-in screen and chose Options and then Video options. There I found the video settings. Mine was on Good. I changed it to Low and logged into my Paladin and what do you know...I was was now continuing the flight to Redridge Moutains...which I completed successfully. I then flew back to Goldshire with no problem. Distance doesn't look as good...but now that I am out of Redridge I will change Video settings back to Good and will use this fix if I need it again. I want to apologize to folks that were trying to tell me in other threads. I wasn't understanding. I thought you were talking about steering the Gryphon low...which I couldn't do unless I could log in. Duh!!! Thank You all and good luck to everyone else with this fix.
Ahhhh...thanks to whoever posted the video fix!!!!! I haven't been able to log in for almost 3 days, just kept getting disconnects whenever my bar was loading but I had been in redridge prior. Contacted Blizzard and they had no idea, finally saw this thread set all my video to low and was able to log in. Thanks a million!
Yes, me too. And I can enter game now, every time is disconnect from the server
Problem Solved when you turn down the Resolution to LOW.

Thanks Guys!
I had the same problem too. 2 days of trying to figure it out, including erasing and reinstalling the game, before i read this forum. lowering the video resolution worked. I was able to exit Redridge and reset my video again in Elwynn where it's playing normally again.

Join the Conversation

Return to Forum