Can't Log Into My Account!

Technical Support
Well, every time I try to log into my account since I downloaded patch 4.0.3a I get the error message , "There was a problem logging in with this account. You may not have a World of Warcraft game attached to your account, or you may be logging into a different region than the one you created the account in."

My account is in good standing, I have confirmed this with customer service.

While I have recently moved houses, I still live the same county as my old residence within the United States albeit with a different internet provider.

I am INDEED using my email/password to try to log in and NOT my WoW account name and password.

I have ran the system repair tool from the main WoW folder and it said that there were no problems detected, but when I tried running the repair tool from the newer 4.0.3a launcher... it told me that it could not repair my problem and that I should attempt to reinstall WoW.

I deleted my WTF, Cache, and Interface folders.

Even after doing all that I STILL recieve the same error message when I try to log in... PLEASE help! Thanks!
There's a really good chance that you're not using a North American version of the game. Try deleting your World of Warcraft folder and try this -

Account and Technical Services
Can't find a resolution on the forums? Contact a support representative directly:

Great minds discuss ideas; Average minds discuss events; Small minds discuss people.
I'm having the same issue, but when I click that link it says that it's not found.
Rihannon, click on EXPLORE at the top of the page, and then Game Client Downloads.

This link will take you there too:

This is the direct link to the Downloader:

If that doesn't help, please create your own thread.
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly:
'Black holes are where God divided by zero.'
Rate Me!

Join the Conversation

Return to Forum