Launcher cannot get Patch Info

Technical Support
First off, I have tried everything here (that relates to a Windows 7 machine and except booting in safemode which I'll do shortly):

This includes uninstalling AVG and disabling Window's native firewalls as well. I am on an university network, and no, they wont change any settings. (Already fought that battle. =/)

I've had this issue in the past, and getting the WoW.tfil has fixed it. However, this time it didn't and I'm not sure why. Could someone post a confirmed latest patch tfil? I've tried using tfils posted only 2 days ago and none of them work.

Any additional help would be appreciated.
Tried safe mode. No luck.
Check and see if the tfil file you add is still there or if it is being deleted when you start. I'm in the same boat and I noticed my tfil keeps getting deleted.
I've noticed the file purge as well.
Ok just making sure I wasn't the only one. This is getting ridiculous and still being ignored.
I went down to my nearest open WiFi spot (a coffeshop) with my laptop and patched it. After stealing the tfil from my laptop, my desktop started downloading without issue. I have no idea why that tfil wasn't purged. =/ But if you have a laptop, it may work for you.
Ha welll the school I go to doesn't let you just leave whenever so I'll have to try to do that this weekend when I'm allowed out. If only blizz could just fix this so we didnt have to go all the way around the world to get something done...

Join the Conversation

Return to Forum