Cape of Stranglethorn Quests Achievement

Also did Cape before Northern. When I do Northern, will it fix it?
Also did Cape before Northern. When I do Northern, will it fix it?

A few people on this thread have tried, and apparently it's given no extra quests for Cape, unfortunately.
Are people getting the Message in the Bottle? There's like, 3 quests right there that takes you out to the Princess to help her escape. I dunno. Shot in the dark since the quest is gotten on the beach near BB.
Also stuck at 57/60 but i may have come across what is causing the issue.
I did cape before northern stv and did all the quests before going to north stv, currently i finished which should lead into
On completing this quest a whole new quest chain is available to you of around 4 quests at HH

Problem being i am not getting the quest that gives me the free ride to Hardwrench Hideaway from bambala.

So awaiting a hotfix or a bluepost regarding this issue for players that went to Hardwrench hideaway before completing the northern stv quest chain
Did Cape first, can't get the flight to Hardwrench to continue the Mogg'osh artifact chain. Never offered the Holy Water of Clarity I am stuck at the same place as many others, and there is no solution.
There's a quest at Stardust Spire in Ashenvale, near the border of Stonetalon that is "rebels without a clue." Takes you to STV. This may be the quest you're looking for.
55/60, did Cape first. Scouring through this thread and the zone itself and I want to pull all my hair out, 5 quests from finishing EK and I can't do crap about it. Wish I could at least finish the bugged quest Let's See What You've Got, Zanzil. Help me blues, help us all.
I opened a ticket on this issue about 3 days ago. Finally got a response today via in game mail.

Very generic response: "We are aware of the issue you have mentioned" etc.

I guess we can just hope that it'll be hotfixed shortly.
I had a couple extra quests in northern STV, but the cape is stuck at 57/60. This is my last zone for the continent meta achievement, so I'm no stranger to completing them. I completed the quest for the arena (getting the arena token I assume?), but I still cannot find the one I need. I did not complete any quests for being sent to the zone, and am currently checking which zone would send me there to see if that gives me another.

The Holy Water of Clarity quest wasn't offered for me. I also started in Booty Bay and worked northwards, so I didn't get any quest that gave a free ride to HH.

Update: Upon taking the boat to Ratchet to check for any "go to Booty Bay" style quests, my quest count for the cape lowered from 57/60 to 56/60.
I did randomly find a dropped quest when I thought I would come up short. Its a coin that drops off the worgen pirate sleeping where Duncan used to be outside BB.

Thank you for that. Although I'm still stuck, just at 57 instead of 56 now.

Completing this quest brought me back up to 57, though I'm completely certain that I had 57 before taking the boat to Ratchet. This isn't really surprising though, my quests completed for the 3000 quests achievement has been changing by about 550 quests every time I go through a load screen. It drops when I load, and goes back up when I complete another quest.
This isn't really surprising though, my quests completed for the 3000 quests achievement has been changing by about 550 quests every time I go through a load screen. It drops when I load, and goes back up when I complete another quest.

That is an add-on messing with your quest count, you are not actually losing any quests.

I too am stuck with the Cape quests though I think I am stuck at 55/60. I completed ever quest in NSTV and a number in the areas that should lead to quests in the Cape but have not found any new chains. Think Blizz needs to go back and change the # needed.

BTW thanks Blizz for making me do the Nesingwary it was annoying and I am disappointed that I did not get double credit for completing the chain again.
I don't think Alliance will be able to get this achievement. I put in a ticket to a GM and his response was with the shattering of Azeroth some quests and quests items are unavailable now. I put in a follow up ticket to verify he meant Alliance won't be able to get achievement. Pretty lame if we can't get it, yet another thing for Horde to have that Alliance doesn't.
Just talked to a GM and he said they were aware of the problem on Alliance side and that the reason MAY* (not to quote him) be that some quests chains haven't been released yet (meaning released ion Cata)
This is crap. I have been all over the Cape looking for a quest I missed, did the bottle, the coin, the arena, read something about a hand that drops in Northern STV got that, turned it in, talked to the guy at bambala, got the box, opened it, did a few other quests there that were offered as well even though i completed northern STV already, hoping it would lead me back to the cape. And what do we know. NOTHING. No free ride to HH, I know the NPC that should be giving me quests is Flem Gizzix, havent done a single quest for him yet, and Wowhead says he gives quests. But yet has nothing for me. Put a ticket in to a GM, got a generic response back, resubmitted the ticket, got another generic response back, this time telling me to check the forums, since they wont tell me where the quest is at. Honestly I think its just *%@@ing bugged and blizzard is being a douche about it with the generic reply on the ticket i got.

P.S. Side note: Started at BB myself, went to HH first then did northern so if its a bug from doing it that way. Great job Blizzard!
Horde, Alliance who cares who gets what.

The Holy Water of Clarity quest used to be a 'discovered' quest when you went to the top of the hill and 'found' the well while gathering Akiris Reed. It was converted to a given quest for Cataclysm. From all the posts I've read you can do Cape before Northern as long as you skip Hardwrench Hideaway quests before you finish your Northern STV quests. This seems to be how nearly everyone achieved Cape of Stranglethorn Quests.

I've done the Message in a Bottle, Arena, and all the other quests in Cape, with the exception of the Coin and Warchief's Command: Stranglethorn!, and am still at 57 of 60. I've noticed that if you start questing in certain zones you can no longer do Warchief's Command for that zone. During the Bloodsail vs Booty Bay questline I gained no rep at all with SW Cartel as I was already exalted, but my Bloodsail went down from Honored to Unfriendly during that. Even when I was infiltrating the Bloodsail. Better not mess up my Insane in the Membrane achievement. I can only assume there must be a bug somewhere in there.

I had no trouble with the quest to give Zanzil's mixture to the three prisoners. This zone is bugged much like Ashenvale. I still have seven to complete there and it's a no go. Other than that I've completed all the other zones in the game that are available at this time.
I had put in a ticket a few days ago regarding this and got the generic blizz GM response. They said that they have 80+ quests in the area and I just might being missing some...ummm GG blizz LOL

wtb hot fix...
To the people complaining about the horde getting something the alliance aren't.. most of the posters here are horde. I imagine most of the horde started in Booty Bay or Grom'gol, since that is our normal starting area in Stranglethorn (or at least it used to be), and you don't seem to get a quest leading into either zone as horde (at least, not from the Eastern Kingdoms)... so you kinda get to choose. For all those that chose to start with what used to be our starting area, we can't get it either.
Previous Horde Loremaster, I also started w/ the Cape of Stranglethorn quests.... stuck at 57/60 including the arena quest.

So have we confirmed whether or not anyone has been able to reach 60/60 quests completed in the Cape of Stranglethorn?

Join the Conversation

Return to Forum