Flash acceleration and WoW performance.

Technical Support
Many players find that they have significant performance issues with a Flash application (e.g. YouTube) open in the background. The content can be paused, muted, or even in a tab that's not in focus and the performance loss will still be intact.

Flash content plays using the H.264 codec. This will clock some graphics chips at 400 MHz for the Unified Video Decoder (or UVD for short), assuming you have hardware acceleration enabled. For example, I am able to force my clock speeds to stay at 735 MHz, regardless of whether or not the chip detects 2D, low-power 3D, or high-power 3D. Flash hardware acceleration can and will knock those down to 400 MHz.

When I'm not forcing clocks, they'll be at 157 MHz core when idled/2D, and 735 MHz when any 3D mode is detected. 400 MHz doesn't come into play anywhere with either of my power settings. Yet, 400 MHz is what my graphics cards will clock themselves to when a hardware-accelerated Flash video is open. I can't control this. No one can.

For example, with hardware acceleration enabled, it looks like this:


400 MHz. Once again, I can't control that with any settings. Even forcing 735 MHz through profiles doesn't work; it'll downclock to 400 MHz to play the video back using my GPU to accelerate things. 400 MHz is higher than my 2D clocks, though, which is why a very small portion of the player base may see a performance increase with this. Without hardware acceleration, my GPU's got pretty much nothing to do, defaulting to its lowest clock speeds:


Hardware acceleration can be great, and it can also be quite evil. The changed clock speeds can give you better performance or worse performance, depending on where sat before (i.e. if they were sub-400 MHz in WoW), but this is extremely rare and Flash normally cuts FPS by quite a bit. I get just a bit more than half the clocks when I enable it and play YouTube videos, basically forcing me to disable the acceleration to maintain high FPS in-game.

Note that if you're an ATI/AMD owner that seems to see better FPS with Flash hardware-accelerated videos, you can force your clock speeds to max out as well. More info here:


Another workaround for ATI owners experiencing oddly low clock speeds is enabling the D3D11 API. In DirectX 11 mode, graphics chips tend to stay at their max clocks.

tl;dr: Getting low FPS in WoW with a YouTube video open? Disable Flash hardware acceleration.

One does not demand respect. One earns it.
CORE I7 3.6GHz | 12GB RAM | RADEON 5970 | F120 SSD
Wowpedia technical support page:
For live support, click the #wowtech link
Not sure if I should post this in this, but it's kind of related:

Occasionally while in DX11 mode playing a H.264 will "fix" the alt-tab slowdown issue with 10.12 release drivers.

There is a "new" 10.12 "hotfix" that seems to play nice now, as well. (Though it lists itself as 10.11 in CP)
12/30/2010 3:26 PMPosted by Kuji
Occasionally while in DX11 mode playing a H.264 will "fix" the alt-tab slowdown issue with 10.12 release drivers.

Neat! Thanks for that information. :) I noticed some major alt-tab issues with 10.12 and reverted to 10.10e after that. I'm surprised other players were having issues; I figured it may have just been an issue on my end or a fault of the CrossFire configuration.

I think I'll hold out until 11.0 at this point, but that's some really great information. I hope ATI/AMD can work all of these oddball issues out soon enough.
One does not demand respect. One earns it.
CORE I7 3.4GHz | 12GB RAM | RADEON 5970 | F120 SSD
'Your processor is under that hockey puck thing.' -Dat
For live support, click the #wowtech link
Bumping down from sticky status and putting a blue on it to get some more attention overall. I've linked to this thread from the System Performance Guide.

-sticky thread cleanup-
Account and Technical Services
Can't find a resolution on the forums? Contact a support representative directly: http://us.blizzard.com/en-us/company/about/contact.html

Great minds discuss ideas; Average minds discuss events; Small minds discuss people.
Vial of Tears http://www.surveymk.com/s/RHXXKHK
Sounds good, Dat. I'm just glad that the User Tips and Tricks thread is stickied again. I hated going into the temporary sticky holder to access that. >.>
One does not demand respect. One earns it.
CORE I7 3.4GHz | 12GB RAM | RADEON 5970 | F120 SSD
'Your processor is under that hockey puck thing.' -Dat
For live support, click the #wowtech link
The exactly same problem happens with me. But with some differences:
1) update Windows 7 to SP1
2) update internet explorer 9 (which I don't use by the way)

After some research I found this topic and a friend of mine mentioned that IE9 has hardware acceleration by default. and it was throttling my VGA (ATI HD 6850).

The fix is easy, just disable the hardware acceleration and my fps are back.
Link how to disable it:

Hope it helps someone.
Bottleneck, browser acceleration and video acceleration are two entirely different beasts. Hardware acceleration in a browser uses a variety of tricks to speed up page rendering time using a GPU; it does not (or, at least, shouldn't) affect a video card's clock speeds. Mozilla posted a great article last September with a fair bit of information on browser hardware acceleration here:


Additionally, I've done a bit more reading up on this issue, and unfortunately, this is an issue that absolutely cannot be fixed in a driver update. That's why I posted about how the problem occurs even when I attempt to force my clock speeds through a profile. So long as you're watching hardware-accelerated Flash videos on certain video hardware, you will run into these significant framerate drops. The only way this could be at all fixed is through a video BIOS update, which - at this point - is highly unlikely. For the time being, the only valid workaround short of not having Flash videos in the background at all is to disable the acceleration.
The wise speak only of what they know. - J.R.R. Tolkien
CORE I7 3.4GHz | 12GB RAM | ATI 5970+5870 | F120 SSD
Live Support: irc://chat.freenode.net/wowtech
Sorry for this horrible necro, but I am having a similar problem, but it includes whenever I use Window Media Player. I have looked into various ways to disable the Hardware Acceleration, but I am running ATI Radeon HD 5670, which does not appear to offer the capability to disable it.
I have the complete opposite problem.. my WoW FPS is low until i play a youtube video or something with flash. And if i disable hardware acceleration my FPS drops..... wtf
Yeah do not enable hardware acceleration if your using Evga precisionX with K-boost enabled, it will cause crashes.
Very interesting reading.

Removing Flash using the official uninstaller, official link below, would theoretically also work..


Join the Conversation

Return to Forum