Error Retrieving Character List.

Technical Support
I was hacked about a year ago, but I got my account back thanks to blizzard, but when i tried to log into my smolderthorn realm (reckoning battlegroup) I get the "Error retrieving character list", I stopped playing warcraft because of this. so a year later i come back wanting to play on my characters again, I thought it blizzard would of fixed something like this by now or atleast fix itself since i completely uninstalled it. It still gives me this error still, I tried deleting my WTF, both Cache folders, and both interface folders, I tried power cycling my router. I called blizzard twice but they didnt help, I contacted an in game GM he had other methods, he reset the Game files, i used the repair tool but it said there were no problems with warcraft. I even uninstalled it and reinstalled it... I'm running out of options, I need professional help, someone who can actually fix this and knows why this is happening. I read other problems just like this, and i read that the realms in the reckoning battle group had this exact same problem a year ago or a few years ago, they got their characters fix, why didn't I? Please if anyone knows why this is happening to me please respond.
its happening to me right now also can a GM please help me
same here
yes and now it is telling me that a char with my name already exist and i cant load my own char.

I was doing an instance during it so maybe that was the reason but I cannot even load my char.
did this problem fix itself? cuz im experiencing it now as well
same with myself.. good ole darkspear
me too in darkspear as well
ERMA GURD same, i was able to get back on then i got off for 10 min and came back, same problem.... (from darkspear as well)
Me as well, on Darkspear... This is aggravating...
Ive been trying to find a reason but this goes unanswered in every thread, and blizz phone Q time is full....
yea me 2 i made my own thread about it
I'm having the same trouble in darkspear. I uninstalled wow, totally reset and shut my computer, made sure i was connected to the internet and everything, but nothing seems to be working. are they running maitenance on the darkspear realm or something?
Don't think it's an individual problem. Darkspear server is having issues. I can log into other servers...just not Darkspear.
my character list actually just same back up on darkspear so i recommend that you guys try to login again
cant login in (from darkspear)

    On darkspear
    Same error message
    second time just today
    I think it has something to do with the level 1's stalking Swifty and the youtubers.
GOGO Darkspear is server down or what?
From what I've read Darkspear has had this issue before. Back in October it went down for a little while. Im sure they will get it back up and running.
Same here must be Darkspear

Join the Conversation

Return to Forum