won't patch

Technical Support
So I'm at my parents for Thanksgiving and their computer has an old version of WoW I need to patch ( according to the launcher). However, the launcher doesn't say anything about it needing to patch, logging into the game doesn't say anything about patching, and I can go all the way to realm selection which just fails to connect (obviously). The WoW repair tool tries to connect to over HTTP (the old patch server, afaik - was it hardcoded as that's not us.version.worldofwarcraft.com which is in the realmlist.wtf?) and can't connect as the server's not up (error is "Cannot connect to the server to download repair information"). Was the same problem last night.

So, yeah. How do you get to patch?
Obviously the launcher needs to update, but it believes it's perfectly up to date. It is downloading PatchSequenceFile.txt from us.version.worldofwarcraft.com just fine, it just refuses to believe there's a new launcher.

Are there are security programs installed that might be keeping the launcher from updating?

Maybe try running the launcher in safe mode to see if an update goes through.

Here's how to get into safe mode:


Also, remember that if you are using Windows Vista/7 to run the launcher as admin by right clicking on the WoW icon and selecting "Run as admin".
Account and Technical Services Forum Representative
If you can't find a resolution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 12PM to 8Pm Pacific Time
Feel free to rate my services at the following link: http://www.surveymk.com/s/RZ289DL
I tried everything in the above post with no success. Both the launcher and the game seemed totally oblivious to a newer version being available and neither seemed to be running into any errors all the way up to letting me attempt to select Hyjal on a woefully out of date client.

I fixed it myself, maybe the following will provide some useful info (imo it's a problem on your side with this old launcher version 394). When I looked at the launcher's logs, it was clearly thinking it was up to date when it wasn't:

09:27:06.4407 Launcher version
09:27:06.5127 Fetch version information from us.version.worldofwarcraft.com (
09:27:06.6087 Received version information from
09:27:06.6097 No update is required.

Looking at the PatchSequenceFile.txt, there was no entry for the version 394 launcher, so I added one that pointed to what looked like the 4.0.0 tools and pointed the launcher to my server. It then recognized it needed to update and downloaded it, but refused to extract the update:

10:12:29.0957 Failed while patching. Command was 'extract WoW-'.

There was no obvious reason why it failed to extract (no errors via filemon), so I used a MPQ extractor to get the file out of wow-patch.MPQ and ran it myself. It downloaded 4.0.0 and updated the launcher and started patching everything and I'm now patched and able to play.

This was all with launcher version 394 and client version 12340 if you want to see if you can replicate it. Btw, another problem was the repair tool in that version attempts to connect to servers that no longer exist. I tried connecting to the same addresses on a different system + network to confirm. It looks like you changed IPs and forgot about the ones the old repair tool uses.

Join the Conversation

Return to Forum