Wow Downloader Stuck @ Setup

Mac Technical Support
Its been a whole night and total download remaining is 12.8GB. Still stuck at setup, not moving at all, although it is saying I am downloading at 100KB/S. Been a whole night and has not moved at all. Please help...
I am also running on a 2010 Macbook Pro if that helps at all.
Any help... I found 5 other posts kind of the same, and still no blue posts... what is going on?
How are you connected to the internet? (Wireless, wired, data card, etc)

Also since this is a new machine, did you transfer any data from your old machine via time machine/Migration assistant?

I would run some basic system maintenance just to make sure nothing is preventing any data from being downloaded like permissions and etc.

Please use the steps below to repair file permission settings on the hard drive.

1. Navigate to /Applications/Utilities/ and open Disk Utility
2. Select the hard drive the game is installed on
3. Select the First Aid option
4. Click on the Repair Disk Permissions button

Repair Directory Procedure:

1. Start from your Mac OS X Install disc: Insert the installation disc, then restart the computer while holding the C key.
2. When your computer finishes starting up from the disc, choose Disk Utility from the Installer menu. (In Mac OS X 10.4 or later, you must select your language first.)
Important: Do not click Continue in the first screen of the Installer. If you do, you must restart from the disc again to access Disk Utility.
3. Click the First Aid tab.
4. Click the disclosure triangle to the left of the hard drive icon to display the names of your hard disk volumes and partitions.
5. Select your Mac OS X volume.
6. Click Repair. Disk Utility checks and repairs the disk.
**Always start up your computer from an Install or Restore disc when using Disk Utility to verify or repair your startup volume. Otherwise, you might see some disk error messages.**

If you do not have your install disk, you can use this method:

1. Shut down the computer.
2. Power up holding Cmd (Apple) +s until you get a black screen with white type
3. At the cursor please type the following: /sbin/fsck -fy and press return
*NOTE - Please be aware that some of the procedures will look like they are frozen, but are actually taking a long time i.e. checking hierarchy
4. If anything had to be repaired, repeat step 3. Do this until it says "The Volume appears to be OK."
5. Once things are repaired type exit and press return
6. Computer will boot into Mac OS

Account and Technical Services || Mac Tech Support
Tue-Sat 9 AM - 5 PM CST
Can't find a resolution on the forums, contact a Support Rep directly:
Do you love Boomkins? Sure we all do!
Wait I mean, take a moment to let me know how I am doing.
Did that, but apparently it did not do anything. I am now at a cafe center with T1 internet and is still going at same speed, stuck at 0.0/4.3GB. Please help. I have no fire walls up and did all the port forwarding for world of warcraft and world of warcraft launcher.

Thanks for your timely and detailed response to Bossz. I, too, am having pretty much the same problem.

I'll sketch out the territory. Apologies for what is probably some extraneous information.

--computer: MacBook Pro (about 1 1/2 years old) (MacBookPro5,3)
--Mac OS X version 10.5.8
--Processor: 2.8 GHz Intel Core 2 Duo
--Memory: 4 GB 1067 MHz DDR3
--Startup Disk: Macintosh HD

--World of Warcraft Launcher
--The top, drag-able bar reads "World of Warcraft v4.0.3.13329"
--it randomly downloaded some megabytes on a random re-launch of it (from 156 to 122)
--however, it is again stuck
--it reads "Total download remaining: 122.2MB (XX.X KB/s)
--The download rate is quite high (ranging from 50 KB/s to 100KB/s)
--I am on a college campus, with a password protected wireless network...I do not
believe this is an issue, as I have had no problems downloading, until now. However,
they may have changed something without notification.
--Connection Info window
--"Completed: 10.3 GB of 10.4 GB (0%)
Downloaded: 62 MB (this number continues to tick upward)
Download Rate: XX.XX KB/s (this also changes)"
--it is reading two IPs under "Connection":
--one with numbers: its "Time" continues to go longer, "Available"=60%, "Local" has
a blue dot, nothing under "Up Rate", "Up Total", "Down Rate", and "Down Total",
"Peer ID" has a jumble of letters and numbers
--HTTP Direct Download: "Time" continues to read "00:00:00", "Available"=100%,
"Local" has a blue dot, nothing under "Up Rate" or "Up Total", "Down Rate"
continually changes, "Down Total" is stuck at 160 KB, and "Peer ID" is

Any solutions you could put forth would be appreciated.

And I did try both things you suggested*
Same issue I'm having as well.
same here was working fine on monday before patch.

i completely reinstalled from scratch and same result
same here was working fine on monday before patch.

i completely reinstalled from scratch and same result

You could reinstall? The launcher is freezing for me during the first patch application.
Hi, for those of you experiencing this, can you guys send your Apple System Profiler so I can take a look at this, and find out whats going on?

To further trouble shoot your issues; please send us a complete Apple System Profiler report for your system.

1. Click the Apple in the upper left hand corner and choose "About this Mac."
2. Click the "More Info" button.
3. When the System Profiler is finished gathering its data, click "File" then "Save As..."
4. Add your name to the filename, and save it to your desktop for easy location.
5. Send as an attachment to

Also, when you send your info, please put this thread's URL in the email so I can reference this and know what I am looking for. Thanks guys!
Account and Technical Services || Mac Tech Support
Tue-Sat 9 AM - 5 PM CST
Can't find a resolution on the forums, contact a Support Rep directly:
Do you love Boomkins? Sure, we all do!
Wait I mean, take a moment to let me know how I am doing.
Whats the status on this issue? I got a lot of leveling I would like to get done before Cataclysm...
I am having the same problem on my computer but its a PC with Vista. Its at Setup and wont go from 0.0/5.0 GB
I to am experiencing this issue on my windows vista 32 bit machine. I have never had problems instaling or downloading in the past. I not doing the regular game setup though. I am trying to download the public test relam. it is currently stuck at setup part of the three part installer (setup,available,playable) it says on the bottom 289.1/289.1 MB for the setup part yet it doesnt allow me to even open the game and the installer has since stayed stuck at this part... and i still have 9.4 GB to go :(
I have a windows 7 laptop and my world of warcraft is still stuck at setup. It is running around 836.1 kb/s. I have no firewalls i also have removed my anti-virus because people told me this could also be a problem. Still is not moving from setup. Can anyone please help ?
same problem here, used to be able to play, then suddenly.
cant click on play. =/
Please don't necro threads. And also this is Mac Support forums. You want the PC forums.
Mac Tech Support for Baaaaahlizzard Entertainment || Tu-Sat 8:45 am - 5 pm CST
If you can't find it here, contact a rep direct : ---- Rate my Baaaaalue Posts. Haala at your sheep!
Pfft! Secret doors, who needs 'em? What do I care about secret doors?... and the unparalleled delights they keep hidden from the world!
bump this for a fix

Join the Conversation

Return to Forum