Installer problem- case sensitive hard drive

Mac Technical Support
Every Time I try to install Warcraft I get the following error:
"Sorry, World of Warcraft cannot be installed on a case-sensitive volume." Aren't all Mac volumes case sensitive? I can't find anything in Support about this. Please help. Is there a work around? I don't want to reformat this drive it is a half full TB drive.
Not usually no.

If you want to a work around without formatting make a non case sensitive disc image using Disc Utility and install into that :D

Should work in theory just be sure to wipe the Blizzard folders in /Users/Shared after you do. Modify any short cuts to point to the new location on the disc image.
You must've specifically formatted it as a case-sensitive volume. Mac volumes are not case-sensitive by default, so a folder called "Data" and another called "data" are the same to the system and cannot exist in the same directory. They can on a case-sensitive filesystem.

If you didn't have a reason to make the volume case-sensitive then I advise that you backup your data, wipe the drive as a Mac OS Extended (Journaled), and reinstall. WoW isn't the only application that doesn't like case-sensitive filesystems. If that's not feasible, then Bluespaecow's advice should work. It's cumbersome, but there's really no other option unless you have another non-case-sensitive drive you can use for WoW.
Thanks Bluspacecow, your suggestion to make a disk image worked fine and the game installed and plays normally.
I'm having the same issues. Can you give any instructions on how to create this new disc image?
I JUST hit this today trying to install WoW from scratch on my Mac as I am coming back to the game after a 4 year hiatus. Backing up with Time Machine now. I'll then install OSX over the old and then upgrade to Mountain Lion and then restore from the Time Machine backup. What a pain in the !@#.
Our games aren't able to install on a case-sensitive volume.
thanks a lot i stopped playing wow because of this after i got my new mac but you just saved me. :D
Hey Blizzard, is there a reason for this. Having developed software for the last 12 years I can't believe it would take much time and effort to fix this issue (there should never have been an issue in the first place!). Especially since your games (tested WoW and Diablo III) play fine on case-sensitive volumes. Its the launcher that just absolutely refuses to work!

I can't format my drive as case-insensitive just for a game. I have to use my computer to do development as well. Please fix this problem so I don't have to create a case-insensitive disc image every time there is a new expansion pack!
I have to agree with this. I keep WOW and other Applications on a fast external firewire 800 (will be upgrading to thunderbolt on next upgrade cycle) drive. I even have a symbolic link from ~/Applications to the drive. I have been running this way fine for years. Beats all the headaches I've had on the windows side. I have even trained many people to just drag the .app where ever they want and it runs. This is a known and often used fact for Mac users. There maybe a problem in all the windows users coming over, not knowing this since they haven't been introduced to it. There is a reason Mac apps are self contained. This type of crude, well turns them into windows machines. Run everything as administrator and have no to little control over where your machine puts files or what it does.

Now that I have vented that.. back the the issue at hand.

How do you tell WOW not to run in /Applications then the optimizer will not try to put our files on a case sensitive drive.
09/07/2012 07:41 AMPosted by Lygen
Especially since your games (tested WoW and Diablo III) play fine on case-sensitive volumes. Its the launcher that just absolutely refuses to work!

Our games aren't tested on on this, since it isn't supported in the first place. Various workarounds may have worked in the past, but that was something that isn't supported.

I'll send this feedback up to the appropriate teams, but currently this is still unsupported.
I have played since BC and recently (16 months ago) had to migrate my data to a case sensitive drive due to work needs (MySQL development for a server that is Linux). Since I restored from a backup (and did not run the installer) everything was running just fine. But recently an update failed and I have not been able to play since then. I was on the fence on purchasing the MoP expansion. But I guess the decision got easier. My computer is quite clearly not supported by the game developer. So, it's the end of a long run at this game for me. I cannot reformat my drive and I do not see myself purchasing additional drives or going through other gyrations just to get this one program to run. There are other games that install easly and without problems on case-sensitive drives in OS X.

Join the Conversation

Return to Forum