Quest: Be Raptor

I'm in Zul Gurub for the quest Be Raptor, it says to talk to Tan'shang, but that npc doesn't exist. I've walked all around this place. there's nothing here. This is about the 5th glitched quest I've run in to, it's really frustrating.
Did you speak to the priestess first?

...or did you just walk into the area?

I'm not sure how you'd be able to "walk all around the place" if you were in raptor form, as it would continually teleport you directly in front of Tan'shang until you have spoken to her.

You need to speak to Princess Thaalia to advance this quest in the correct manner.

No, the same thing happened to me. I am in raptor form and not alram is raised when I walk or run casually around. I ran through a guard and nothing. There is no dinos in any doorways, I watched the Youtube videos, I know what to look for. :(
I too am having problems with this quest, and I totally want the Darkspear rep. ME = UPSET.
Same here!
Doing this quest to get the lashtail Hatchling and I cannot do it because it is bugged. I do not see any of the raptor NPC's the quest tells me to talk to and watched the youtube vid guide and it's nothing like that.
Read that if U deactivate addons and/or delete the interface folder it wotrked. Did it and nothing.
Sent a GM ticket... 2 days wait time... c'mon, what do we pay 15$ a month for....
I also am having the same problem. I cleaned out my WTF files and took my add on folder out and it's doing the same thing as you, Drakuskyp. :( It's annoying. I do the vehicle UI is messed up because when i try to click off of it, don't do anything. Only way I can not be a raptor is log out. I even abandoned the quest and got it back and that didn't work either.

SAme thing is happening to me!! im not alone woot!.. theres Tian-kuyi when i get teleported in but then i cant find anything else in here.. /ragequit

eta--deleted wtf and cache folder and mines now working
I was having the same problems, deleted wtf folder, cache folder and was able to start the quest. Everything is working fine now.
I tried all of that and I'm still having those issues as well.... :(
05/20/2011 02:07 PMPosted by Elirra
I tried all of that and I'm still having those issues as well.... :(

This. :/
Same issues here. I have tried all the fixes mentioned in this thread but nothing has worked yet.
I had the same problem! Everytime I'd 'become the raptor' I couldn't even talk to the first raptor.

Deleted WTF and Cache and no problems.

-- Complete lie. Still screwing me around >.<
I gave up after I realised I wouldn't get a pet...
Seems like this is a common problem....

Yeah I also deleted the WTF and the Cache folders and I'm still able to walk around nonchalantly without any alarms raised... :/
I see the big raptor right in front of me. I cannot talk to the big raptor, no matter how hard I right-click. He's being anti-social.
same as everyone above. cache and wtf don't help. relogged many times, abandoned quest, etc. nothing helped.
WTH (what the hell) is going on Blizz. Like everybody else, I cannot talk to the first raptor, there are no other raptors there and I can run around the place and even back to the quest giver and back to where the first raptor is. Looked on you tube and know where things are suppose to be but they are not there. It makes it really hard when you want to get a great little companion like that when the quest is glitched and trying for the next lvl of acheiv for compnion pets. :((
05/22/2011 04:01 AMPosted by Zakkibank
I gave up after I realised I wouldn't get a pet...

Actually, you do eventually get a pet. If you've completed the quest chain, you'll have another quest available in ZG, after killing the second boss. Sadly, he doesn't carry body parts around for you anymore.
Just thought I'd say I'm having the same problem right now.
Same here. The raptor you are teleported to isn't Tan'shang it is Tian-kuyi and although I get a speech bubble nothing is said. I have done all the glitch "fixes" and nothing helps.

Join the Conversation

Return to Forum