Quest: Be Raptor

i have the some problem, but alittle differnt. at first it was working fine. but at the part where you have to burn tikis to distract the guards, i got caught and teleported back to the second raptor. after then, i could walk freely around and no alarms, no other raptors, guards in the first and second rooms, but beyond that there is none. obviously im not the only one having this problem. i would sure like to complete this quest, even though i said screw it and procedded to booty bay
yep, i totally agreee. i just tried this quest 3 times, nothing worked, reallly hopefully that it will be fixed soon.....been a dayss....
Yup same here all the above....Second time I've put in a ticket now.....
Put in a ticket, they know that its broke. Sadly we're going to have to wait for a game fix.
Ok, so I thought i would try something... and it worked

Try setting your Dungeon level to 'Normal' 5 man.. instead of heroic

Post if it works to help any that have this issue
That DEFINITELY worked! I have no idea how you ever thought of that....but good job!

05/26/2011 08:06 PMPosted by Kiminz
Try setting your Dungeon level to 'Normal' 5 man.. instead of heroic

Noob question, but....

How do you do that?
Same here. Dont know how.
In the default ui, you change the difficulty by right-clicking your portrait, which should give you a menu with the dungeon difficulty option, which you can change.

Unfortunately, changing the difficulty did not fix the problem for me. Running the repair tool, running WoW from "Wow.exe," and deleting my WTF, Cache, and Interface did nothing to solve my problems either (a GM suggested I try these things).

EDIT. Changing the difficulty did fix the problem for me, but I had to abandon the quest and pick it up again. So if you're already on the quest, you may need to change the difficulty and then abandon/reaccept the quest for it to work. Thank you so much for figuring out the difficulty change fix! I am in debt to you!
I might be missing it somewhere, but it is not in the portrait menu.....?
I don't think the lowbies get heroic dungeon, that's a 80+ problem.

I'm having the same problem. Ticket told me to delete WTF and Cache, which I did - all 4 of them, since I'm on Windows 7 >.> - and then run the repair, which I did. Still having the problems. And I don't think this is a dungeon difficulty either because you can see your arrow on the map; plus, the layout is the old ZG, not the one you find in heroic ZG. I really wish they'd fix this, because it's downright annoying.
Tried the dungeon difficulty fix, deleted WTF and cache folders, tried logging in/out, tried abandoning and getting quest again. No luck for me. Any other fix ideas?
I posted in the other thread about this, but i'll just post here also saying I've tried all the above suggestions and this quest is bugged. You can't even speak to the first raptor to figure out what to do.
Confirmed, quest is still bugged. Deleted cache and wtf folder contents, ran wow repair, disabled all addons and changed difficulty to H and back, tested with it on both Heroic and Reg.
I just completed the "Be Raptor" quest after a couple of weeks of ticketing GM's with problems. I was unable to interact with the first raptor and there were no NPC's after the first area. After getting responses from GM's saying the quest was working and that I must have an addon conflicting with the quest I'd nearly given up. I finally spoke with a GM who said they are aware there is a problem with the quest and were working on a resolution. Addons have nothing to do with the problem.

Then today I was working on archaeology in STV and the little raptor pet popped out and began following me around. I thought it was odd so I figured I would attempt the quest one last time and it worked. I zoned into the quest and was able to interact and see all the NPC's. So my suggestion is if you see the raptor pet following you grab the quest and give it a try, it's an indication the quest line is working again I believe. Good luck.
Make sure you abandon the quest before you log out to try the dungeon fix, otherwise it won't work.

I run Windows 7 as well, and abandoning, logging out and changing the dungeon difficulty before starting the quest again fixed the bug. Never deleted a single addons or my WTF
Got tired of trying everything just to have nothing work. Delete and done!
I can't even get to be a raptor. How do you do that?
I got all the way through this except for the last little part... escape from Zul'Gurub. I can go out.. but it doesn't trigger the escape part of the quest... any help would be appreciated.

Join the Conversation

Return to Forum