Problem installing Burning Crusade...

Technical Support
Well I downloaded a 14-day trial out of a Warcraft 3 Battlechest and decided the previously hated game WoW was worth popping in the disk-tray out of boredom. Well one thing led to another and now I have decided WoW isn't horrible. I went out and bought the Battlechest and still using the trial-version upgraded my account. I put in the game disk and downloaded the Burning Crusade, but right at 75% I get an error message saying:

"Sorry, the installation failed.
The file "C:\World of Warcraft\Data\common-2.MPQ" could not be found. If this problem persists, please contact Blizzard Technical Support. (OpenArchive::Execute)"

My disk is perfectly clean, no spots, scratches or dust. Not sure how to get around this, I have tried it several times and the same error occurs. Maybe I should re-install the game? My only concern with having to do this is downloading the patches again... the god awful patches. Took me 2 days of downloading to get those suckers done. If I uninstall do the patches remain?

Thanks in advance for any advice.
I am having this EXACT same problem. Brand new disc, super clean, tried copying all the files to my hard drive, etc, nothing works.
If you're getting that error, it sounds like the cd is missing files on it. Have you tried using the streaming downloader from your
I thought about doing that, but couldn't figure out how to download the Burning Crusade client only. Then there is the fear that I will also have to download all of the patches for Cataclysm again as well.
Well even if you use the cd, you still have to patch up to cataclysm even if you don't have it. It'll take longer if you use the cd, as the streaming launcher downloads the core data first, then you can play while it downloads the rest, assuming you have a fast enough internet connection.
Ok, how do I download the client for Burning Crusade. Every link I see to download the client downloads the regular WoW client only.
So if I have the CD key for BC I can download the client? How does it work?
Having exact same issue with retail lich king, 74% fails install ecact same error. Tried install in safe mode on two different computers. Both brand new, lap top is ASUS gaming version. ? I think even if I bought CATA special edition it would do same thing. Any answers....Thanks in advance
My computer is an HP Pavillion laptop. Not sure if that helps or not.
Ok. Update. I spoke to customer service after holding for about an hour. They had me uninstall WoW from my computer and download the client again. Yes, ALL of it.

So, I downloaded it overnight as I was sleeping. Woke up this morning and found that I was able to play Lich King (which I had also bought at the same time as Burning Crusade) after I finally figured out what was going on. However, I still don't see how to access the Burning Crusade portion of this game.

Anyone have any idea's?
Did you have to redownload the patches? That's my only worry.
I am almost having the exact same problem. I recieved the battle chest from a friend for christmas and downloaded the refer a friend trail he sent me saying we could level up faster if I took the trail and then installed the game a few days later. I did so (the game worked great on the trail) and now after entering my retail keys and patching it says, " Launcher requires written permission to the World of Warcraft Registry Key to successfully locate and run the game. Please enable write access to the Registry key using an Administrator Account." Any thoughts, ideas, or absolute fixes would be most appreciated! -Thx
I see both symptoms of installing the older game files on top of the updated game client in this thread. Please check this thread -

Account and Technical Services / Game Master
Can't find a resolution on the forums? Contact a support representative directly:

Great minds discuss ideas; Average minds discuss events; Small minds discuss people.
Vial of Tears
So I'm thinking it might be the trial version or something. Only now when I try to uninstall it, it says "File in use". Wtf? WoW is just full of problems.
Had to download EVERYTHING again. Which is why I did it overnight as I was sleeping.

As far as my Burning Crusade question, talked to a buddy in the game and he was able to explain what I needed to do.
i have the same problem i have an ASUS laptop G73SW and when i try to install BC it fails at 74 percent
yeah you do have to download the patches again it sucks a lot
I just recently returned to WOW after almost 6 to 7 months of hiatus, I installed the entire WOW again but while installing TBC my PC would not accept CD-4. I had two sets of CD's for TBC so tried the other one instead but the same problem. Then I skipped the BC and installed the lich King and got and installed Cataclysm.

Now here is the mystery, after the complete installation of Cataclysm I can now play all races and my main character is a Blood Elf Death knight (Blood elf belongs to TBC expansion).

Does this mean I can play TBC zones? I have not gone there out of the fear of crashing my PC. Also does the new WOW client install the other expansions if you already had already bought it?

Join the Conversation

Return to Forum