Wrath of the Lich King WON'T DOWNLOAD ERROR

Technical Support
I can't install "Wrath of the Lich King". It stops at 74 percent with an error message saying a specific file cannot be found. I have followed all the tech advice on the tech support page and also uninstalled the whole World of Warcraft off of my computer and reinstalled. I also turned off my firewall and antivirus during the download as well and it is still producing the error message. Is there any advice on how to fix this?
I'm having the same exact problem, It stops at 74%. Blizzard told me to do the same thing but it didn't work! HELP!!!!!
It would probably be best to scrap that installation and just download the full game client from your account summary page. With the recent patches leading up to Cataclysm, you most likely had the game files already. Attempting to install the WoTLK client over the newer files will just corrupt the client.

Delete what you've started and then log into your battle.net account. Go the your account summary page and look for the Game Client link. Select that and download the full game client. This will install all the files needed for your account level.
________________________________________________
Unofficial WoW Tech Support Pages
http://www.wowpedia.org/Portal:Technical_support
Unofficial Live Support:
irc://chat.freenode.net/wowtech
http://webchat.freenode.net/?channels=wowtech
IT WORKED!!!!! Thank You SOOOOOO MUCH Drezbek!!!!!!!
thankyou im just re-downloading the full game client now. i will then install burning brusade and lich king. i hope it works.
03/16/2011 1:47 PMPosted by Hypnoticz
thankyou im just re-downloading the full game client now. i will then install burning brusade and lich king. i hope it works.
...

No, once you have the client you are DONE with installing.

Oh, and for future reference, please create a new topic instead of digging up a thread that's relatively old. You can do so by hitting the "Create Thread" button located in the top left corner, under the Hearthstone icon.
It worked thanks!!
That worked perfectly Thanks!
thank you iv been trying to get it to work for such a long time
I downloaded the full client and it still won't work!!
Avitus,

This thread is from nine months ago. It's a common error that occurs when someone tries to install the obsolete Wrath installer disk over the full version of WoW. If you have WoW installed, don't use the Wrath installer.

Update your account with your Wrath authentication key here on the website (if you haven't yet) and then log in and play.

If you're having a different issue, please create a new thread and explain the issue in detail there.
________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html
How's my driving? https://www.surveymk.com/s/R5D3LCF

Check your G-diffuser system!

Join the Conversation

Return to Forum