Stuck at 59/125 in Deepholm

1 2 3 6 Next
I just finished getting the 1st World Pillar Frag, now I have no more quests for this zone. I had the quest that leads you into Stonecore, but I finished that and it didn't lead anywhere outside the instance. I'm lvl 83, did I miss some random guy in a cage somewhere? Or did I miss a quest drop? I remember getting a quest starting item from those silver mercury mobs in that area where you hide under a crate, and a quest item from some cultists at Deathwings Fall when you first start the zone.
I got 117 done it was fairly linear for me to get thro the quest arc each part of the zone led into the other until i had a full circular map. However I cant find any more
I'm stuck at 49/125 quests.
i'm in the same situation as you, don't know what's going on :(
Same here. (And this also happened to me in Hyjal.) I see some quest givers with silvered-out exclamation marks above their heads, so this leads me to believe that I am too efficient and got here before they were ready. LOL Like you have to be at a certain point in xp to trigger the rest of the quest line to light up. Either that or I am supposed to go somewhere else and I have no idea where.
I'm stuck at 63/125. There is LITERALLY NOTHING to pick up. I think mine bugged out, because I was never given the continuation quest for the third pillar fragment after having recovered the second from Stonehearth. I'm not sure what the deal is, but I was already a ways into 83, so I said eff it and went to Uldum instead.
I am stuck at 51 quests done in Deepholm. Would very much like to start the Therazane quests but don't have any more quests to do there. I'm wondering if my Earthen Ring rep isn't high enough for someone to give me a quest to move on, but I have no idea where to go to get quests to get it up.
I'm stuck at 116! I even tried the dailies, which don't count. How do I find the remaining ones?
This is happening to me in all the zones. Well, I'm not sure about Vashj'ir but I don't like the underwater setting so I've stayed out of there for the most part. Was very sad when the Uldum quests stopped coming in as that has been my favorite zone.
I too am stuck at 59/125 quests. Right now Im at 75% or so xp into level 83 and I have done Stonecore when I got the quest for it. Blizzard confirm if its a limit or a bug.
Please add me to the list of affected people as well.

I've been doing all my Deepholm quests in order and, other than running the instance (I did the first part to talk to the NPC inside, but not the instance quest,) I am sitting at 59/125 quests completed.

I've checked the central pillar, I've checked the gun ship, I've ported to SW and came back (in case this was a phasing bug,) and nada. I have the "old" Loremaster title and I've already completed Vashj'ir and Hyjal.

I literally have nothing to do in Deepholm at the moment, althoug there are obviously a ton more quests to do. I'll keep flying around in the meantime to search for quests (note that I already have the explorer achievement,) but this is absolutley game-breaking for me at the moment.
Take this with a grain of salt, but I found that I had the "Rush Delivery" quest available to me (from Clay Mudaxle) after I went to SW and came back.

I had previously been questing in this area, but I had zero follow ups - no exclamation marks in-game or on my mini map. That's what originally made me assume that area was completed and then go turn in the two quests I had in the central pillar, neither of which led to anything further.

For all of the above posters, go check this out. As best I can tell, there is some type of phasing issue (yet again) that prevented me from having access to this earlier.
Im stuck at the pillar quest as well. I turned in that quest in the Stone (dungeon) cant find anymore quests.

Went to Stormwind to get a quest for Hijal but cant find any either?

Is everything bugged?
Will blizz fix this im so mad!
Im stuck in Deepholm as well did not give did not give me a follow up quest after i captured that dragon and turned in the first shard to the earthen temple.
101/125 here. Terrath would not give me quests; Was unable to pick up the quest from Gorsik to meet Therazane.

Kind-of frustrating
12/08/2010 7:20 PMPosted by Ardenraym
Take this with a grain of salt, but I found that I had the "Rush Delivery" quest available to me (from Clay Mudaxle) after I went to SW and came back.

This worked for me ..tnx so much
I just turned in the Middle Fragment Quest and had two quests - The Wrong Sequence and the Fight Fire with Water Air and ... The middle fragment quest apparently phases you out so you cant turn in anything ..after the battle the Stonemother has another quest to visit her throne in Therazane. Went there was able to do that quest, phase seemed to end. Took the portal back to the Earth Temple and the quest givers I needed to turn in quests to were back. It may be that you have to go see her , complete that last quest (The Stone Throne) with her, and then take port back for the phasing to end and everything to work normal. Hope this helps someone. It worked for me.
Linear questing is a bad idea Blizz.

Join the Conversation

Return to Forum