BUG: Full Circle

Bug Report
Prev 1 13 14 15 20 Next
I'm stuck on this bug.
Shadow council as of 10:30 PM mtn time just worked for me! go try yours
This is super irritating.
Bonechewer comfirmed aswell.
Stormscale as well.

Please fix.
DId 4 times. Bugged. Fix please!
Bugged on Khaz-Modan as well, I can't get credit for boarding the sub and also can't get credit for the ride. NPCs are also appearing and dissappearing every three or four seconds.

Was able to complete on my main last night before server reset w/o problems.
Same Bug on Trollbane
Just tried. Confirmed. The door would not open for me.
Same bug on Frostwolf US-PVP.
Yes it is irritating, but considering a lot of phased areas have been blinking in and out it's no surprise an event as heavily phased as this one wouldn't be working at all. Hopefully Blizz will actually fix it. And it will actually stay fixed.
Im getting the same bug.....makes me sad... Im trying the whole abandon quest and retry trick
confirmed still on Proudmoore. I actually got inside the submarine by just swimming about in the middle of where it docks... it threw me inside the ship and then at one point I saw the captain and lieutenant phase in and back out. No Credit. No Blizz. No Nothing. How does everyone feel after paying $180 per year on top of $40 for a broken expansion, and not getting a single word about anything from the high and mighty blizzard staff. "here's a survey" *sticks middle finger in the air*

I SAY FLOOD THE FORUM WITH POSTS!
bump, PLEASE FIX
Still glitched here on US-Nathrezim.
Bugged on Wanderlust, even when I get into the cabin, goblins disappear and reappear. But can only get in once you get to the cavern, so can't get credit for either part of the quest. Hope it's not a chain. Double you Tea Eff?
Glad I am not only one having issue I got so fed up I just went on to Mount Hygial and will return when that quest is fixed hopefully soon
got a ticket response (automated of course) saying they're working on it.

am able to go into the verne through the underwater door, but no NPCs were spawned and the quest didn't complete.
US-Spirestone, glitched.
It's making me crazy!
I sat in the sub for seven rounds. : |
No credit.
I couldn't get in until it docked in the cavern. : (
also been having the bug. tried dropping quest at least 5 times and didn't help. super annoying.

Join the Conversation

Return to Forum