BUG: Full Circle

Bug Report
Prev 1 3 4 5 20 Next
I can confirm it as well ^_^
The door didn't open the first couple times for me...kind of. Although the door opened, it revealed a similar door behind it that no one on the boat could walk through. After the second trip to the surface, the door decided to really open. I ran in and proceeded to take the trip down several more times and still didn't get credit for the quest. I tried standing in different rooms. Nothing worked. Other players experiencing a similar problem.
Same happening on Azjol-Nerub... tried everything I could think of.
as well as the npcs in the ship appering then disappering every 5 sec and see the lv 85 elite is in the caverns wich should be gone if you completed the quest right? any one know if that elite attacks ya cause i only see 1 way out of the cavern and its like blocking the way
Same door isn't opening on the boat for Malorne either :( sigh issues with phasing I guess.
After the boat took off, I got into the bottom by just running up against the door non-stop, rode boat all the way around another time.
Bug confirmed.
12/09/2010 1:30 PMPosted by Dethstryke
Same problem on Sen'jin. I can get on the ship, but not credit. NPC's phase in and out.

In-completable.

This is what bugs me about progression chain quests. If one bugs out, you're dead in the water (no pun intended).

NEW BUG alert - I was just standing in the sub and started taking 8k damage every 3 secs for no apparent reason. Died and can't get to my body now. /sigh


I think you drowned, I noticed my breath bar was going down even with the Sea Legs buff. I cast water breathing on myself and it filled up again.
Just attempted to do this quest. There were a few of us on the sub, and it was bugged for everyone.
Also confirming.
It is not working for me as well. The door doesn't open on the surface, only once you reach the destination, however you don't get credit for doing any of the quest objectives. I am sure it is a phasing issue which needs to be fixed.
adding to the list of those paying to beta test....

ah so it is a pahsing issue witch is bugging out the questing makeing everyone get no credit
Boat is still bugged you can get in by running to the door repeatedly, but no credit for boarding or for defending the tunnel. :(
12/09/2010 2:02 PMPosted by Gibblechips
Who cares, stop bumping this. It's the LAST quest in the line, you can go do other things


Is it really the last quest in the line? I was told it leads to more quests, but if this isn't the case then this isn't nearly as big of a deal, I suppose.
Hey Blizz fix this already plz "TIME IS MONEY, FRIEND".......
12/09/2010 2:02 PMPosted by Gibblechips
Who cares, stop bumping this. It's the LAST quest in the line, you can go do other things


I'm doing Hyjal now, but that doesn't mean that I don't want to come back say tomorrow and finish this. Vash'jir has been really epic so far and I don't intend to leave it unfinished.
Here too
Ugh. Making a ticket.
bug confirmed. Is this a chain? Should I even bother?

Join the Conversation

Return to Forum