Full Circle, broken?

This quest is Broken on Sen'jin as well.
There seems to be a problem with the way the X2 and the crew just phases around.

This is really annoying. Same as others have mentioned. I've had one door open to find a second closed door onto the sub. If I manage to get inside, the crew appears for about three seconds, and that's all. No chance t do anything but ride around. I also get a Breath bar while on board.
I am also experiencing this on Shattered Hand.

Posting so that this can be noticed. I would like to continue in this area.
Same thing on Dath'Remar. Not sure if i should skip it or wait for it to be fixed for the quest chain to continue.
Broken on Misha...
Broken on Drak'Tharon for alliance as well. I opened a ticket earlier this afternoon and still no fix. Hopefully customer support will come through for all of us and make it right!
I am having the same problem. Where do I start the Hyjal quest?
It's not just Cata quests, it's also BC quests too, one i'm trying to complete "the final code"
I just finished this quest and there is a bit of a trick to it. After the sub arrives you must quickly board and enter the hatch (vault like door) and make your way down and forward. At the bottom you will see a glass porthole (large one). Just stand there and the quest will complete. I dropped through the pool of water in the middle and swam back to the beach. Quest complete. Hope this helps.
^Just tried it this way on my druid and it worked. After previous attempts of not entering the sub.
this quest does work, enter the door of the sub and make your way down to the bottom of the sub and watch from where the wheel is. no doors have to be opened though it is a pain having to find the way at first.

If it glitches or you did not find the way down just go back to the boat Captain Taylor is on using the seahorse flight path and try again until you can turn in the quest.
This quest is really glitchy. The securing the cave part wouldn't complete for me. Then I couldn't reaquire the quest to try it again. Bliz need's to fix these quest.

The above does work but if you can't complete the quest you might have to drop the quest, relog back in to try it again.
This quest is still bugged, I'll try it again tomorrow. I walked through the door on sub and fell through the floor. Never even seen the insides of it. Just trying to get this quest to begin with I had to relog over and over as NPC to get it from keeps phasing in and out of game.
I ended up breaking this quest just now, jumping off the sub before the quest completed.

I dropped the quest to restart only to find that the questgiver was still phased out.

I figured I could port to org then Hearth to Legion's Rest to see if I could de-phase myself and pick the quest up again - it worked.
Having the problem too. Where does the pincer go after you get off? And how do you do the securing the cove part?
finally took me a sixth try, I actually entered the entire sub, stood at the control panel with the captain and no.2, and it worked... jeeze
This quest still has issues, both Ally and Horde side. After trying for hours to complete it on this toon, I managed to get stuck in midair in the cavern unable to log out.

Finally contacted a GM who got me unstuck and told me they could auto-complete the quest for me due to the large number of people still having problems.

I took that route rather than tear out my stylish purple hair.
The submarine isn't even showing up for me in the first place. The boarding plank appears, and the goblin announces its arrival, but no sub. If I swim to the end destination, the sub will eventually show up and I can force my way in. That gives me credit for "Secure Tenebrous Cavern," but I still can't get credit for "Board the Verne once it arrives." I'm effectively stuck.

Join the Conversation

Return to Forum