Am I being hacked?`

General Discussion
I was questing with my Warlock this morning, and about 5 minutes before the server restart, I get DCed from the game. I load back in, it seems to take a bit longer than usual, and I find myself in Orgrimmar with my Hearthstone on cooldown. Is this a danger sign of unauthorized access to my account? I have an authenticator, though I'm not sure if that really guarantees safety.
It's pretty hard to hack past an authenticator, unless you have a nasty bit of spyware on your computer that grabs your authenticator code in real time and uses it before the timer is up. It's rare, but possible.

http://en.wikipedia.org/wiki/Man-in-the-middle_attack

However, there's been a ton of bugs and glitches for the last couple of days. Chances are, when you DC'd your character got stuck, or bugged out in some way, and deposited you at your hearth location.

If you're really worried, run a full virus scan on your computer, as well as a malware scan. Do it with your WoW login screen open, and a fake name and password entered into the fields, since some malware is designed to stay dormant until certain conditions are met.
Thanks for the reply, I was pretty worried. The last time I had to authenticate on login was a few days ago, so I'm probably safe. Still gonna run that scan, though. :)
I once fell through the world in Crystalsong Forest back in Wrath and after about 30-45 seconds of falling in a blank screen my game crashed and when I loaded back in I was in Ironforge.

This game does some straaaange things sometimes.
I ran the scan too never to sure
I was getting disconnected last night while leveling an alt. After I reconnected, my alt would be in a spot where I was several minutes before the disconnect. This happened several times.

I have authenticator.

However my quests were partially completed up to the moment I lost connection. So I didn't hearth back to this spot, because impossible to bind there. Progress had been saved for all but where I was standing.

It's not a hacker. It's just a server issue.
Same sort of thing happened to me last night when the hotfix dropped and kicked everyone off Illidan. Took forever to connect, load my character on the server, and then actually load in game. I didn't start out anywhere near the mobs I'd been killing but instead back in the quest giver area. Most likelh an issue with the server resetting.
I wouldn't have been worried if my character was simply back at the quest giver area or something. I was only worried because I haven't been in Orgrimmar in days and my HS was on CD.
10/16/2014 10:44 AMPosted by Beishang
I wouldn't have been worried if my character was simply back at the quest giver area or something. I was only worried because I haven't been in Orgrimmar in days and my HS was on CD.
Yeah, really strange things can happen when your client or the servers crash.

Years ago, when the servers would crash you'd end up dead at the Crossroads GY if you're Horde, or the Westfall GY if you're Alliance - I think they're default graveyards. It was really weird when it would happen. You may have been on a totally different continent, and still end up there, dead.

Join the Conversation

Return to Forum