Proving Grounds title gone?

General Discussion
I got my Endless wave 30 title "the Proven Assailant" and upon logging in, it was gone. I understand that Proving grounds went away, but why the title? Simply a bug or was this intentional? I feel if it were meant to be like this, it wouldn't make much sense for us to keep the challenge mode titles as well.

Either way, would like to know! :D
Known bug, being worked on.

https://twitter.com/Celestalon/status/522104752952197121

A search of "Proven Healer" in the search box up there yields more information.
We're aware of the issue with missing Proving Ground titles and are working on a hotfix to address this.
10/14/2014 02:05 PMPosted by Rygarius
We're aware of the issue with missing Proving Ground titles and are working on a hotfix to address this.


Thank you! I worked hard for my Proven Assailant title and would love to show it off.

(I managed to nab it 2 days before the patch dropped.)
I haven't checked myself, but I seem to remember them saying on twitter that they wouldn't take the title away from people who earned it (because it was an extremely hard thing to earn for a lot of us). It would not be cool if they did take those away.

Edit: Nvm, blue responded before I had hit my post button.
10/14/2014 02:05 PMPosted by Rygarius
We're aware of the issue with missing Proving Ground titles and are working on a hotfix to address this.


Thats good to hear, I was gonna get worried soon, thanks
Thanks! I was worried when it wasn't available. Good to know it is a bug and not intended.
Titles wtf about not being able to zone into any raids or dungeons I think titles can wait lol
Good I was about to lose it!
Thanks guys.
Handle it.
Why is it telling me the servers are incompatible? is this a know issue or something new?
Can' t auto open updater, can't login. and manual update run says there is no patch to apply. The other posts I saw said this would be fixed 2 hours ago, just wondering if there is a new ETA or if something else is the issue.
I cant log in stops at connecting and then after 5 min says disconnected from server
10/14/2014 02:05 PMPosted by Rygarius
We're aware of the issue with missing Proving Ground titles and are working on a hotfix to address this.


I seriously hope you guys are working on fixing everything else that is broken as well. This squish and not having all raids and dungeons properly re-tuned for it is a serious problem and is wasting so many peoples time. My ability to solo older content has been severely changed. Plus there's the whole "still need a cloak" for Ordos thing. AND you should seriously consider reinstating the Black Prince buff until the xpac.
At least you guys can log in.
hello um on my game i cant see any of my toons in game and cant see anyone elsa and i cant even see the trees,
Been trying for hours to get on,,cant get any kind of download ,,always do,,I have no add on's with my toons,,,,cleaned up my computer,,,son is saying servers must still not be working for all,,,,,,servers are red click on says connecting then disconnecting,,,,giving up soon,,its frustrating maybe I can log on tomorrow ha ha maybe not ,,,,, !
addons have not been updated thru curse,thats why they don't work.as far as login...I had some issues also,but worked itself out after about 30 minutes...Blizz has to be working on it...just be patient.

Join the Conversation

Return to Forum