Failed to create storage component

Technical Support
Have the game running ok on my desktop but not my laptop.

Was getting the "Whoops looks like something broke error." on my laptop. Tried deleting files etc etc but could not fix it.

Copied the WOW folder from the desktop to the Laptop. Got rid of "Whoops etc" but now when I click the play button, after about 10 seconds I get "The CAS system unable to initialize client handler: initialisation error: failed to create storage component".

I downloaded the Battlenet app again.

Any thing else I can do?

Thanks in advance
No, you've lost your WOW forever~

just kidding, you can always try re-installing the entire game~
Had the same error, full reinstall (while that sucks) worked. Game running fine now.
I was hoping I wouldnt see this...

:(

world of downloadcraft.....
Try running a Scan and Repair under Options on the launcher.
Easy fix if you have not found it yet.
Just run all wow.exe as admin and you are set to go
its not working for me
Blackcatz,

This usually indicates a permissions issue. Try right clicking on the icon for the launcher and select 'Run as Admin' when starting it up.

If the issue persists, try resetting the game folders. The game will rebuild them with default permissions.

______________________________
Monday - Friday, 7am - 4pm Pacific Time
Rate me? Send feedback!

Join the Conversation

Return to Forum