Contrast issues after update?

Mac Technical Support
So I don't know if this is due to the patch update for WoW or the Yosemite update to my mac OS, but after doing both and logging in, suddenly the contrast in-game is crazy dark. It's nowhere else on my computer but in WoW.

Basically the blacks got about 5 shades darker and the lights seem to be just light enough that highlights in-game are too bright. Together the increased darkness/lightness and reduced midtones make it difficult to see detail. It makes it rather difficult to play when in Tirisfal Glades in particular, since it's already so dark ;v;

I have already tried playing with all the system settings (low quality graphics all the way up to good quality), and played with my mac's settings a bit to see if there was any contrast setting there, but haven't seen any improvement.

Anyone have a trick for decreasing contrast on a mac, in-game or not? Thanks C:

(Feel free to delete this if it is in the wrong area.)

Edit:
Forgot tech specs, just in case. I have a late 2013 i5/8GB retina display MBP, 13" with iris graphics and a 2.6 ghz processor.

I've not had any resolution issues or loading issues, other than the launcher refusing to download the last 6 MB within the optimal bracket. :/ Thus far there have been no issues stemming from that other than this contrast issue.

I have no add-ons or anything open that should affect performance. I'm getting a decent framerate since I usually only play it at 'fair' settings.
It's probably a gamma setting bug. I've seen this bug on 10.8.5 on my MacBook Pro. The workaround there is to log in as windowed, switch to full screen, and then switch back to windowed. Problem goes away and doesn't come back until I reboot the machine.

I can't say this is the same problem you're having, but the workaround is quick at least to try.
I didn't notice a difference after loading up windowed (how I have been playing so far), then going to the system settings, clicking fullscreen, hitting apply, then doing it again back to windowed. I'll try exiting the game as fullscreen and try it again to see if that works when I get back home.

Thanks for the suggestion!

Edit: I was able to test it and it didn't work. Alas, it must be something else bugging :/ Oh well. As I said, it's still playable, it'd just be nice to be able to play without squinting, haha.
Silvienna, have you tried using the gamma slider option build into the game? You can locate it under [Esc Menu] -> System -> Advanced.
________________________________________________
Technical Support MVP
Uh-oh! The truck have started to move.
Under the advanced menu it didn't have any sliders mentioning gamma, just the UI and foreground/background FPS sliders.

Do you have to have a different setting enabled to display the gamma option?

Edit: Ah, nevermind! I was playing in windowed mode, but switching to fullscreen showed the gamma settings.
In fullscreen the gamma slider did fix my issue, but it reverts if I switch it back to windowed.

I will just play in fullscreen when in darker areas, then.

Thanks!
Windowed will not show gamma controls because it is using the gamma setting that the OS has in its color calibration controls. This is intended behaviour.
________________________________________________
Technical Support MVP
Uh-oh! The truck have started to move.
I have the same darkness issue on my wife's imac. The gamma is
Set all the way to as bright as possible but her screen still looks dark. She noticed this after the patch 6.0.2. She is running Yosemite and I have tried all the brightening screen options I found in the forums. Changing from 1.8 to 2.2 or the reverse like another post said did nothing.

Any help would be appreciated
Thanks
J
I'm having a similar issue with my gamma settings (MBP, Yosemite, 13" retina). I have gone into System to correct the gamma with the slider (I have to bump it up to around 75% or 80% to see anything). This works, but I have to do it every time I log into the game. Also, the setting doesn't persist if I tab out of full screen. When I tab back in, the gamma slider is unchanged, but the appearance is dark again. I then have to click the slider (but not move it) to bring the gamma back up. Checking/unchecking the OS background gamma option makes no difference. I had the same issue on my older MBP 15" for several months, but the problem has followed me to my new laptop. No amount of deleting config files has helped.

Anyone solved this? I saw one or two threads about this in the forums, but they were old/unresolved.
Bump.

Join the Conversation

Return to Forum