[Bug] Inconsistent framerate

Mac Technical Support
1 2 3 47 Next
A major bug is in 6.0.3 at the moment which causes the framerate to feel extremely unstable.
All Macs are affected regardless of OS X version.

A patch will be released soon that will fix this.

Workaround: Set the "Max foreground FPS" to 20-25 FPS.
To set this you can type in the chat: /console maxfps 20

Update: The workaround only improves the issue, it does not resolve it completely.

Update #2
Build 19103 did not fix this issue, it fixed a crash that several people were getting.
We are still working to deliver a fix for this issue asap.

Update #3 10/31/14
The fix is on the beta realms if you have access to the beta please verify that it fixes the issue for you.

Update #4 11/3/2014
Patch 6.0.3.19116 should fix the framerate issue introduced with 6.0.3.19102.
Don't forget to type: "/console maxfps 0" in the chat to uncap your FPS.
Thank you!
yep just letting you know i have the same issue, good to know this will be fixed.
Someone get this guy a Dutch Bros.
This explains why turning on movie recording fixed the issue.
Go Go Go!! try to fix it ASAP!! its not nice to play with this bug

Ty!! :)
The workaround did nothing for me.
The "workaround" didn't really do much for me. It's still running pretty choppily. And this is probably a stupid question, but how do I turn that off once the bug is fixed?
Thanks for that workaround. Looking forward to a fix soon.
10/28/2014 05:47 PMPosted by Drizzdurn
The "workaround" didn't really do much for me. It's still running pretty choppily. And this is probably a stupid question, but how do I turn that off once the bug is fixed?


System Settings > Advanced settings, right side of the menu.

Edit: Workaround seems to have helped a small bit, but it's still quite present otherwise.
10/28/2014 05:47 PMPosted by Drizzdurn
The "workaround" didn't really do much for me. It's still running pretty choppily. And this is probably a stupid question, but how do I turn that off once the bug is fixed?


The workaround is just a console command, you can change your max fps back to what you like using that same command with a higher number (60 for a max of 60 fps) or go to system -> advanced -> max foreground FPS.
Well, the "workaround" made it so my eyes don't feel like they're bleeding, but it's still kinda funky. Hoping a fix is out soon.
Any eta on when the fix goes in, /console maxfps 20 made it slightly less choppy, but its still slightly nastaulgic even when using that command.
same problem here on
MacBook Pro (Retina, Mid 2012)
2.6 GHz Intel Core i7
8 GB 1600 MHz DDR3
NVIDIA GeForce GT 650M 1024 MB

The frame rate seems to stay decently high. It is the very choppy/skipping thats driving me crazy, unplayable.
10/28/2014 05:51 PMPosted by Todash
Well, the "workaround" made it so my eyes don't feel like they're bleeding, but it's still kinda funky. Hoping a fix is out soon.


Same.. at least it's better than before.
So knocking the resolution down to 800x600, playing in window mode, and having the settings at lowest setting seem to almost cause the stuttering to go away, but I have to say, I think it's still kind of there, haha.

Also, who wants to play like that? Not this gal.
This bug deeply angers me
Is this 'bug' affecting all Macs? Or just those of us with Yosemite?
I've had success setting the framerate to 40:

/console maxfps 40
I am running Yosemite and experiencing this. However, the game was running just fine before todays patch. So it was definitely something in today's patch that caused the issue.

Join the Conversation

Return to Forum