Glyph Chasing in Silithus

Could someone..anyone, help me out here. This is the only quest I've had trouble with like this on my way to 60 so far.

I found the glyph for Hive'Ashi easy. But the Glyph for Hive'Zora is marked on the map by a location that is nothing close to a Hive area. I went to Hive'Zora anyway, looked around underground quite a bit, though I didn't cover every inch because of the massive number of bugs in there, but I never saw the glyph.

I haven't tried for Hive'Regal yet, though I'm about to.

Can someone tell me how to get to the Hive'Zora glyph?
Actually, I just assumed that was the Hive'Zora glyph. I don't really know which one it is. The map says it's somewhere near the center of the map.
And the other one is supposedly somewhere in the mountains down at the most souther end of the zone? I guess I'll go check that out.
I dislike these silithid caves to the point where I find them stressful to navigate. I can't seem to find anything quest-related in them, and I feel like I'm unintentionally grinding my levels up from all the bugs I'm killing to get through them.
Found the glyph for Hive'Zora. Not sure why/how this could've been so difficult for me...I think I need sleep..
And the last glyph is now also found. Not where the map says =|
wheres the last one??? bc i i cant find anything in regal.... =(
Since patch 4.1 you only need to collect one glyph, from Hive Regal (the one next to Natalia).

Natalia and the glyph are right at the end of the tunnel from the southernmost entrance in Regal. It doesn't branch except for short dead ends, just keep working your way south and you will get there eventually.
Still not finding it :(
Okay I found the glyph but it will not rub or complete. Please advise.

Join the Conversation

Return to Forum