Patch Required ---Cant log in !!

Technical Support
I cant even log on !!! I get to the menu screen and then a message appear saying the a Patch is Required and I need to exit game to download it....but there is nothing to download !!!!

I even tried to run battle.net uploader as admin and still nothing, wtf ???
Same here. Gawd I am tired of this crap.
Hey guys,

We did release a small patch earlier today. If you close out of the game and launcher entirely and then start up the launcher again it should start patching.

If not, run the launcher's Scan and Repair tool located in the options menu just under the game title.

______________________________
Sunday - Thursday, 7am - 4pm Pacific Time
Rate me! Click here!
Jura, you guys are actually aware of the problems yes.. like this is annoying, the issues right now are garrison servers unusable at the best of times, and the general issues surrounding aussie servers
Im trying to run the repair tool and after it begins scanning it says I need to check my internet connection, even though clearly I'm connected :o
i am also having issues.... when i start the scanner it says waiting on another instalation or update. but no games have a loading bar on them. i also leave my battle net app open so i dont have to download patches when i get home from work. i can just play. y isnt that the case here? didnt get on yesterday atall now it seems i wont get on again today.
It won't even let me use the scan & repair button. Between today and yesterday, I'm getting pretty frustrated with this game.
Same problem, except the error message I got said I had to reinstall.....went the repair tool 3x, then after restarting the launcher 4x and a computer restart it wont download all of the data....
i restarted my computer.... the patch is fetching stuff im clyda the monk above :P and my sham is also 91 in game
Logged in to battlenet launcher. Launch wow and log in. Sit on the "Connected" screen for 5 minutes and then get logged out. This is how the past 3 hours have gone.

Launcher and game are very much up to date. All have been closed and restarted (multiple times) and the system itself has been shutdown and booted back up three times. No way is this issue on my end. Everything else works fine.

Very occasionally I make all the way into a character only to be booted right back out 15 seconds later.

It's beautiful (when you can actually get in) but honestly what's the point of a game that causes hours of frustration when you simply try to launch it? This is painful experience and the more it continues on the less I'm inclined to renew a subscription.
Same problem. The scan and repair just ran for over an hour and appeared to be about 2 percent complete. This game is turning out to be more work than fun.
Also have this issue. Tried restarting desktop client. I have no antivirus programs so that can't be it either. Firewall is turned off.
Yeah the patch server is sucking some mad D.
My Wife had the issue 'the game is running and requires a patch' and it just wouldn't do it.
She restarted battle.net a few times, we did the ipconfig/flush/register/renew/etc..
And then I altered her internet options to uncheck ssl3 and check ssl2 (windows7)
Suddenly it started to work for her. Dunno why, or if any of that actually did anything, or if it was just luck.
I have now re-installed Battle.net for the second time in two days. After shutting down during installation I am now stuck between entering my password and being able to use my authenticator. I have been looking through the forums and I am alarmed that Blizzard thinks this is an isolated problem. The solutions I have seen in the blue posts indicate that we should manipulate different files on our computers, but with the number of people having problems this is obviously something that Blizzard broke. Yesterday there was supposedly a problem with the authentication servers, but I did not see anything indicating it was fixed. Despite this seemingly unresolved problem you still release a patch? This is day two of not being able to log on yet Blizzard is still taking my money. Please fix the problems soon.
i found this solution on redit to the OP....go into your task manager and end task on the b.net update agent. restart b.net client. and it should start downloading the patch. i too had the problem of it letting me launch the game and saying i needed to download a patch.
tried that over ten times. The task manager would let me stop the update agent or the client. I have delete wow and battle.net to start over, but now I can't download the client. <sigh>
sorry moon. i wasnt having the same issues as you i guess. but as the OP said. i could log into the game and it would tell me patch was required. all i did was close the game. end task the update agent. restarted the client and it finally found i needed an update...
1) Force quit the bnet app
2) Leave it closed
3) Find your wow install directory and run wow.exe or wow-64.exe and let it show you that error(may take up to 5 mins as it did for me to pop up)
4) Restart the bnet app and it should detect a patch required now

Portus advised me of this and it worked for me.... Worth giving it a try
Still cannot get on........

Join the Conversation

Return to Forum