6.1 Error suppress macro

UI and Macro
I've been using a macro for on use trinkets with some abilities that suppresses the error sounds and text if the trinket is on cooldown. I'm not certain if it stopped working with 6.1 or I just noticed it had stopped.

Can anyone offer a solution which works to do the same thing now?

It looks like:
#showtooltip Mind Blast
/script UIErrorsFrame:Hide();
/console Sound_EnableSFX 0
/use 13
/use 14
/console Sound_EnableSFX 1
/script UIErrorsFrame:Clear();
/script UIErrorsFrame:Show();
/cast Mind Blast
Something with 6.1 has messed with the /script command. None of my macros with scripts in them work anymore either. Sadly, I haven't found a solution yet.
Same problem occurring and it's annoying hearing all that macro spam. I can confirm that this started with 6.1 patch. Hope it gets fixed as it's a nice option for my macros.
Try /run

/run still works for me in macros
/run does not work for the suppression of error messages. e.g.

/run UIErrorsFrame:Clear()

Now we get to listen to the spam of "I can't do that yet - not ready". Lots of fun.
/console Sound_EnableSFX 0

is also a bit redundant, there is a checkbox in option that says "enable error speech" you can uncheck. You don't have to LISTEN to any spam. Just see the messages from UIErrorsFrame:Clear
02/26/2015 12:27 AMPosted by Omegal
/console Sound_EnableSFX 0

is also a bit redundant, there is a checkbox in option that says "enable error speech" you can uncheck. You don't have to LISTEN to any spam. Just see the messages from UIErrorsFrame:Clear

That doesn't help. I still want to hear the other error sounds, I just don't want to hear "I can't use that item yet" and "It's still recharging" every time I hit Kill Command because my trinket that's macroed into it is on cooldown.
6.1 introduced some regression here. I've had more than a few users of my addon now complaining about this.

I currently know of no workaround other than disabling error speech altogether.

Hopefully we can get a blue response on this issue.
This does the trick:

/console Sound_EnableErrorSpeech 0
02/26/2015 07:50 PMPosted by Crushtastic
This does the trick:

/console Sound_EnableErrorSpeech 0

OMG that works! Thank you :D
Thank you!
What about a fix for /script UIErrorsFrame:Hide(); and show
02/26/2015 10:03 PMPosted by Palonblade
What about a fix for /script UIErrorsFrame:Hide(); and show
No fix needed, they're working.
02/26/2015 07:50 PMPosted by Crushtastic
This does the trick:

/console Sound_EnableErrorSpeech 0


thank you thank you thank you!
Thank you!

I've been using the original "/console Sound_EnableSFX 0" macro for years, and couldn't quite figure out why things sounded different after the patch was released this week.
I just noticed this myself. I've been using "/console Sound_EnableSFX" for ages in my macros to suppress the error sounds.
was totally mystified what happened. lol
thank you very much for sharing the new console command =D
This worked! I can't thank you enough!!! Repetitive noises drive me bonkers :)))
This has made me groan and sigh for years now: Blizzard wrote functions specifically to do this for us in ChatFrame.lua...


-- easier method to turn on/off errors for macros
SlashCmdList["UI_ERRORS_OFF"] = function(msg)
UIErrorsFrame:UnregisterEvent("UI_ERROR_MESSAGE");
SetCVar("Sound_EnableSFX", "0");
end

SlashCmdList["UI_ERRORS_ON"] = function(msg)
UIErrorsFrame:RegisterEvent("UI_ERROR_MESSAGE");
SetCVar("Sound_EnableSFX", "1");
end


...however (this is where the groaning and sighing come in), they forgot to assign actual slash command strings to those functions.

You can add your own, fortunately. It used to be as simple as

_G.SLASH_UI_ERRORS_ON1 = "/erron" -- invent your own, don't forget the '1'
_G.SLASH_UI_ERRORS_OFF1 = "/erroff"

but then they added the hash lookups. You can still do it for commands which don't need to be secure, but I don't recall the variable names off the top of my head.
Disabling the error messages does nothing to prevent the seriously annoying sound effect that goes along with my character telling me it's not ready.

And conversely, disabling the sound effects do nothing to prevent my character telling me over and over and over AND OVER that it's not ready... yah I get it!

In the end I used a combination of both solutions offered above to stop the spam.

Tried and tested just now around my garrison, but not under all conditions. AFAIK it should work fine though.
========================
/console Sound_EnableSFX 0
/console Sound_EnableErrorSpeech 0
...
INSERT YOUR ABILITY STUFF HERE
/USE BLAH BLAH BLAH
...
/script UIErrorsFrame:Clear()
/console Sound_EnableSFX 1
/console Sound_EnableErrorSpeech 1

Join the Conversation

Return to Forum