Game won't load!

Mac Technical Support
My World of Warcraft game won't load! I just upgraded to a 30 day account for the original game and it has been working perfectly! But today, I log on and I get to my player (I've only got one character) and click Enter World (to Darrowmere) and on the screen that shows the loading bar that fills up, it freezes when the bar has about an inch left to load. I've tried logging in three times already and it hasn't worked, resulting in me needing to reboot my computer.

Please help!
Thank you!

P.S. I'm on a Mac if that helps at all.
Drag your WTF , Interface and Cache to the desktop.

If this fixes it it's possibly something in your WTF folder. Go in there and there will be a folder for you toon. Go in there and wipe SavedVariables files and folders and the cache.md5 file.
ok i cant get into my game either
it was running very glitchy for ages but now i get the updating launcher.... then updating updater box pop up.
up until recently i could get past that by opening the game directly and not using the launcher.
it has severely curtailed my playing as when i get into a fight i drop to 1 or 2 fps
thought it was the comp but no.
what ever happened to the repair install app in the root directory.
cant even do that to see if i have corrupt files on my last download.
getting very frustrating.
If you're bypassing the launcher, then this is why the game won''t load. Patch, launcher updates and etc are needed to be installed to run properly.

This seems like a different root cause, and different from what Elestaria posted. Let's create a new thread to better assist you and not mix solutions since they are different.
I open the Launcher. It says it is loading information for an upcoming patch, but the play button is red and on. When I hit "play" the launcher disappears, there is a spining icon indicating loading, then the launcher reapears. It won't enter the game, even to ask me for my password. What's up?
Are you on a Mac or Windows?
I just bought WOW after trying the free trial and I've had to create a new character. I've tried entering the world about ten times and the last bit of the loading bar will not go no matter how long I wait. I've tried uninstalling and reinstalling but it's still doing the same thing.

Please help, so desperate!

Also, I'm on a Windows
Hi Kalandri, if you still can't log on after today's maintenance is over at 11 am Pacific time, try these steps, and see if they help:

1) Remove the Interface, Cache, and WTF folders from the World of Warcraft folder.
2) Reset your connection to clear any residual connections and cache.

I'm going to lock this thread because it was started in 2010.

Can you create a new thread in this Technical Support forum? Thanks!

Rate me!

"One of the more unique traits of the Overlords is the ability to liquefy their own internal organs to produce creep..."

Join the Conversation

Return to Forum