Playsoundfile and Playsound dont work

UI and Macro
hello this has been discussed before but playsoundfile and playmusic dont work and im trying to figure out why is it because of a path change and if so does anyone know what the proper path is and how to get it to work again if anyone knows anything please reply
Demonicow,

Where are you placing the soundfile you want to use and what are you typing in-game to do it?

______________________________________________________________
I'm available in the forums Monday - Friday 6:30 am - 3:30 pm Pacific Time,
Feedback? - https://www.surveymonkey.com/s/Omrakos
05/13/2015 09:29 PMPosted by Demonicow
playsoundfile and playmusic dont work and im trying to figure out why is it because of a path change and if so does anyone know what the proper path is and how to get it to work again if anyone knows anything


I just tested them on two characters. They both worked for me. I used a macro to test both.

For PlaySoundFile:

/script PlaySoundFile("Interface\\Addons\\myMusic\\mp3\\test.mp3")

And for PlayMusic:

/script PlayMusic("Interface\\Addons\\myMusic\\mp3\\test.mp3")

Keep in mind that they do operate differently. PlayMusic plays the file as music so it halts the default game music and plays the file instead. PlayMusic will still have the game fighting sounds, etc but the music will be stopped to play the file instead.

PlaySoundFile however, plays the file as a sound channel (think of a combat spell cast sound). If you play the file using PlaySoundFile and press the macro to play the file 3 times, then you end up with the Blizzard game music playing as well as 3 copies of the sound file.

Might I suggest having a look at www.wowwiki.com/API_PlayMusic for api help if not already visited?
He might be talking more about why doesn't the sound files in game trigger anymore.
Pre 6.1 I used #showtooltip
/cast Rocket Jump(Racial)
/script PlaySoundFile("Sound\\Creature\\Rotface\\IC_Rotface_Aggro01.wav", "DIALOG")
for Rocket Jump. Makes the "Wheee!" sound when using the skill. Now it just uses the skill no sound gets played.
05/14/2015 10:01 AMPosted by Sadsas
He might be talking more about why doesn't the sound files in game trigger anymore.
Pre 6.1 I used #showtooltip
/cast Rocket Jump(Racial)
/script PlaySoundFile("Sound\\Creature\\Rotface\\IC_Rotface_Aggro01.wav", "DIALOG")
for Rocket Jump. Makes the "Wheee!" sound when using the skill. Now it just uses the skill no sound gets played.

His problem, that I just fixed in his other thread, is the same as the one here. You're using "wav" when you should be using "ogg".
05/14/2015 10:11 AMPosted by Rubyheart
His problem, that I just fixed in his other thread, is the same as the one here. You're using "wav" when you should be using "ogg".


*internets*

Here, take it. You won it fair and square!
05/14/2015 07:16 AMPosted by Omrakos
Where are you placing the soundfile you want to use and what are you typing in-game to do it?


Are we allowed to change sound files from game?

The "alert" used by dbm and bigwigs is obnoxiously loud - especially relative to the rest of the sounds in game.
03/08/2018 07:10 AMPosted by Narwas
The "alert" used by dbm and bigwigs is obnoxiously loud - especially relative to the rest of the sounds in game.

You can configure which sound they use and also switch the sound channel they use. By default they run off the Master channel which can be louder than others.

Join the Conversation

Return to Forum