Problems with mouseover

UI and Macro
Hello, I seem to be having a problem with my mouseover Ice Lance macro that I've been using since BC for shatter combos. The mouseover part of my macro isn't casting at the target that my mouse cursor is hovering over, but is instead casting on my target as if I was using no macro, and whenever I have no target and try to mouseover Ice Lance a target, I get a no target error.

Here's the macro. I've changed nothing in over 3.5 years yet now it's not working for some reason and I've even tried other variations but none of them work either.

#showtooltip Ice Lance
/cast [target=mouseover,harm] Ice Lance; Ice Lance

As I said before, I've been using this macro since early BC and it's always worked up until now, and I looked around the forums to see if anyone else has been experiencing the same problem but could not find any.

If someone could help me solve this, I would greatly appreciate it.
Nevermind, I'm a complete idiot that had regular Ice Lance bound... Disregard this post until I can figure out how to delete it.

Join the Conversation

Return to Forum