"Play" button on launcher won't start WoW

Technical Support
Same for me. I have done everything that the forums have said to do. I can't even open from wow.exe. Please give us a Blue post.
Same problem here. Running Win 7 64 bit, something is not allowing access to the start up of the program, it worked fine yesturday after i patched, then today "Blam" no work.
Same problem and its all i got 5pc's next to me NONE OF THEM WILL OPEN WOW Called my brother same problem GF on her laptop SAME PROBLEM I reinstalled wow on the next pc STILL WONT OPEN! System reseort to 3days ago Still WONT OPEN!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
I got the same problem, after i clikc play on the news page that redirects you to deathwing gripping onto the building the page never loads and i cant even get to the news page again unless i restart computer and it still wont work...
Mine works using the file but no with the settings I set and I still want to use the launcher
I have the same exact problem ill try doing what you guys do to see if i can openmy login screen
I have the same problem i can only start my launcher after i restart my computer then i click the play button and it acts like its starting up WoW but it never comes up. I tired launching it from the folder and nothing happens the launcher doesnt even come up
nvm wow just worked from the folder
There are various problems for me concerning the launcher not starting WoW. Since 4.2, The fastest times I can load WoW are when my computer is fully restarted now. Just now after having not restarted I was unable to run the Launcher.exe at all. When running Repair it told me the Launcher was still open. So, I opened task manager and killed the Launcher.exe task. I then was able to open the Launcher.exe just fine. Now I hit Play and it takes 5 minutes to just give me a WoW icon in the task tray (5 minutes just to get to the black load screen for login that is).

Not sure what is causing this issue, happened for me during PTR 4.2 as well.
EDIT2: During the PTR I was never able to get on because Launcher would fail to update. Norton always spammed me with removal messages during updates and I'd never be able to do anything WoW PTR related until I rebooted and tried the launcher again. So I would disable Norton while ever patching during PTR. I figured this same issue would pop up again during Live 4.2, but I forgot to disable Norton then. Norton didn't tell me it removed anything, but it must have done it in stealth.
After patching this morning, the launcher will not load WoW. The launcher just disappears and nothing happens. In the task manager, launcher.exe is still there and I can end the process, but that does no good. I can go in and launch wow.exe manually though and it works great. Something is bugged with the launcher.
having the same issues, nothing happens after hitting play button on launcher, but game loads fine if i launch from the WoW folder clicking the game.exe
I have the same issue, i hit play and you see the wow screen for a split second then it disapears.
I've posted this in a couple other threads, but when I click Play the Launcher will close itself but WoW never opens afterwards.

By going to the Task Manager (Ctrl-Alt-Del) I manually close Launcher.EXE and repeat a MINIMUM of 5 times. Sometimes it's 10+ before WoW actually opens.

The checkmark on the Login screen, "Show Launcher," does not have an effect regardless of whether or not I have it on.

Also, the repair tool can be used by also ending Launcher.EXE WHILE the Launcher is open and right BEFORE I run it. It says there are no problems in my installation folder.
WHen I try to start the game through the launcher, nothing happens. I open the process manager and Launcher.exe is still showing, but no Wow.exe. No error messages pop up or anything either.

It seems to run fine when I run Wow.exe directly. Just the launcher doesn't want to cooperate for some reason.

It worked from the launcher once, right after the patch. But after I closed that session, it hasn't worked.
Also happening to me as well as my guildies. We just clicked on the wow.exe to open wow. Suspect this is a widespread issue. Worked fine yesterday evening, today not at all.
I'm having the exact same issue. Was working fine after the patch yesterday(and for 5 years before that) but not today.
I might as well throw in my two cents...

I hit the WoW shortcut....Launcher might show up, it depends on how it feels at the time. When it does I hit play ( It's not grey ) and then the game never shows. I've tried to use the Repair tool but it just says nothing is wrong. Also I was able to get it to run through the WoW.exe but now I figured it would be a better idea to drag the .exe folder to my desktop so I didn't have to go hunt down the folder every time I wanted to play.

Turns out doing that I must've done something because now the ERROR #132 Fatal exception, error pops up every time i try to go back and access the .exe folder.

I really don't know why this is only happening with 4.2 for me, you guys must have stepped on someone's toes for this problem to interfere with something on our computers.

Edit: I also ran the Repair Tool after i discovered the 132 error, said nothing was wrong...

Edit 2: I was just able to get WoW to open from the launcher, after my 10th run of ending the launcher and re-opening through task manager...I really hope this gets resolved either by Blizz or they find out how they can help us fix it...bad publicity for the game if this keeps up...
Yeah, i can't do a thing. And it pisses me off because it won't load at all. There is no way that the login screen will appear. I've tried restarting my computer, but it does nothing. I will open the launcher, click "play" and nothing will happen. Nothing even appears on my task manager.
Same issue here with the launcher. Although luckily I can still load WoW by clicking in the WoW folder.

Join the Conversation

Return to Forum