"Play" button on launcher won't start WoW

Technical Support
work now. need to skip launcher and use wow.exe. If it said no permission, u gotta add permission to ur user name by property=>security=>add...
^ my wow.exe wont work either, its set to the only user on the pc. seems to be a slight patching error that shuts down the game once its run or something, since blue havent posted here again i assume they're looking into it :L
My wow aint working even if i do the wow.exe it just exxits out right when i clik play
how did u fix it?
mine won't work either, not even through wow.exe, also i did repair and i got a new folder called launcher.patch... which does the exact same thing as the regular launcher does, get to about 5 percent on updating tools then crashes.. weird
same with me
For the Updating tools when it gets stuck on like 5%. I put my computer into Safe Mode Networking. When i opened wow it downloaded right up. But was still not able to start wow through the Play button or WoW.exe.
Launcher is downloading updated tools and at abot 5% it dissapears. When i click on WoW.exe it dosent come up either. PLEASE HELP BLIZZARD! these people are counting on yous.
I was having the same issue, the launcher would open but when I hit the Play button, nothing would happen. Wow.exe. did not work either. I'm running Windows XP, everything is up to date. The Launcher.exe would show up in the task manager box but nothing would be happening visibly. I read through the forums and tried several of the options, including removing & reistallation but nothing has worked.

I came back to the game for a month to see what was new and have since cancelled my subscription again, since I can't actually play the game that was paid for, and this is just getting too annoying. It's frustrating to pay for something that isn't functioning.

I will note for people trying to fix this still, this happened to me previously with the game (last patch, hence why I'm cancelling, why pay for a monthly sub that doesn't run a full month?) and I fixed the problem last time as follows:
Under Network Places, under View Network Connections, right click on your connection, select Properties, click Advanced tab at the top, click Settings, and click Exceptions. Make sure that Blizzard Launcher is checked. With the last patch I had the same problem and fixed it this way. However with this patch when I go under Exceptions, instead of seeing one Blizzard Launcher box (which was checked), I see five and all are checked. This time it didn't fix the problem, and I don't feel like wasting more time on figuring it out. No idea if that info is helpful at all.. but eh. Interestingly, there are also eight Blizzard Downloader boxes all checked as well.

Good luck everyone, I hope you can play soon.
Welp...like most in this thread...Can no longer run WoW.

Started day after patch...launcher would not work. Went to Wow.exe and worked for 2 days. Now this morning..no go.

Even my dang Mobil AH not working! WTF over. haha bah! Blue...what is the fix here?
Same with me too, i can load the the start up screen but my Play button is usless.... its kinda of a bumer... if anyone knows why this is happening Please leave a message on here.
i was able to play by downloading a 10day trail and loggin in thru the screen there tell me if that works
I'm having the same problem dont know how to fix it anyone have any suggestions? Its been like this for two days now was able to play then i couldnt the next morning.
Blizzard needs to fix this..
@Basscannon This is exactly what's happening to me... I have been locked out of WoW for about 3 days and its super frustrating...
What is going on with this launcher problem? I have it as well, and I keep checking back every day to see if there's any new info from Blizz, but it just seems like there's more and more people complaining about it. I can launch the game from the executable, but I would like to have it launch from the launcher window. What exactly is the problem?
Running the Wow.exe file from the World of Warcraft folder works for me. Try that out?
Got same problem.. Can't get wow from launcher and after hit play button the launcher still running and can see it from windows task manager on processes menu, but it seem only in windows 7 64-bit.. I try in windows 7 32-bit and it works fine, no problem at all..

Join the Conversation

Return to Forum